ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-07-2013, 05:07 PM   #11
Dirty in all
Adrenaline Junkie
 
Dirty in all's Avatar
 
Joined: Apr 2012
Location: Connecticut
Oddometer: 168
Quote:
Originally Posted by Vico1 View Post
I am not sure why, maybe I am not demanding enough, but I love my 5 hunny and I have had ZERO issues after desmog replacing 10M filter and installing JD turner. Starts perfectly, runs strong and very crisp. I came off a well set up 530 and there is no comparrison. This bike is wicked!

However, I live in Florida so super cold is not a problen nor is elevation nor for that matter water. I just do normal maintenance and ride the shit out of it...

If you are thinking about a 5hunny as your new ride you will not be disappointed. IMHO.
I agree 100%. Same exact set up but I did/do tweak the JD Tuner. I have mine mounted up on the frame close to the headlight so I can adjust it while riding. I deal with altitude from 0 - 500ft or so and temps from 10 - 95F. There's a small hiccup that shows its face once every few months so it does require a bump up or down, mostly in the mid range. Recently I put a supermoto setup on it and the bike is a screamer. I have an Aprilia SXV 550 that is also supermoto setup and sees alot of dirt roads and the occaisional trail. On the pavement I swear the EXC is faster and it does it with less violence, if youve been on an SXV then you know what I mean. The EXC surpases it hands down in all other areas. Ive been on WR250s, Husky 610s, DRZ 400s, KTM 690s and I wouldnt trade the EXC for any of them. In dirt trim is where the EXC really shines. The bike has made me a better rider in every way and the confidence it inspires for me is unmatched by any bike or time in my life with the bikes Ive owned and been on. I was getting a lot of flame outs in the begining when the bike was only desmogged and I found that just bumping the idle up a click at a time until it went away was good enough. Im also a very clutchy rider, I dont mind using it and Im very mindful of it so maybe thats part of my fix or lessened issue with it. Since the tuner Ive not had a flame out, the bike lugs in low rpm very well.
Dirty in all is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:38 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014