ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-14-2013, 10:37 AM   #1
Hisbikes OP
n00b
 
Joined: Feb 2013
Oddometer: 2
05 950 Adv clutch drag

I hate flogging a dead horse and there's heaps of info but I need to get a clear answer of what to do. I just bought a 05 950 done 45K km's and still under dealer warranty. I've returned the bike 3 times now to the KTM dealer and even had the Australasia KTM technical lead work on the bike and this issue seems to persist. They have removed the clutch, inspected, found no issues or wear, oil jet cleaned and checked. Replaced o-rings in the slave cylinder, flushed fluid replaced with the correct Motorex mineral stuff. With the bike cold and idling clutch engaged, the throttle is blipped the bike runs forward, after about an hours of riding it seems to improve but still slight movement when this is done and gearbox seems to be a bit chunky when gearing down.
Hisbikes is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:33 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014