ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-02-2010, 11:23 PM   #211
the_wes
Adventurer
 
the_wes's Avatar
 
Joined: Aug 2008
Location: Cape Town, South Africa
Oddometer: 91
Quote:
Originally Posted by Hoder
There have been no changes (that I'm aware of) since the initial release. What's your biggest worry?
hmm, let's see - flaring, fit, leaky petcocks, etc. basically everything I've read here

however, I did go ahead and order one and so far I'm happy. It arrived on Friday, and was fitted on Friday in a hurry (left for an overnighter Saturday 6am and needed the range). It arrived without instructions, which bummed me out, since I am mechanically retarded, but with some googling and advrider-ing, I figured it out (someone had posted a link to the Halls hose routing on the SM 610 which was a great help)

over-zealousness led to me crushing the 2 brass coloured "filter tubes" (have no idea what they are called) on the front 2 petcocks - I didn't care though and left them in - crushed. So far (about 750km later) no hassles. drilling the hole for the main petcock was a biatch, as I didn't have a big enough drill bit, so I ended up filing it and forcing it the last bit.

My hose routing could be better (well the routing is fine, I just need to shorted some hoses) but it worked for the trip. Can't remember exactly what range I got, I think it was 265km or 285km - I usually get about 15km/l though (shocking). Haven't yet filled the tank from empty, so not sure how much it will take - but when I ran dry there was still some fuel in the "lobes" - any idea how to get past that?

Had no issues lining the tank up, BUT I did notice that the gaps between the lobes and the radiator on either side are not the same size.

Will now look at installing better petcocks for the front, new hoses, brass T-connectors and possibly an external fuel filter, though not sure if it's neccessary. I also want to move the overflow. it's in a stoopid place and I kept overfilling the dang tank to try get that "extra bit"... I need to lengthen the side stand as well...

I opted for clear - fuel level visibility being 1 reason, and "that aftermarket look" being the other (I am such a poser, I know). I also ordered IMS tank foam, but haven't installed it yet.

Ordered everything from justgastanks.com - thanks guys!





1 things for sure - the bike looks 4 x meaner with the tank on
the_wes is offline   Reply With Quote
Old 08-31-2010, 05:59 AM   #212
the_wes
Adventurer
 
the_wes's Avatar
 
Joined: Aug 2008
Location: Cape Town, South Africa
Oddometer: 91
Let's drag up an old thread now shall we... after running the IMS tank for a very short while, I experienced leaky petcocks as is common. The tank came off immediately and sat in the corner of my garage pending a better solution for installation.

A few weeks back I decided to get my ass into gear and get it done.

For starters, in the process of getting the old tank off I busted the main petcock, like so...



say it with me: eeee-deee-ot!

In the process of doing that I also ripped out the sensor wires, leaving a tiny hole in the "putty" on the outside of the petcock. I started by chipping it away, which revealed a bigger hole (making it easier to plug). Chipped, filed, cleaned with benzine and Pratley Steel repaired:



Then I just screwed the filter part back in without the brass sensor pipe.

For the front petcocks, I sourced some rubber bushes:



Off I went to my favourite workshop, where a team consisting of the usual Saturday morning regular "hang out" peeps helped me get it all together. We started by drilling and tapping the holes with Adrian's help. Perry had brought along some "stag paste" (I dunno what it is, but it works, what can I say he's a plumber) and had the bright idea to chuck a couple of O-rings on.

We tapped, pasted, sank the bushes, and tightened them up. We then teflon-taped the threads of the petcocks and threaded them in just right for tightness and positioning.





Then it was home to mount and plumb the tank... I added a small transparent in-line fuel filter, as the filters on the 2 IMS petcocks broke ages ago - it's there on the left next to the airbox hiding away...





I had some super-thick heat resistant multi-fuel hydraulic chuck norris quality hose that I got from a local hydraulics place, but that was the wrong inner diameter to use - so I cut a section of it, "filleted" it open and wrapped it gently with 2 cable ties around the bit that I was worried about with heat (A). Now my only concern is the kink at (B) - will try route that bit better.



and THEN only I cleaned it



I also finally put the tank foam in and went for a long day ride. I can't say I feel the difference - yet - I'll have to take a spin in some sandy trails and report back!





So far the tank is holding up well, but I want to fabricate little "petcock protectors" for those 2 frontal petcocks... they look vunerable to falls and rocky roost!

Still think the bike looks the business with the tank on



the_wes is offline   Reply With Quote
Old 03-11-2013, 12:47 PM   #213
cassos
n00b
 
cassos's Avatar
 
Joined: Feb 2007
Location: Los Altos, CA
Oddometer: 2
Hi folks,

This is a two years old thread, same questions again :-)


I am in the process of converting my 06 610 from SM to TE.
I bought a set of wheels, front brake, set of plastics, and an IMS tank from
Dan at Motoxotica.
I started to work on it.

I did not realize the IMS tank has two extra fuel petcocks at the front lower left and right:

That raised a few questions.

1- IMS provided the petcocks that need to be mounted with teflon directly on the tank's platstic. I hope these will not cross-thread. Also they did not drill the hole big enough for the tiny filters to go in. I don't want to messup the inside with plastic cuts when resizing, any advice?

2- Can someone post recent pictures of the fuel connections between the 4 petcocks and the curburator.

3- Any extra ventilation needed for the tank?

Thanks, Christian.
cassos is offline   Reply With Quote
Old 03-11-2013, 01:05 PM   #214
ebrew
Motorcycle A.D.D.
 
ebrew's Avatar
 
Joined: Nov 2005
Location: Denver colo
Oddometer: 1,226
On sent

Sir
ebrew is online now   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:31 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014