ADVrider

Go Back   ADVrider > Bikes > Road warriors
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-19-2013, 12:58 PM   #18
grelcar
Adventurer
 
grelcar's Avatar
 
Joined: Apr 2012
Location: SE VA
Oddometer: 92
Quote:
Originally Posted by NonDairyCreamer View Post
A question for any Road King owner, present or past.

I once owned a '92 FLHS, Electra Glide Sport Moco called it, Road King now. When cruising interstates, usually 80-85, I had the slightest bit of vibration in the front end which I thought was the wind pushing the windshield. It was very subtle. Is this something anyone has noticed on later models?

Also the motor vibration had my feet always slowly sliding off the floorboards, I always wanted to find some of the boot scrapers found on bikes from many years past to mount, like stirrups.

A great bike for exploring and touring though. I wonder now if a fork damper or just tightening up the yoke bearings would fix the first problem. Maybe for the other issue some boot magnets?
I have never noticed any vibration with my Road king other than at idle. I often cruise at 75-85 on the interstate. No vibration or buzzing in the footboards, seat or in the handlebars. I recently installed Progressive monotubes in the front forks that firmed up the front end eliminating nose dive issues, bottoming out and some noises I was getting in the front end.
grelcar is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:22 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014