ADVrider

Go Back   ADVrider > Bikes > Battle scooters
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-19-2013, 11:05 PM   #14
ParrotheadJeff OP
Cultural Infidel
 
ParrotheadJeff's Avatar
 
Joined: Mar 2011
Location: Margaritaville, UT
Oddometer: 1,232
Quote:
Originally Posted by fullmetalscooter View Post
gald it runs so far.
Thanks

OK, time for another minor update. Remember how that battery was dead? I tried adding distilled water and setting it on charge, but that didn't get too much of a charge. I went ahead and drained out the water and replaced it with fresh battery acid before leaving it on the charger overnight. I took it off charge this morning, rinsed the outside off (there was still a little bit of acid on it in places), and left it until this evening. I hooked the battery up to the leads on the scooter and something awesome happened...

IT WORKED

New battery acid was only $5 or so where a new battery would've been $60

My next order of business will be getting another key cut, getting the vacuum & fuel lines, and getting the oil changed. I'll also have to order up the new valve stems and petcock. It won't be too long at all until it's on the road
__________________
Just show me the way to the bar and a nomad who knows
- Jimmy Buffett
ParrotheadJeff is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:22 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014