ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-22-2013, 06:50 AM   #11
tundra61
I wish I had a title
 
tundra61's Avatar
 
Joined: Nov 2008
Location: There
Oddometer: 997
I have a starter question I was hoping you guys migt be able to help with.

Sometimes when I hit the starter button nothing happens. Nothing as in absolutely nothing. No clicking, engine turnover etc etc. Usually, if I hit it a few more times the bike fires up as expected - but obviously something is wrong.

I haven't been stuck with the bike due to this - but given that there is no kick starter I want to stay a step ahead on addressing this.

So, have any of you had a similar problem and if so how have you addressed it?

I already took the handlebar starter appart in an effort to clean it - but all the internals lool to be - well - internal - so there was really nothing accesible to clean.
__________________
Lots but currently:
2012 BMW GSA
2012 KTM 350 XCF-W
tundra61 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:49 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014