ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-06-2013, 07:46 AM   #1
5 speed OP
Studly Adventurer
 
Joined: Sep 2006
Location: Orlando Florida
Oddometer: 852
05 950 Adv- lost my clutch while riding-need some help

Beautiful day in Florida, and unseasonably cold this morning. Fully suited up, new helmet this week for my birthday(unfortunately a street helmet but still too much wind noise). Riding and enjoying the scenery and I noticed that the clutch engagement point was really close to the grip and the lever seemed spongy. I was headed toward home and realized it was getting worse and worse. Last 10 miles I had no clutch and was in town. If I could find neutral at the light fine, otherwise it just cut off. What a PITA.

So, does this sound like the clutch slave? How can I check and what is the preferred replacement?


I have 16K miles on it and i guess its getting to that age; far as I know its original and believe it has the original water pump and fuel pump too. scary to think about those going out.
5 speed is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:55 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014