ADVrider

Go Back   ADVrider > Bikes > Old's Cool > 2 smokers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-10-2013, 02:22 PM   #1
sam2 OP
Adventurer
 
Joined: Jun 2012
Oddometer: 31
82 Husky 430 won't start

So last time I rode the bike, it stalled out down the street from my house (on my way back in) after a short ride. I tried to restart it, it then backfired about as loud as a rifle out the exhaust, shooting the silencer end cap and spark arrestor across the street and blowing the silencer packing halfway out. I removed the mangled packing, replaced the cap, and it will not start. I know i should replace the packing, but it should fire up without it, right? tried all of the usual tricks, but every time i just keep kicking and nothing. I replaced the plug and it has spark. its getting fuel and the compression is unchanged. the most I have gotten while attempting to start it has been a mild backfire out the exhaust. and I'm confused. Any suggestions?
sam2 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:10 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014