ADVrider

Go Back   ADVrider > Bikes > Beasts
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-22-2013, 07:32 AM   #9
CafeRacer99
Gnarly Adventurer
 
Joined: Apr 2012
Location: Las Vegas
Oddometer: 372
Quote:
Originally Posted by tremor38 View Post
I get some water in that area after a wash but not much. I don't understand why you chose not to use the factory grip wiring though.

Sent from my SC-03E using Tapatalk 2
I went with the Oxford heated grips. I'm not entirely happy with them because they are a little short, but other than that they work fine.

I didn't use the Yamaha grip wiring because I wanted to leave it intact. Just in case I decide to change grips someday, or sell the bike and the next guy wants to. Isn't rule one of farkleing "First, do no harm"? lol.

Plus, I had the heated jacket liner to hook up and I'm sure other stuff down the road, so I was going to do the fuse block anyway.
__________________
Ride to Coffee
Coffee to Ride
CafeRacer99 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:02 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014