ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-12-2013, 07:17 AM   #1
COracer OP
Adventurer
 
COracer's Avatar
 
Joined: Jan 2011
Location: Co Lo Rado
Oddometer: 58
690 Going on it's first voyage, what is NECESSARY to do?

Taking my 690 for it's first long voyage over Memorial Day to Moab, read through all the threads here and came up with a few main issues. Which of these do you all with experience think have to be addressed before I go?

Tank bolts- yes I read up and know these are a major issue, problem is they are back ordered everywhere for weeks. Should I buy an extra stock set as spares? Anyone have an extra set of the RR ones they would be willing to sell?

Fuel pump- bike has 1700 miles on it, runs perfect. No issues with starting or bogging. Is it worth pulling it out and cleaning the filter? How necessary is a spare? Am I ok just running some fuel treatment like some have?

Anything I am missing? Would like to make it there and back with no issues...
__________________
"I have discovered that even the mediocre can have adventures and even the fearful can achieve" - Edmund Hillary

KTM 690R Yamaha YZ450 sumo
COracer is offline   Reply With Quote
Old 05-12-2013, 07:31 AM   #2
wiswoodsguy
Kmart shopper
 
wiswoodsguy's Avatar
 
Joined: Apr 2012
Location: Northwoods of WI
Oddometer: 1,724
Re-read the entire megathread and repair EVERTHING listed

I would check the filter, check all the grounds, check the wiring for possible rub thru's

Just have the knowledge and a few tools to fix some minor issues and you will be fine
wiswoodsguy is online now   Reply With Quote
Old 05-12-2013, 08:02 AM   #3
COracer OP
Adventurer
 
COracer's Avatar
 
Joined: Jan 2011
Location: Co Lo Rado
Oddometer: 58
Yeah, the megathread is out of control. By the time I read 20 pages I forget what I read...just trying to catch the cliffs notes version
__________________
"I have discovered that even the mediocre can have adventures and even the fearful can achieve" - Edmund Hillary

KTM 690R Yamaha YZ450 sumo
COracer is offline   Reply With Quote
Old 05-13-2013, 02:42 AM   #4
francs
Gnarly Adventurer
 
Joined: Jul 2008
Location: Ljubljana Slovenija
Oddometer: 242
You have 1700 miles (3000km) on the bike?
Just take out bolts from radiator guard and ziptied it, and ride.
Something might go wrong but possibilities it's so little...
francs is offline   Reply With Quote
Old 05-13-2013, 05:32 AM   #5
Albie
Kool Aid poisoner
 
Albie's Avatar
 
Joined: Mar 2004
Location: NWA
Oddometer: 9,034
Just go through the wiki; http://ktm690.info/index.php/690_Hall_of_Wisdom
__________________
Good. Bad. I'm the guy with the gun.

Another day, another foot injury!
Albie is online now   Reply With Quote
Old 05-13-2013, 06:04 AM   #6
BygDaddee
Where do I get a pie
 
BygDaddee's Avatar
 
Joined: Oct 2012
Location: Brisbane Northside, OZ
Oddometer: 1,484
Just ride it and forget about all the hype.

Unless you've had dirty fuel the fuel filter will be fine, clean it at 5000 or 10000km when its serviced.

Unless there's play in the tank bolts forget about them until either there is, or you've got it apart for a service.

Quote:
Originally Posted by COracer View Post
Taking my 690 for it's first long voyage over Memorial Day to Moab, read through all the threads here and came up with a few main issues. Which of these do you all with experience think have to be addressed before I go?

Tank bolts- yes I read up and know these are a major issue, problem is they are back ordered everywhere for weeks. Should I buy an extra stock set as spares? Anyone have an extra set of the RR ones they would be willing to sell?

Fuel pump- bike has 1700 miles on it, runs perfect. No issues with starting or bogging. Is it worth pulling it out and cleaning the filter? How necessary is a spare? Am I ok just running some fuel treatment like some have?

Anything I am missing? Would like to make it there and back with no issues...
__________________
Relax and enjoy the journey, not just the destination.
2013 WR450F(The best bike KTM never built) and BMW G650GS Sertao (The refined mans DR)
Pauls Spot Tracker http://share.findmespot.com/shared/f...mgxmQRRUCqrKiY
BygDaddee is online now   Reply With Quote
Old 05-13-2013, 09:52 AM   #7
Maurizio
2 smoker
 
Maurizio's Avatar
 
Joined: May 2003
Location: Turin, Italy
Oddometer: 162
I would put fuel in the tank, wear the appropriate gear and an helmet, and go...
__________________
maurizio
'14 250 EXC E "Sparkling Orange"
'08 FLHCTUSE3 - '76 CB 750 F ss
sold: '03 950 adv s, '05 450 exc, '08 690 e
Maurizio is offline   Reply With Quote
Old 05-13-2013, 01:36 PM   #8
wsmc831
Studly Adventurer
 
wsmc831's Avatar
 
Joined: Jan 2006
Location: Central Oregon
Oddometer: 648
I did the tank bolts in the 4 days I had between buying and taking on a 1200 mile OBCDR ride. they are a slightly better design, but as long as you don't let the stock ones get loose to let in some slop, they are fine.

At 1700 miles your filter should be fine. You may want to take along some filter skins if you are using the evo airbox lid.

three of us went on the trip, the oldest being an 08 with 10k miles and original fuel filter, none of us had a single problem.


oh, change the seat and put in super heavy duty tubes.........
__________________
97 TL1000S
2010 690 EnduroR
2013 500 Exc
wsmc831 is offline   Reply With Quote
Old 05-18-2013, 04:54 PM   #9
COracer OP
Adventurer
 
COracer's Avatar
 
Joined: Jan 2011
Location: Co Lo Rado
Oddometer: 58
Help!

Ok so clearly I cursed myself....took a couple rides and all was well, then the other day I go out and it stalls, then stalls again....now it won't idle for more than a minute without stalling and is running rough and surging.

I leave for Moab Friday...well if the bike runs. Here is what I have done so far:

-New battery, original was close to going, figured this might be an easy fix of low voltage, no such luck still not running right.
-Did TPS calibration (key on throttle up then down and off)
-Checked electrical connections to fuel pump, no issues I could find
-Pulled pump, filter isn't black but isn't clean either even with only 1700 miles so I will be replacing this as well with the Napa version
-Ordered CA cycleworks pump to install as a last ditch effort

It has an FMF can on it, thinking of trying the stock one again to see if it makes any difference. Other than that I am at my wits end and if I can't get this worked out I will have to cancel the trip

Anyone local have any expertise in fixing these 690 stalling issues or installing the CA Cycleworks pump? Anyone that can check for codes or upload maps? More than willing to pay in good beer...
__________________
"I have discovered that even the mediocre can have adventures and even the fearful can achieve" - Edmund Hillary

KTM 690R Yamaha YZ450 sumo
COracer is offline   Reply With Quote
Old 05-18-2013, 05:11 PM   #10
skypig69
n00b
 
Joined: Feb 2013
Oddometer: 9
Good luck with a timely fix.
Sorry I can't help.

Is there a small filter between the pump and the injector? I've heard of injectors that need cleaning. Is it a good idea to put automotive injector cleaner in the gas sometimes?

My low mileage '08 has just started running less than perfect (low fuel light just illuminated, like 2miles earlier so shouldn't be a factor?, flamed out for no reason when maneuvering, etc.)
skypig69 is offline   Reply With Quote
Old 05-18-2013, 05:24 PM   #11
The Letter J
lost in the 690 mega
 
The Letter J's Avatar
 
Joined: Aug 2010
Location: Santa Maria, CA
Oddometer: 829
Backflush the injector?

Pull the injector out (keeping fuel line and electrical attached) turn the ignition on and press the starter. It should spray an extremely fine mist of fuel in a cone pattern. If it does not do so, or it drips instead of sprays, (assuming you could feel the fuel line pressurize before hitting the starter) completely remove the injector and backflush it. The easiest way to do this (or at least how I have done it as instructed by a KTM mechanic) is to use compressed air. About 90psi through the nozzle will cause the injector to open and blast out any gunk that may have accumulated in the injector, back the way it came from instead of forcing it through the nozzle.

I use a small piece of fuel line (you can fill this short section of fuel line with carb cleaner if you like) attached to the nozzle with a hose clamp and the other end of the hose attached to my blow gun. If you put a paper towel on the inlet side of the injector while doing this it will catch any debris that comes out so you can inspect it. After doing this, reattach the fuel line and electrical and double check for a good spray pattern, if it is still not perfect just repeat the flushing process until all is well.

This has made my bike go from unrideable and unable to idle for more than 15 seconds, to running perfectly normal. All you have to do to access the injector is remove the seat and the airbox, so it is really easy and definitely worth a try.
__________________
I can ride my bike with no handlebars, no handlebars, no handlebars - Jamie Laurie
The Letter J is online now   Reply With Quote
Old 05-18-2013, 06:36 PM   #12
COracer OP
Adventurer
 
COracer's Avatar
 
Joined: Jan 2011
Location: Co Lo Rado
Oddometer: 58
Thanks J I will give that a try tomorrow. Have the pump out now and cleaned the screen, was some white crud on it so removed that and will see if that helps too.
__________________
"I have discovered that even the mediocre can have adventures and even the fearful can achieve" - Edmund Hillary

KTM 690R Yamaha YZ450 sumo
COracer is offline   Reply With Quote
Old 05-18-2013, 10:58 PM   #13
Assfault
Exposed Member
 
Assfault's Avatar
 
Joined: Sep 2007
Location: RockyMountains
Oddometer: 2,081
After cleaning and backblowing the injector, I am periodically running injector cleaner thru the fuel system.
I haven't had another issue with the injector plugging up since, and that was over a year ago I had issues.
__________________
* Assfault, Ass-Fault, Ms Ass, thier neighbors or friends, are not responsible for any incidents, accidents, or accusations, that might result from you using this forum in the pursuit of adventure greatness. Avoid taking ADV before bed time. Do not use if you experince faintness, dizzniess, inversness, difficulty urinating or an erection lasting longer than 4 hours. Thank you*
Assfault is offline   Reply With Quote
Old 05-19-2013, 05:29 AM   #14
skypig69
n00b
 
Joined: Feb 2013
Oddometer: 9
TLJ and Assfault
Great info.

Since I recently discovered that there is a some stuff on the Internet that wasn't Porn, I've been amazed by what I've found.

(well actually when I thought there was only Porn, I was frequently amazed, but you get the idea)

A couple of Brigstone vids, and a life long terror of tire changing - cured!

"surfing for information on line, is like quenching your thirst with a fire hose"
skypig69 is offline   Reply With Quote
Old 05-19-2013, 07:03 PM   #15
COracer OP
Adventurer
 
COracer's Avatar
 
Joined: Jan 2011
Location: Co Lo Rado
Oddometer: 58
Blew out the injector, a bunch of blackish crap came out as well as one chunk of brownish stuff that looked like resin. Bike idles and doesn't stall now, rode it for 45 miles and no issue, thanks for the tip Letter J.

Fuel filter looked pretty dirty, definitely replace that this week given the black crap in the injector. Not sure if I should install the CA Cycleworks pump or carry it as a backup, not sure I would even want to do that job outside of the garage though.

Now that it has me spooked I noticed some clacking at idle, wondering if it is the chain smacking the case a bit? Anybody else have this type of noise at idle?
__________________
"I have discovered that even the mediocre can have adventures and even the fearful can achieve" - Edmund Hillary

KTM 690R Yamaha YZ450 sumo
COracer is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:58 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014