ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-13-2013, 08:57 PM   #10
rfoll
Adventurer
 
Joined: Jun 2013
Location: St. Helens, OR
Oddometer: 35
1988 klr 250 carb issues

I suspected air leaks initially, but I have inspected everything, even the car adapter and it's O ring. All of the emissions stuff has been removed, so the vacuum port at the front of the port is capped. I put a new O ring under the pilot spring, and I replaced the broken starter cap and assembly thinking it might leak there. I suspected the worn slide of leaking too much air but the slot it fits in showed no signs of wear, likely a better material. The fact it idles well with the pilot turned all the way in tells me something odd is happening, but I have run out of ideas. I am going to pick up a complete parts bike tomorrow, and with any luck, the pilot needle will be intact and give me something for comparison. I am not a stranger to carburetors, I have been drag racing for over 35 years. But this isn't a Holley, and I don't have 3 functional spares on the shelf. I wonder if the removal of all of the factory systems has somehow unbalanced something. When I tried to run without the air cleaner, ( I think it's a unifilter) the engine ran so lean it wouldn't rev past 7000.
rfoll is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:47 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014