ADVrider

Go Back   ADVrider > Riding > Regional forums > Australia
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-15-2013, 09:53 PM   #1
Falcon Rust OP
Adventurer
 
Joined: Jun 2006
Location: Brisbane, QLD
Oddometer: 96
HELP! 640 Adventure.

Hi.
i need someone with some knowledge to help me figure out why it's so hard to start my 640 Adventure.
i have charged the battery, pulled the decompressor lever and the engine struggles to turn. I also try to kickstart it but i really can't crank it easily (noob). I have tried for 10/15 minutes ever day, an sometimes, all of a sudden, she starts. this is day in, day out.

The previous owner had an extensive service done. bike has 24,000Kms.

i am really getting quite shitty about this. when she goes she's fine, but with this issue, i am so frustrated.

Can anyone in Brisbane help me figure it out?
I am in New Farm.

Thanks,
Daniele

ps: i am happy to pay you in Beer.
Falcon Rust is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:51 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014