ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-01-2013, 04:48 AM   #1
Magnus73 OP
Adventurer
 
Magnus73's Avatar
 
Joined: Jun 2013
Location: Mora, Dalarna, Sweden
Oddometer: 18
Cry Runs poor at around 6000rpm and higher

Hello there,

I've been trying to search but couldnt come up with anything, I've just bougth a 2004 950 adventure with around 21200 km (
13173mile) on the meter so it hasnt gone far, it has had 2 owners and got all the services done.

The previous owner had a problem with it started to run poorly at around 6000rpm and higher so he had someone fix it by raise the needles a bit just before I bought it.

But now it still runs poorly at around 6000rpm for me (didn't test it a high speed when I bought it...) but it runs perfect up to around 6000, Power wheelies without problems at first gear but at around 6000rpm it begins to cough bad and at higher rpm its the same, NO backfire just cough!

I know it's hard to say what it could be, but some tips maybe? the carburators has been cleaned when he raised the needles, oil, sparkplugs are changed recently.



Edit: I can ad that it needs almost full choke, even when it's warm outside and needs it for a good amount of time!
Magnus73 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014