ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-09-2013, 05:18 PM   #1
AutoXfreak OP
Gnarly Adventurer
 
AutoXfreak's Avatar
 
Joined: Feb 2012
Location: Denver
Oddometer: 118
Clutch slave bleeding problem

Hey there OC'ers

I had to replace my clutch slave due to the stock one failing. I have installed the new Recluse unit and pre-bled the slave before installing. I am trying to back-bleed the system using the provided syringe. But no matter how hard I push, there is no fluid coming through the master. I have pushed hard enough to pop the tight fitting hose off the syringe. I have the bleeder open, at times it's just spewing out of the bleeder threads. I'm just lost... Please help!?!?

__________________
950 Adventure
AutoXfreak is offline   Reply With Quote
Old 07-09-2013, 05:48 PM   #2
Johnf3
Beastly Adventurer
 
Joined: Apr 2007
Location: West Texas
Oddometer: 1,021
Quote:
Originally Posted by AutoXfreak View Post
Hey there OC'ers

I had to replace my clutch slave due to the stock one failing. I have installed the new Recluse unit and pre-bled the slave before installing. I am trying to back-bleed the system using the provided syringe. But no matter how hard I push, there is no fluid coming through the master. I have pushed hard enough to pop the tight fitting hose off the syringe. I have the bleeder open, at times it's just spewing out of the bleeder threads. I'm just lost... Please help!?!?

The clutch lever is putting enough pressure on the master cylinder so that you can't back bleed it. Make sure the lever plunger is not contacting the master cylinder at all and you will be able to back bleed without issue.
__________________
'06 950 Adventure S
'10 Husaberg FX 450
'01 KTM 520exc
Johnf3 is offline   Reply With Quote
Old 07-09-2013, 05:57 PM   #3
crazybrit
Beastly Adventurer
 
crazybrit's Avatar
 
Joined: Mar 2006
Location: Portland, OR
Oddometer: 8,458
Quote:
Originally Posted by AutoXfreak View Post
I am trying to back-bleed the system using the provided syringe. But no matter how hard I push, there is no fluid coming through the master.
Turn the red adjusting knob on the clutch lever until fluid flows.
crazybrit is offline   Reply With Quote
Old 07-09-2013, 07:29 PM   #4
AutoXfreak OP
Gnarly Adventurer
 
AutoXfreak's Avatar
 
Joined: Feb 2012
Location: Denver
Oddometer: 118
Well. After reading a lot of threads about bleeding the slave, I had never heard of this. And sure enough, turned the adjuster on the lever and YATZEE! A huge spatter of fluid emerged and all the air has been bled! Awesome guys! Orange Crush is awesome!



Thank you!
__________________
950 Adventure
AutoXfreak is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:44 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014