ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-17-2013, 07:46 AM   #11
Reposado1800
Juicy J fan!
 
Reposado1800's Avatar
 
Joined: Dec 2006
Location: 5th and Main
Oddometer: 5,740
Quote:
Originally Posted by Kirk the Jerk View Post
So...

I replaced my air cut off with a new unit from eBay.

http://cgi.ebay.com/ws/eBayISAPI.dll...m=310701234175

The old one had several pin holes in it. The new spring was not similar in length (shorter) or shape (beehive) so I use the old spring.

I also replaced all the exhaust gaskets, which the mid pipe gasket was just falling apart...

And...I'm still getting a decent amount of decel pop, not loud, but there. I sometimes have to really listen for it with my helmet on and all.

I rode into work this morning, and the bike was running quite weird. It seems like it was misfiring at idle, and then it would idle high, like super high. I'm thinking I may have had the idle screw turned up too high to compensate for the idle, and then something *cough* pulse generator *cough* is causing the idle to drop occasionally, and allow the bike to misfire.

My idea... is the pulse generator. I have a brand new one in my parts box with side cover gasket. I think I'm gonna attack that tonight.

It also seems to just fall on its face at higher speeds. The bike takes off in 1st like I remember, leaving the front end nice and light... But in 4th or 5th, at around 60mph, giving it throttle will just bog the bike down.

Thoughts?
It is probably a fried pulse generator.
At nearly 30 years old these bikes need every electrical replaced.
I did it all in one shot. PG, CDI, coil, stator. The bike runs fantastic.
__________________
Hate gets you nowhere.
Tequila is a weapon of mass destruction.
Reposado1800 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:47 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014