ADVrider

Go Back   ADVrider > Bikes > GSpot > GS Boxers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-02-2013, 09:42 PM   #1
oz97tj OP
Studly Adventurer
 
oz97tj's Avatar
 
Joined: Mar 2012
Location: Fenton, MI
Oddometer: 814
Wethead - Euro LED signal swap

I didn't take photos of the bike apart, but here are a few photos. The rears were super easy and took maybe 10 minutes. The front was a bit more complicated. To get to the plug, you have to remove the side panels which is a pain in the butt due to all the fasteners but is fairly straightforward.

There is one problem though. The dash gives a lamp warning. I installed the lights the day before going in for my first service at the dealer with the intent of having them make the change to the computer to fix the lamp warning. Turns out BMW hasn't released the update in the software to allow this change yet. My dealer has contacted BMW about the issue and they believe it will be handled shortly. The option was available on previous bikes so should be available on this one as well, especially considering these are the Euro factory signals offered to the rest of the world.

Rear side by side...

Complete...


Front side by side...

Complete...


Other than the lamp warning, the LEDs work great. They have given me extra horsepower and better fuel economy along with making women have the uncontrollable urge to show me their bewbs. Everyone should do this mod!
__________________
'13 BMW 1200 GSW
'05 Honda ST1300

oz97tj screwed with this post 05-02-2013 at 09:51 PM
oz97tj is offline   Reply With Quote
Old 05-02-2013, 11:36 PM   #2
paulW
Gnarly Adventurer
 
Joined: Jan 2006
Location: Wirral, UK
Oddometer: 143
Quote:
Originally Posted by oz97tj View Post

Other than the lamp warning, the LEDs work great. They have given me extra horsepower and better fuel economy along with making women have the uncontrollable urge to show me their bewbs. Everyone should do this mod!
That is an interesting and little known fact. Out of all the options, I like the third one best
paulW is offline   Reply With Quote
Old 05-03-2013, 12:40 AM   #3
RichBMW
Beastly Adventurer
 
RichBMW's Avatar
 
Joined: Jul 2012
Location: Surrey, UK
Oddometer: 1,791
Much much better
__________________
2015 BMW S1000R Sport
2015 BMW R1200GSAW (on order)
RichBMW is offline   Reply With Quote
Old 05-03-2013, 07:10 AM   #4
SS Twin
GS 4 ADV
 
Joined: Dec 2005
Location: NE Florida
Oddometer: 310
Love the look (of the "bulbs); now how about some pics of the "bewbs"?

Seriously, it's a great look. How much for the led's? Please let us know how/when you get the update. Thanks.
__________________
Steve
2014 R1200GSW
Fernandina Beach, FL

"Looking for adventure!"
SS Twin is offline   Reply With Quote
Old 05-03-2013, 08:39 AM   #5
oz97tj OP
Studly Adventurer
 
oz97tj's Avatar
 
Joined: Mar 2012
Location: Fenton, MI
Oddometer: 814
Quote:
Originally Posted by SS Twin View Post
Love the look (of the "bulbs); now how about some pics of the "bewbs"?

Seriously, it's a great look. How much for the led's? Please let us know how/when you get the update. Thanks.
The LEDs arent cheap. They are like 45 bucks each. I ordered mine from Max BMW.
__________________
'13 BMW 1200 GSW
'05 Honda ST1300
oz97tj is offline   Reply With Quote
Old 05-03-2013, 05:57 PM   #6
SS Twin
GS 4 ADV
 
Joined: Dec 2005
Location: NE Florida
Oddometer: 310
Thanks, not totally hateful, but then again they are "genuine BMW parts"! Hahah.

Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.
__________________
Steve
2014 R1200GSW
Fernandina Beach, FL

"Looking for adventure!"
SS Twin is offline   Reply With Quote
Old 05-03-2013, 06:56 PM   #7
paco fernandez
Mexico
 
paco fernandez's Avatar
 
Joined: Aug 2010
Location: URUAPAN, MICHOACAN. MEXICO
Oddometer: 64
At Mexico since 2008 all bmw bikes comes with led turn signals as standard




Enviado desde mi iPad con Tapatalk HD
paco fernandez is offline   Reply With Quote
Old 05-03-2013, 09:32 PM   #8
oz97tj OP
Studly Adventurer
 
oz97tj's Avatar
 
Joined: Mar 2012
Location: Fenton, MI
Oddometer: 814
Quote:
Originally Posted by SS Twin View Post
Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.
So far so good. I've done the 600 mile service on the new motor now with no issues. I took it to the dealer for the first service so they could look at it just to cover my ass and I figured they would give it a good look seeing as they've gotten so personal with it already. I'm pretty happy with it overall.

Quote:
Originally Posted by paco fernandez View Post
At Mexico since 2008 all bmw bikes comes with led turn signals as standard
Those signals come on pretty much every bike outside the US. Supposedly our Department of Transportation says the LEDs don't have enough surface area so they don't meet their requirements. From what I understand, it has nothing to do with the brightness but rather the size. Makes no sense to me.
__________________
'13 BMW 1200 GSW
'05 Honda ST1300
oz97tj is offline   Reply With Quote
Old 07-20-2013, 02:27 PM   #9
pfiedler
Adventurer
 
Joined: Feb 2010
Location: Boxford, MA
Oddometer: 26
Quote:
Originally Posted by SS Twin View Post
Thanks, not totally hateful, but then again they are "genuine BMW parts"! Hahah.

Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.
Had a set of the LEDs installed at Max BMW today during my 600 mile service. The problem with the LAMPS warning is still not resolved despite the fact that BMW recently "released" the LED signal lamps to the dealerships after having them on "hold" due to this CANBUS/software problem. The tech hooked my bike up to the "mother ship" at BMW, but he and another tech were very frustrated to see that this problem has still not been resolved.

The GM and the Accessories Manager at Max's are going to contact BMW next week to see if they can find out when the software update will be available. Until then, I have to live with the yellow caution light and the LAMPS warning on the computer read out.

The LED turn signals flash quicker than normally, however work at the normal flash rate when operating the hazard lights. Supposedly, when the software silliness gets ironed out by BMW, the flash rate will return to normal.

I'll drop a note back to this thread once (if ever) this is resolved! You would think BMW would have fixed this by now.

Please ride safely!

Peter
__________________
------------------
2012 K1600GT Light Gray
2013 R1200GSW Thunder Gray
pfiedler is offline   Reply With Quote
Old 07-20-2013, 04:18 PM   #10
oz97tj OP
Studly Adventurer
 
oz97tj's Avatar
 
Joined: Mar 2012
Location: Fenton, MI
Oddometer: 814
Yup, I'm still waiting too.
__________________
'13 BMW 1200 GSW
'05 Honda ST1300
oz97tj is offline   Reply With Quote
Old 07-20-2013, 07:05 PM   #11
def
I've little to say
 
def's Avatar
 
Joined: Feb 2004
Location: The woods and mountains of Alabama
Oddometer: 8,897
Quote:
Originally Posted by oz97tj View Post
Those signals come on pretty much every bike outside the US. Supposedly our Department of Transportation says the LEDs don't have enough surface area so they don't meet their requirements. From what I understand, it has nothing to do with the brightness but rather the size. Makes no sense to me.
There is little sense to be found in most everything our gov has been doing for the last 6+ years....and, it seems to be getting worse.
def is offline   Reply With Quote
Old 07-21-2013, 09:08 AM   #12
hammick
Beastly Adventurer
 
hammick's Avatar
 
Joined: Dec 2007
Location: Kansas City, Missouri
Oddometer: 1,352
Quote:
Originally Posted by def View Post
There is little sense to be found in most everything our gov has been doing for the last 6+ years....and, it seems to be getting worse.
Yeah let's blame the led blinker issue on Obama. Pretty sure we were all running led signals when Bush was in office.
__________________
2015 R1200 GSA (on order)
2014 S1000R
2013 KTM 500 XC-W
hammick is offline   Reply With Quote
Old 07-21-2013, 10:49 AM   #13
JetSpeed
Naviator
 
JetSpeed's Avatar
 
Joined: Nov 2007
Location: KNZY
Oddometer: 2,589
Thumbs down

Quote:
Originally Posted by hammick View Post
Yeah let's blame the led blinker issue on Obama. Pretty sure we were all running led signals when Bush was in office.

I say; Blame it all on that worthless piece of shit.


Nice blinkers by the way, I'll get a set as soon as the software update is released.
__________________
2013 R1200GSW
JetSpeed is offline   Reply With Quote
Old 07-21-2013, 10:58 AM   #14
El Gato
Studly Adventurer
 
El Gato's Avatar
 
Joined: Jun 2010
Location: Los Gatos, CA
Oddometer: 649
Quote:
Originally Posted by oz97tj View Post
The option was available on previous bikes so should be available on this one as well, (snip)
Love the look. FWIW - I did the euro LED swap on my '12 GSA, and no software update was required. It was a straight plug 'n play and they worked perfectly out of the box. Not sure why BMW felt the need to complicate matters on the new LC.
__________________
---
El Gato is offline   Reply With Quote
Old 07-21-2013, 01:38 PM   #15
FixxiT
Lunitic Fringe
 
FixxiT's Avatar
 
Joined: Jul 2004
Location: TaxToll Island, NY Elevation: 22 feet
Oddometer: 944
Quote:
Originally Posted by El Gato View Post
FWIW - I did the euro LED swap on my '12 GSA, straight plug 'n play and they worked perfectly out of the box.
'13 GSA same deal, plug & play, no issues here
__________________
Survivor Series:
CroMag: 04*05*09*10*11*13 Recompence: 10 12 13
FixxiT is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:46 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014