ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-11-2013, 07:49 PM   #1
skidxr OP
Excuses
 
skidxr's Avatar
 
Joined: Mar 2006
Location: Durango, Colorado
Oddometer: 376
990 Idle Problem

Hey all. My 2007 990 Adv will not idle. Just out of the blue when I come to a stop it just dies. I haven't done anything to troubleshoot except connect to TuneECU to check for any error codes and there are none. Where should I begin to troubleshoot this?
__________________
...
skidxr is offline   Reply With Quote
Old 08-11-2013, 09:30 PM   #2
bikyto
Dans le doute...gaz!
 
bikyto's Avatar
 
Joined: Jun 2009
Location: Northern Cali
Oddometer: 2,140
In tuneecu, with a warm engine but not running, check your tps.
Anything below 0.58v or above 0.64 could lead to idling issue.
Most target 0.60v as ideal tps.
__________________
The race is long and, in the end, it's only with yourself...

bikyto screwed with this post 09-04-2013 at 08:02 PM
bikyto is offline   Reply With Quote
Old 08-11-2013, 09:52 PM   #3
Midlife
HalFassed
 
Midlife's Avatar
 
Joined: Mar 2006
Location: Canton GA
Oddometer: 69
Simple stuff first?

Quote:
Originally Posted by skidxr View Post
Hey all. My 2007 990 Adv will not idle. Just out of the blue when I come to a stop it just dies. I haven't done anything to troubleshoot except connect to TuneECU to check for any error codes and there are none. Where should I begin to troubleshoot this?
Clean filter? How old are the plugs?
__________________
STILL fun after all these years! Thanks GOD!

2008 KTM 990 Adventure, and a bunch of dream bikes in my head.
Midlife is offline   Reply With Quote
Old 08-11-2013, 10:03 PM   #4
Mother_trucker69
Adventurer
 
Mother_trucker69's Avatar
 
Joined: May 2011
Location: When home Visalia Ca
Oddometer: 16
Check fuel filter.
Mother_trucker69 is offline   Reply With Quote
Old 08-12-2013, 04:30 PM   #5
Zuber
Zoob
 
Zuber's Avatar
 
Joined: Sep 2004
Location: Main Street, Shedd, Oregon
Oddometer: 1,795
Check the throttle cables, if too tight, the ECU will not pick up the idle. You are starting it with a closed throttle? If you crack the throttle, the auto-idle will not take over.

Then +2 on the TPS sensor.

-2 on fuel filters, they usually don't show problems on idle.

So the count sofar is 2 for TPS, 1 for cables and 0 for filters. Any one of us is not as stupid as all of us.
__________________
"Dad, can I get a motorcycle when I grow up?"
"Son, you can't do both"
Zuber is offline   Reply With Quote
Old 08-13-2013, 03:04 PM   #6
skidxr OP
Excuses
 
skidxr's Avatar
 
Joined: Mar 2006
Location: Durango, Colorado
Oddometer: 376
Thanks for the replies.

So I connected it up to TuneECU again after riding it around for a bit. I had the ignition turned on but the engine is not running and the headlight fuse is out. On the test screen under TPS it reads 0.71

I don't know enough about TuneECU to know if I did that right.

When started it today after sitting for a couple days it started just fine and idled fine while in neutral. It did not die on me but the idle dropped down to just below 1k after I popped it into gear and rolled forward a few feet and then stopped. Then it will slowly increase up to about 1400k.

Thanks again...
__________________
...
skidxr is offline   Reply With Quote
Old 09-04-2013, 03:48 PM   #7
skidxr OP
Excuses
 
skidxr's Avatar
 
Joined: Mar 2006
Location: Durango, Colorado
Oddometer: 376
I adjusted to TPS and all is good with the idle now.

Thank you all for the help. I couldn't own this bike if not for this forum !!!
__________________
...
skidxr is offline   Reply With Quote
Old 09-04-2013, 08:00 PM   #8
bikyto
Dans le doute...gaz!
 
bikyto's Avatar
 
Joined: Jun 2009
Location: Northern Cali
Oddometer: 2,140
Quote:
Originally Posted by skidxr View Post
I adjusted to TPS and all is good with the idle now.

Thank you all for the help. I couldn't own this bike if not for this forum !!!
__________________
The race is long and, in the end, it's only with yourself...
bikyto is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:41 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014