ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 08-31-2008, 07:02 PM   #11
Grreatdog
Beastly Adventurer
 
Grreatdog's Avatar
 
Joined: Apr 2007
Location: Annapolis, MD
Oddometer: 9,795
Quote:
Originally Posted by moonie527
Okay, first question. I took the bike out for a short 5 mile ride today and noticed that there was oil leaking from the oil fill plug. Unscrewed the plug, cleaned it and the area, then tightened it back down and went back out riding. Got home and noticed that there was oil seeping from the same place, is this common, or should I be worried?
Was there an o-ring on the plug? If not, there should be. I used to tighten mine with a wrench to keep if from leaking even with a decent o-ring.

BTW, my wife just looked over my shoulder and asked if I was missing my old bike. She said yours looks like mine did when we got married in 87. The answer was no - I was only admiring how virgin it looks.

Good find. Mine lasted 17 years. All that's left now:

__________________
640E, MXC200, XT200

Grreatdog screwed with this post 08-31-2008 at 07:31 PM
Grreatdog is online now   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:51 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014