ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-27-2005, 12:25 PM   #1
Badmunkie OP
...and needing spanked!
 
Badmunkie's Avatar
 
Joined: Feb 2003
Location: Central Arkansas
Oddometer: 181
640 Idiot Lights..Year by Year

I'm planing to rework the idiot lights on my '01 640e. I like the TT 100R300 IMO but it's a bit pricey.

I know that the 640 ADV's have had several different arrangements for idiot lights over the years but I really don't know what functions were monitored.

Please chime in with with the different years and models and what idiot lights were included. Pics if ya 'ave 'em.

To start, my 640e has the following:

High H2O Temp (red)
Turn Signals (yellow)
Neutral (green)
High Beams (blue)

This is the TT Rallye Bracket with included faceplate and idiot lights that I've fitted to mine.



'munkie
Badmunkie is offline   Reply With Quote
Old 12-27-2005, 01:16 PM   #2
markjenn
Beastly Adventurer
 
Joined: Nov 2003
Location: Swellvue, WA
Oddometer: 10,311
My 00 Adv has the same four lights from top to bottom: signals, high beam, neutral, high temp.

- Mark
markjenn is offline   Reply With Quote
Old 12-27-2005, 02:26 PM   #3
Arch
Incurable Gearhead
 
Arch's Avatar
 
Joined: Dec 2001
Location: Katy, TX
Oddometer: 11,705
Quote:
Originally Posted by markjenn
My 00 Adv has the same four lights from top to bottom: signals, high beam, neutral, high temp.
Ditto for my '01, 'munkie...

__________________
Arch
Arch is offline   Reply With Quote
Old 12-27-2005, 08:05 PM   #4
wadventure
Mellow Adventurer
 
wadventure's Avatar
 
Joined: May 2004
Location: Lakewood Colorado
Oddometer: 221
Quote:
Originally Posted by Arch
Ditto for my '01, 'munkie...

Speaking of '01's Arch, have you ever replaced the light bulb in the computer? Mine died!
__________________
'09 300 EXC (my 525 replacement )
'11 690e R (makes me smile! - 525 / 990 replacement)
Say hi to Jeanne - she's UltraJ
wadventure is offline   Reply With Quote
Old 12-27-2005, 08:29 PM   #5
CountPacMan
KTM 640 Adventure abuser
 
CountPacMan's Avatar
 
Joined: May 2004
Location: Portland, OR - USA / Oltenita, ROMANIA
Oddometer: 106
Quote:
Originally Posted by wadventure
Speaking of '01's Arch, have you ever replaced the light bulb in the computer? Mine died!
I'm not Arch, but I had the same thing happen to my 2000 model year. When I took the IMO apart, it was a really thin and badly soldered wire that went from the circuit board on the bottom to the display that had broken connection. Easy fix.
__________________
"Improvement makes strait roads, but the crooked roads without Improvement, are roads of Genius"
- William Blake 1757-1827

spake Rad, "The KTM will reward you like a very expensive mistress where the BMW will reward you like a, like a... like a wife "
CountPacMan is offline   Reply With Quote
Old 12-28-2005, 07:57 AM   #6
wadventure
Mellow Adventurer
 
wadventure's Avatar
 
Joined: May 2004
Location: Lakewood Colorado
Oddometer: 221
Quote:
Originally Posted by CountPacMan
I'm not Arch, but I had the same thing happen to my 2000 model year. When I took the IMO apart, it was a really thin and badly soldered wire that went from the circuit board on the bottom to the display that had broken connection. Easy fix.
Thanks Count,

I'll give it a look on my next tear down (in the next few weeks.)

wadventure
__________________
'09 300 EXC (my 525 replacement )
'11 690e R (makes me smile! - 525 / 990 replacement)
Say hi to Jeanne - she's UltraJ
wadventure is offline   Reply With Quote
Old 12-28-2005, 08:12 AM   #7
Badmunkie OP
...and needing spanked!
 
Badmunkie's Avatar
 
Joined: Feb 2003
Location: Central Arkansas
Oddometer: 181
Low Fuel Level?

Don't some of the 640 ADV's have an indication of low fuel level?

'munkie
Badmunkie is offline   Reply With Quote
Old 12-28-2005, 08:28 AM   #8
cwk
n00b
 
Joined: Sep 2004
Location: Copenhagen, Denmark
Oddometer: 0
Do I understand correctly that non of the Adventure models had any low oil pressure lights???

chris
cwk is offline   Reply With Quote
Old 12-28-2005, 09:34 AM   #9
Arch
Incurable Gearhead
 
Arch's Avatar
 
Joined: Dec 2001
Location: Katy, TX
Oddometer: 11,705
Quote:
Originally Posted by wadventure
Speaking of '01's Arch, have you ever replaced the light bulb in the computer? Mine died!
Mine's still working and the parts manual doesn't show any individual parts inside the actual Tripmaster, so I dunno about the bulb. Time for a look inside!
__________________
Arch
Arch is offline   Reply With Quote
Old 12-28-2005, 09:40 AM   #10
Arch
Incurable Gearhead
 
Arch's Avatar
 
Joined: Dec 2001
Location: Katy, TX
Oddometer: 11,705
Quote:
Originally Posted by Badmunkie
Don't some of the 640 ADV's have an indication of low fuel level?
The low fuel indicator (and mileage countdown) arrived in '02, I believe.
__________________
Arch
Arch is offline   Reply With Quote
Old 12-28-2005, 09:32 PM   #11
Loadedagain
making chips
 
Loadedagain's Avatar
 
Joined: Jan 2003
Location: West Vancouver, BC
Oddometer: 26,718
my 02 has low fuel level. no warning lamps. everything is intergrated into the imo.

__________________
** iba - 22936 *** Alcan5000 - 2006, 2008, 2012, 2014 ***

Stenhouse Racing - Specializing in KTM Upgrades
custom cnc service available to suit your specific needs.
Loadedagain is offline   Reply With Quote
Old 12-28-2005, 10:09 PM   #12
PASSMORE
Just the last name...
 
PASSMORE's Avatar
 
Joined: Apr 2004
Location: The Texas Embassy in Sloughhouse, CA
Oddometer: 4,250
Quote:
Originally Posted by Loadedagain
my 02 has low fuel level. no warning lamps. everything is intergrated into the imo.

How ya got that GPS mounted up there Loady?
__________________
- Michael
facebook.com/passmoreranch
PASSMORE is offline   Reply With Quote
Old 12-29-2005, 07:14 AM   #13
Arch
Incurable Gearhead
 
Arch's Avatar
 
Joined: Dec 2001
Location: Katy, TX
Oddometer: 11,705
Quote:
Originally Posted by Loadedagain
my 02 has low fuel level. no warning lamps. everything is intergrated into the imo.
Oops! Forgot about the different computer thingie.
__________________
Arch
Arch is offline   Reply With Quote
Old 12-30-2005, 07:17 AM   #14
Badmunkie OP
...and needing spanked!
 
Badmunkie's Avatar
 
Joined: Feb 2003
Location: Central Arkansas
Oddometer: 181
So the KTM IMOs have the standard lights (Blinkers, High beam, Neutral, High H2O Temp) built in?

And from '02 they include the Low Fuel Warning.

It must be some other make with indications for Low Oil Pressure and Low Battery.


'munkie
Badmunkie is offline   Reply With Quote
Old 12-30-2005, 07:44 AM   #15
meat popsicle
Ignostic
 
meat popsicle's Avatar
 
Joined: Feb 2004
Location: Circumlocution Office of Little Dorrit
Oddometer: 14,152
I didn't think about this before munkie, but the parts fiche online have the parts listed, including lights in some cases

2000 model
http://www.ktminfo.com/partscat/Part...0497&CatID=231
HIGH BEAM INDICATOR LIGHT BLUE 58011021200
NEUTRAL INDICATOR LIGHT GREEN 58011023200
TEMPERATURE WARNING LIGHT RED 58011022200
FLASHER INDICATOR LIGHT GREEN 58011024200
listed separately; must not be part of the IMO?

2003 model
http://www.ktminfo.com/partscat/Part...0899&CatID=555
no indicator lights listed; part of the IMO assembly
__________________
Kronreif Trunkenpolz Mattighofen LC4 640

Its not so much staying alive; its staying human that counts.
meat popsicle is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:16 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014