ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-04-2006, 07:24 PM   #1
La_Poderosa_3 OP
It's not freezing!!!!
 
La_Poderosa_3's Avatar
 
Joined: Jan 2006
Location: Tiburon, CA
Oddometer: 164
Dragging brakes

Those people who know me know that I am probably the least mechanically inclined person they have ever met. But, give me enough beer and I will try anything.

My front and rear brakes are dragging a little bit (rear especially, the front always dragged a tiny bit). Anyone know how to fix this? I don't think it's affecting the performance of the bike but it's making it a bitch to move around the garage with the motor off.

Ayuda me, por favor.
__________________
The incredible misadventures of a boy and his bike La Poderosa 3.
La_Poderosa_3 is offline   Reply With Quote
Old 05-07-2006, 08:24 AM   #2
Fred
Banned
 
Fred's Avatar
 
Joined: Feb 2003
Location: under my fallen bike
Oddometer: 1,051
My new one did this while riding the other day. It freed itself up but at the first service I want it documented in case the rotor is or will get warped. I took some Brake Cleen and sprayed in the caliper and cleaned the rotor off. Hasn't happened again.

Some late model Guzzi LeMans and V11 Sports had the same rear brake dragging problem. On mine, the pads were hanging up on the pins that hold them in. A bit of brake grease (anti-seize) on the pins and the problem was solved on mine.

On the 950, the rear brake now squeals, so I'm just going to let warranty take care of it and not touch it myself.
Fred is offline   Reply With Quote
Old 05-07-2006, 10:01 AM   #3
craft
Aventurero
 
craft's Avatar
 
Joined: Aug 2005
Location: Texas
Oddometer: 199
simple fix?

Quote:
Originally Posted by La_Poderosa_3

My front and rear brakes are dragging a little bit (rear especially, the front always dragged a tiny bit). Anyone know how to fix this? I don't think it's affecting the performance of the bike but it's making it a bitch to move around the garage with the motor off.

Ayuda me, por favor.
Any chance your wheels are out of alignment/center?
__________________
'05.5 950 Adv
'02 YZ250F
craft is offline   Reply With Quote
Old 05-07-2006, 04:05 PM   #4
La_Poderosa_3 OP
It's not freezing!!!!
 
La_Poderosa_3's Avatar
 
Joined: Jan 2006
Location: Tiburon, CA
Oddometer: 164
Probably, there is a good chance. I just did 1300 off road miles in Baja. But I rode back on the hiway and it was fine. The brakes really just started dragging when I got back to Denver. I am going to flush the rear MC.

Quote:
Originally Posted by craft
Any chance your wheels are out of alignment/center?
__________________
The incredible misadventures of a boy and his bike La Poderosa 3.
La_Poderosa_3 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:41 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014