ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-04-2013, 07:58 AM   #25171
tlking6
Gnarly Adventurer
 
tlking6's Avatar
 
Joined: Jul 2008
Location: Lower Left Side
Oddometer: 281
Quote:
Originally Posted by g.mccormick View Post
I remember seeing a post somewhere in this thread about mirrors. It was using another Husky models mirrors, they were cheap and worked really well. I need mirrors, and can't find that post. Anyone help out?
The stock mirrors for the 510 fit perfectly. They fold up out of the way, dont vibrate too bad and are cheap. $15 at my Husky dealer.
__________________
08 Husky 610 TE
01 KTM 453 MXC
tlking6 is offline   Reply With Quote
Old 05-04-2013, 09:48 AM   #25172
g.mccormick
Gnarly Adventurer
 
g.mccormick's Avatar
 
Joined: Jul 2010
Location: New Whiteland, IN
Oddometer: 145
Quote:
Originally Posted by tlking6 View Post
The stock mirrors for the 510 fit perfectly. They fold up out of the way, dont vibrate too bad and are cheap. $15 at my Husky dealer.
Thats what I was partially remembering. Any year 510 in particular? The ram mount mirrors seem nice, but I dont want to spend $80 on mirrors.
g.mccormick is offline   Reply With Quote
Old 05-04-2013, 03:22 PM   #25173
h2o_snow
Water, snow & dirt too.
 
h2o_snow's Avatar
 
Joined: Sep 2008
Location: North of Boise-vegas, ID
Oddometer: 713
Mirror Threads

Quote:
Originally Posted by Flashman1 View Post
I use a little 12 volt air compressor - I think it made by slime. It is very small and quick.
Thanks Flash - I will check it out.

Also - of the top of anyones head - whats the thread and pitch for the stock 2006 610 mirrors?
__________________
06 TE 610; 98 DR 650 - Sold: a past pleasure
02 XT225 - Wifey's ride
So I'm packing my bags for the Misty Mountains
Over the hills where the spirits fly,
I really don't know.
h2o_snow is offline   Reply With Quote
Old 05-04-2013, 07:11 PM   #25174
Taranis
Gnarly Adventurer
 
Joined: Jun 2011
Location: LBC, yo.
Oddometer: 357
M10 x 1.25 right-hand threads

Most common Japanese thread. I put my stock 610 mirrors on a Suzuki street bike.
__________________
DIRT BIKES ARE FUN AND INTERESTING
Taranis is offline   Reply With Quote
Old 05-04-2013, 09:47 PM   #25175
h2o_snow
Water, snow & dirt too.
 
h2o_snow's Avatar
 
Joined: Sep 2008
Location: North of Boise-vegas, ID
Oddometer: 713
Quote:
Originally Posted by Taranis View Post
M10 x 1.25 right-hand threads

Most common Japanese thread. I put my stock 610 mirrors on a Suzuki street bike.
Thanks T.

Good link & info on the spacer - that's what I was thinking.
__________________
06 TE 610; 98 DR 650 - Sold: a past pleasure
02 XT225 - Wifey's ride
So I'm packing my bags for the Misty Mountains
Over the hills where the spirits fly,
I really don't know.
h2o_snow is offline   Reply With Quote
Old 05-05-2013, 05:01 PM   #25176
1 lunger
Beastly Adventurer
 
1 lunger's Avatar
 
Joined: Mar 2011
Location: Bloomfield CT
Oddometer: 1,187
Anyone REALLY using the Hyde skid plate on their 610 that can confirm it will hold up to the abuse like the aluminum ones? My Ricochet skid plat is so bent up its impossible to get it off and on.
1 lunger is offline   Reply With Quote
Old 05-05-2013, 06:35 PM   #25177
g.mccormick
Gnarly Adventurer
 
g.mccormick's Avatar
 
Joined: Jul 2010
Location: New Whiteland, IN
Oddometer: 145
Quote:
Originally Posted by 1 lunger View Post
Anyone REALLY using the Hyde skid plate on their 610 that can confirm it will hold up to the abuse like the aluminum ones? My Ricochet skid plat is so bent up its impossible to get it off and on.

I have one on order, would also like to know some real use opinions.
g.mccormick is offline   Reply With Quote
Old 05-05-2013, 07:17 PM   #25178
Taranis
Gnarly Adventurer
 
Joined: Jun 2011
Location: LBC, yo.
Oddometer: 357
Quote:
Originally Posted by 1 lunger View Post
Anyone REALLY using the Hyde skid plate on their 610 that can confirm it will hold up to the abuse like the aluminum ones? My Ricochet skid plat is so bent up its impossible to get it off and on.
Haven't dragged it across boulders yet, but I've had plenty of tipovers on it and it's been great. Have crashed more and harder with the Hyde plate on my YZ, and it's also been great. I'm convinced that if either of them ever doesn't cut it, I'll have bigger problems to worry about.
__________________
DIRT BIKES ARE FUN AND INTERESTING
Taranis is offline   Reply With Quote
Old 05-05-2013, 10:12 PM   #25179
BiG DoM
African Adventurer
 
BiG DoM's Avatar
 
Joined: Jun 2002
Location: South Africa
Oddometer: 2,462
Quote:
Originally Posted by 1 lunger View Post
Anyone REALLY using the Hyde skid plate on their 610 that can confirm it will hold up to the abuse like the aluminum ones? My Ricochet skid plat is so bent up its impossible to get it off and on.

Best out there - you will not break it and does the job fantastically.Best is due to it being poly it actually slides over rocks rather than wanting to hang up like alu - also quieter as does not amplify engine noise.
__________________
BiG DoM

Life is not a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in sideways, thoroughly used, totally worn out and loudly proclaiming... 'Fuck, what a trip!'

People are more violently opposed to fur than leather because it's safer to harass rich women than motorcyclists.
BiG DoM is offline   Reply With Quote
Old 05-06-2013, 10:56 AM   #25180
TIGERRIDER007
Studly Adventurer
 
TIGERRIDER007's Avatar
 
Joined: Aug 2006
Location: Acworth, GA
Oddometer: 772
Vin

Where can I find the VIN # on an 06? Thanks
__________________
Scott
06' Triumph Tiger (my lifer)
05' Husqvarna TE510 (yeller and blue)
TIGERRIDER007 is offline   Reply With Quote
Old 05-06-2013, 12:37 PM   #25181
shootis
Gnarly Adventurer
 
shootis's Avatar
 
Joined: Apr 2008
Location: Dedham, Maine
Oddometer: 114
09 TE610 battery icon flashing?

My battery icon starting flashing yesterday, I checked the battery voltage at idle and its a steady 14.2.


I just took it for an hour long ride and let it set for a bit and the battery reads 12.5 with the key on and not running.

Is my battery failing?

Thanks,

Shootis

ETA: The battery is not the stock crappy one, it was replaced before I got it.

shootis screwed with this post 05-06-2013 at 12:54 PM
shootis is online now   Reply With Quote
Old 05-06-2013, 01:52 PM   #25182
tunp
Gnarly Adventurer
 
tunp's Avatar
 
Joined: Apr 2011
Location: almost SE PA
Oddometer: 272
Quote:
Originally Posted by 1 lunger View Post
Anyone REALLY using the Hyde skid plate on their 610 that can confirm it will hold up to the abuse like the aluminum ones? My Ricochet skid plat is so bent up its impossible to get it off and on.
I have beat mine for awhile now, rocks bouncing off of it, sliding over rocks and logs, seems to be holding up well.
__________________
Ridin w/ a smile
Tony A
02 FLHT, 11 990 adv,13 TE449,
tunp is offline   Reply With Quote
Old 05-06-2013, 02:18 PM   #25183
TIGERRIDER007
Studly Adventurer
 
TIGERRIDER007's Avatar
 
Joined: Aug 2006
Location: Acworth, GA
Oddometer: 772
Found it

I found the VIN so no worries....getting a little title confusion worked out.
__________________
Scott
06' Triumph Tiger (my lifer)
05' Husqvarna TE510 (yeller and blue)
TIGERRIDER007 is offline   Reply With Quote
Old 05-06-2013, 04:24 PM   #25184
1 lunger
Beastly Adventurer
 
1 lunger's Avatar
 
Joined: Mar 2011
Location: Bloomfield CT
Oddometer: 1,187
Quote:
Originally Posted by shootis View Post
My battery icon starting flashing yesterday, I checked the battery voltage at idle and its a steady 14.2.


I just took it for an hour long ride and let it set for a bit and the battery reads 12.5 with the key on and not running.

Is my battery failing?

Thanks,

Shootis

ETA: The battery is not the stock crappy one, it was replaced before I got it.
That battery icon?? Didn't know they had one? Most just lie to you when you test them and let you down at the worst times.
1 lunger is offline   Reply With Quote
Old 05-06-2013, 06:47 PM   #25185
Flashman1
Beastly Adventurer
 
Flashman1's Avatar
 
Joined: May 2006
Location: Tucson
Oddometer: 5,359
Quote:
Originally Posted by shootis View Post
My battery icon starting flashing yesterday, I checked the battery voltage at idle and its a steady 14.2.


I just took it for an hour long ride and let it set for a bit and the battery reads 12.5 with the key on and not running.

Is my battery failing?

Thanks,

Shootis

ETA: The battery is not the stock crappy one, it was replaced before I got it.
Mine used to do that - but I have a 2007.

On mine it was an over charge condition - I replaced the stock POS headlight with a Baja Designs set up - no more icon.

Here was a hint - does the icon go away with the bright light setting - or when the turn signal is on. Any thing that drew more current would cause the icon to go off.

But you have a 2009 - different electronics.
Flashman1 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:30 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014