ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-02-2014, 06:51 AM   #8731
icbraz
Adventurer
 
Joined: Apr 2014
Location: Italy
Oddometer: 36
Quote:
Originally Posted by leafman60 View Post
Sorry, when I said "needle," I was referring to the plunger, the shiny part of the solenoid that you show in your picture.

The symptoms that you describe DOES sound like an issue with this function of your fuel injection system. Intermittent issues like this are very frustrating. Many a wild goose chase has been launched by such a scenario.

Hey, I wonder about something. When you are underway and the bike is stalling, if you rev the engine when you clutch to keep the rpm's from dropping, will the engine will still stall? If revving the motor to avoid the throttle body from closing avoids the problem, then another big finger points to the idle situation.
Ah, I see, yes, in that case it was all cleaned, I am glad I won't have to pull all apart again :)! And yes, when the problem happened keeping the throttle open would stop the bike from stalling. In fact when the problem happened the only way for me to get back home on the bike was high reving in between gear switching, a real pain... anytime I failed to keep in high revs it would stall straight away...!
icbraz is offline   Reply With Quote
Old 06-03-2014, 06:07 PM   #8732
Pescador
Adventurer
 
Pescador's Avatar
 
Joined: May 2011
Location: Central Florida
Oddometer: 86
To stop this problem a took one more step.

Remove PCV hose from bottom of air box. Extend hose so it reaches behind right side cover. Install small cone filter on end of hose.
Open up air box, clean air box and throttle body with throttle body cleaner wile running. Open up idle accuator. Located on right side of motor three bolts, I think. Pull out , clean accuator and inside accuator housing. Reinstall parts.
Use tectron cleaner every other tank. This should stop the problem.

Installing cone filter will keep the oil mist out of the air box and keep everything cleaner inside for a lot longer. I have had a cone filter for 6,000 mile and still don't have to change it yet.

Knock on wood everything is running Great!!!

Bret
Pescador is offline   Reply With Quote
Old 06-04-2014, 04:33 AM   #8733
leafman60
Beastly Adventurer
 
Joined: Aug 2005
Oddometer: 1,569
Quote:
Originally Posted by icbraz View Post
Ah, I see, yes, in that case it was all cleaned, I am glad I won't have to pull all apart again :)! And yes, when the problem happened keeping the throttle open would stop the bike from stalling. In fact when the problem happened the only way for me to get back home on the bike was high reving in between gear switching, a real pain... anytime I failed to keep in high revs it would stall straight away...!
Well, that could be several things but that does sound like an idle actuator problem.
leafman60 is offline   Reply With Quote
Old 06-04-2014, 01:50 PM   #8734
icbraz
Adventurer
 
Joined: Apr 2014
Location: Italy
Oddometer: 36
Quote:
Originally Posted by Pescador View Post
To stop this problem a took one more step.

Remove PCV hose from bottom of air box. Extend hose so it reaches behind right side cover. Install small cone filter on end of hose.
Open up air box, clean air box and throttle body with throttle body cleaner wile running. Open up idle accuator. Located on right side of motor three bolts, I think. Pull out , clean accuator and inside accuator housing. Reinstall parts.
Use tectron cleaner every other tank. This should stop the problem.

Installing cone filter will keep the oil mist out of the air box and keep everything cleaner inside for a lot longer. I have had a cone filter for 6,000 mile and still don't have to change it yet.

Knock on wood everything is running Great!!!

Bret
That's a great tip, thanks. Actually, now that you explained this way I understand it has been mentioned in other posts I read on this, I just never fully understood which filter they meant. I got it now! Will do that! Bike is running much better so far after the cleaning...
icbraz is offline   Reply With Quote
Old 06-05-2014, 05:56 AM   #8735
madisonreid
Beastly Adventurer
 
Joined: Dec 2008
Oddometer: 1,700
Anyone know where I can find a Leo Vince exhaust for my xcountry?
madisonreid is offline   Reply With Quote
Old 06-05-2014, 10:28 AM   #8736
leafman60
Beastly Adventurer
 
Joined: Aug 2005
Oddometer: 1,569
http://www.renazcoracing.com/index.c...&sortorder=ASC

I think those are still offered by Leo V.
leafman60 is offline   Reply With Quote
Old 06-05-2014, 10:59 AM   #8737
madisonreid
Beastly Adventurer
 
Joined: Dec 2008
Oddometer: 1,700
No longer available there. But thank you. It appears Leo is no longer offered in US
madisonreid is offline   Reply With Quote
Old 06-05-2014, 04:43 PM   #8738
Dorito
Dreamer and Doer
 
Dorito's Avatar
 
Joined: Jul 2010
Location: Maryland
Oddometer: 5,012
Nothing on Dash?

Went out to start to sled today. Started fine...however, not a single electron on the dash. Not a oil or neutral light, not a mileage, not MPH? Fuze or ignition switch issue?
__________________
Nothing (ad)ventured, Nothing Gained
Everything you want is on the other side of fear.
Dorito is offline   Reply With Quote
Old 06-06-2014, 02:23 AM   #8739
jtw000
Survivor
 
Joined: May 2009
Oddometer: 548
I'm thinking of getting rid of my XC. A guy has his eye on her and I think I might be pretty much done with her. I've had her for years, toured Europe and crossed from the UK to Asia through the middle-east and she's not so much as skipped a beat. However, she's starting to show her years. The rear subframe is creaking badly, the alloy is just not up to the abuse. She's starting to piss oil out and while the engine is still running fine, it now needs a lot of attention.
I have an XR400 now and honestly, I prefer riding it. It's quicker, better offroad and is generally more fun.
I don't know. Do I let her go? Would you?
jtw000 is offline   Reply With Quote
Old 06-06-2014, 06:36 AM   #8740
lewiss66
Gnarly Adventurer
 
lewiss66's Avatar
 
Joined: Jan 2008
Location: French Alpes
Oddometer: 362
Look for a more recent XCO!
__________________
http://g650forum.forumactif.org/
http://buyvintage1.files.wordpress.c...porteur_01.jpg

G650 Xcountry 2007 / Beta evo 4T 2011
lewiss66 is offline   Reply With Quote
Old 06-06-2014, 06:49 AM   #8741
madisonreid
Beastly Adventurer
 
Joined: Dec 2008
Oddometer: 1,700
stock echaust mod?

ok...plan B

Anyone do a mod to stock pipe to improve performance, reduce weight etc?

Thanks for your help. Just picked up a very nice and well maintained 08 with 7k. Previous owner added some Touratech goodies and TK80s. I am adding a few more Touratech and Wunder stuff for comfort. Taking her out for a 50 mile romp out in North Bend to get the relationship started. She will be used sparingly as a in town commuter/scrambler. 10% lumber roads.
madisonreid is offline   Reply With Quote
Old 06-06-2014, 07:09 AM   #8742
tbarstow
Two-wheelin' Fool
 
tbarstow's Avatar
 
Joined: Jul 2007
Location: Viva Lost Wages!
Oddometer: 3,149
Quote:
Originally Posted by madisonreid View Post
No longer available there. But thank you. It appears Leo is no longer offered in US
LV went bankrupt now that you can't buy an aftermarket exhaust in the state of California.

Quote:
Originally Posted by Dorito View Post
Went out to start to sled today. Started fine...however, not a single electron on the dash. Not a oil or neutral light, not a mileage, not MPH? Fuze or ignition switch issue?
See if the connector is still plugged into the back of the dash, otherwise I'd start with the ignition switch.
__________________
G650X side panel tank build
tbarstow is online now   Reply With Quote
Old 06-06-2014, 08:32 AM   #8743
c-m
Gnarly Adventurer
 
Joined: Apr 2008
Location: UK
Oddometer: 327
Quote:
Originally Posted by jtw000 View Post
I'm thinking of getting rid of my XC. A guy has his eye on her and I think I might be pretty much done with her. I've had her for years, toured Europe and crossed from the UK to Asia through the middle-east and she's not so much as skipped a beat. However, she's starting to show her years. The rear subframe is creaking badly, the alloy is just not up to the abuse. She's starting to piss oil out and while the engine is still running fine, it now needs a lot of attention.
I have an XR400 now and honestly, I prefer riding it. It's quicker, better offroad and is generally more fun.
I don't know. Do I let her go? Would you?

Where are you based? I'm looking for an xcountry. Don't mind getting my hands a little dirty.
c-m is offline   Reply With Quote
Old 06-06-2014, 09:46 AM   #8744
TymeRider
Gnarly Adventurer
 
TymeRider's Avatar
 
Joined: Apr 2005
Location: Sunnyvale, CA
Oddometer: 382
Quote:
Originally Posted by tbarstow View Post
LV went bankrupt now that you can't buy an aftermarket exhaust in the state of California.
I live in Cali, but since I haven't been in the exhaust market in a while, haven't paid much attention to this. What changed? I assume some new CARB (CA Air Resources Board for those none CA inmates) regulation?

Doug
__________________
2007 BMW G650X Challenge
2005 KTM 950S Adventure
2002 BMW R1150GS Adventure
TymeRider is offline   Reply With Quote
Old 06-06-2014, 03:38 PM   #8745
icbraz
Adventurer
 
Joined: Apr 2014
Location: Italy
Oddometer: 36
Does anyone know where in Europe to look for a new faulx tank cover for the xcountry? I bought mine used, the faulx tank came scratched I didn't think much of it because I was planning on having the bike for a year or so to get some experience and then get something else. Now that is finely tuned, the bike is just fantastic and it's just perfect for me. There is no way I am selling the bike :)! So I took the top of the faulx tank to a local car repair shop he said I should probably look for a used top part on the net, it would be cheaper then doind the paint job on mine... Cannot find anything...
icbraz is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:12 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014