ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-21-2013, 04:07 AM   #526
The Bladerunner
Adventurer
 
The Bladerunner's Avatar
 
Joined: May 2009
Location: Cologne, Germany.
Oddometer: 22
Quote:
Originally Posted by McKay View Post
How are the tank stickers holding up?

I didn't get any and really think the tank needs something.
I had those stickers on my Clark tank. Piece of cr***. Held on for about 6 month
then started to peel of bit by bit.
The Bladerunner is offline   Reply With Quote
Old 05-22-2013, 06:24 PM   #527
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,643
Friend's 2011 450RR, running like crap, seems to be really hot, fan is running constantly, won't take throttle, spitting and sputtering, happened after it got up to operating temps. I told him to see if there was rad fluid flowing freely, but this bike has a thermostat, so if you pop the rad cap off when the bike is cold, you are not gonna see any fluid flowing due to the thermostat being shut, so how do you know/figure out if you have good fluid flow?

Anyone ever have the impeller nut come off a RR/RS motor?
__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.
AustinJake is offline   Reply With Quote
Old 05-22-2013, 08:39 PM   #528
redpillar
Studly Adventurer
 
redpillar's Avatar
 
Joined: Aug 2008
Location: Vancouver Island
Oddometer: 830
Haven't heard of that yet, but it wouldn't hurt to pull the cover and have a look at the impeller.
redpillar is offline   Reply With Quote
Old 05-23-2013, 10:11 PM   #529
atravlr
Gnarly Adventurer
 
atravlr's Avatar
 
Joined: Sep 2010
Location: Arizona Desert
Oddometer: 195
70 mile loop

Rode around I-40 near Goffs and Essex, CA. Not too hot and just a little breeze. No other traffic around and the Beta handled great on the deep super soft sand.





atravlr is offline   Reply With Quote
Old 05-23-2013, 10:23 PM   #530
atravlr
Gnarly Adventurer
 
atravlr's Avatar
 
Joined: Sep 2010
Location: Arizona Desert
Oddometer: 195
Sorry about the small pics







atravlr is offline   Reply With Quote
Old 05-24-2013, 11:06 AM   #531
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,643
Quote:
Originally Posted by AustinJake View Post
Friend's 2011 450RR, running like crap, seems to be really hot, fan is running constantly, won't take throttle, spitting and sputtering, happened after it got up to operating temps.
Confirmed: 1 tight intake valve (0.10mm wouldn't fit in, that's the lowest allowed), caused the hot running, bucking, back-firing through the intake, bad running, bike runs great as long as it doesn't get too hot.
__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.

AustinJake screwed with this post 05-25-2013 at 05:56 PM
AustinJake is offline   Reply With Quote
Old 05-25-2013, 04:41 PM   #532
redpillar
Studly Adventurer
 
redpillar's Avatar
 
Joined: Aug 2008
Location: Vancouver Island
Oddometer: 830
Good info thanks for posting it up
redpillar is offline   Reply With Quote
Old 05-27-2013, 08:19 PM   #533
columbia510
n00b
 
Joined: Sep 2009
Oddometer: 1
Any issues with non KTM motors? Left over 2012 520 RS. I have almost 800 miles on her already within a month. She RIPS and turns like no EFI Husky.
columbia510 is offline   Reply With Quote
Old 05-27-2013, 11:16 PM   #534
3girlsdad
aka FiddyK
 
3girlsdad's Avatar
 
Joined: Jul 2011
Location: Round Rock, Texas
Oddometer: 357
Quote:
Originally Posted by columbia510 View Post
Any issues with non KTM motors? Left over 2012 520 RS. I have almost 800 miles on her already within a month. She RIPS and turns like no EFI Husky.
yes. it will explode at 900 miles !!!! trade it in on a ktm..........
__________________
2008 Honda CRF450X - plated
2007 KTM 450 XCW - a little sip of the kool-aid (gone)
2011 Beta 450 RR - plated (gone. had my sexy italian fling)
2008 Honda XR650L - (gone)
3girlsdad is offline   Reply With Quote
Old 05-28-2013, 02:38 AM   #535
hawaiidirtrider
Adventurer
 
Joined: Oct 2009
Location: Oahu, Hawaii
Oddometer: 50
Quote:
Originally Posted by AustinJake View Post
Friend's 2011 450RR, running like crap, seems to be really hot, fan is running constantly, won't take throttle, spitting and sputtering, happened after it got up to operating temps. I told him to see if there was rad fluid flowing freely, but this bike has a thermostat, so if you pop the rad cap off when the bike is cold, you are not gonna see any fluid flowing due to the thermostat being shut, so how do you know/figure out if you have good fluid flow?

Anyone ever have the impeller nut come off a RR/RS motor?
Never heard of the impeller nut coming off... How about take out the thermostat.. You donT need a thermostat where you live..I don't think..just leave the housing and take out what's inside. That's what I did to mine. I'm not sure what your bad running problem is from what's said so far.. I haven't heard of any problems with Beta enduro motors. They seem real solid so far.

hawaiidirtrider screwed with this post 05-28-2013 at 02:44 AM
hawaiidirtrider is offline   Reply With Quote
Old 05-28-2013, 05:56 AM   #536
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,643
Quote:
Originally Posted by hawaiidirtrider View Post
Never heard of the impeller nut coming off... How about take out the thermostat.. You donT need a thermostat where you live..I don't think..just leave the housing and take out what's inside. That's what I did to mine. I'm not sure what your bad running problem is from what's said so far.. I haven't heard of any problems with Beta enduro motors. They seem real solid so far.
See post above, bad running is from a tight intake valve.

We did dismantle the thermostat, you can't just remove the thermostat from the housing, since the thermostat itself serves as a spacer/washer in between the 2 housing halves, and the you need that piece in there to avoid coolant leaks when you put the housing back together. We just sawed off the top and bottom of the thermostat and jettisoned the internals and re-installed the remainder back into the plastic housing.
__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.
AustinJake is offline   Reply With Quote
Old 05-28-2013, 08:55 AM   #537
catfish
Squidicus Adventurous
 
catfish's Avatar
 
Joined: Apr 2002
Location: Morgan Territory, CA
Oddometer: 567
Quote:
Originally Posted by AustinJake View Post
Confirmed: 1 tight intake valve (0.10mm wouldn't fit in, that's the lowest allowed), caused the hot running, bucking, back-firing through the intake, bad running, bike runs great as long as it doesn't get too hot.

Ahhhh, now the symptoms make sense. Yes, the valve clearances should be checked a little more often.


Quote:
Originally Posted by columbia510 View Post
Any issues with non KTM motors? Left over 2012 520 RS. I have almost 800 miles on her already within a month. She RIPS and turns like no EFI Husky.

+5600 miles & 232 hours on my '11 520RS. All valves are still in spec. Just oil & filter changes so far!


Catfish ...
catfish is offline   Reply With Quote
Old 05-30-2013, 03:32 PM   #538
drdfblackm
VeeFeer
 
drdfblackm's Avatar
 
Joined: Sep 2006
Location: Safe haven from Zombies aka Flagstaff AZ
Oddometer: 805
2008 525rr ????s

I am looking at a 2008 525rr. The bike has a new water pump, new handlebars, and a freshly preped carb.
It has a 3.2 ims desert tank, racetech suspension, fmf exhaust, scotts stabilizer, and arc levers.

I am going to ask if the lights are still on the bike and how many hours are on the bike. Is there any other questions I should be thinking about besides the regular wear and tear items??

Any help would be greatly appreciated.
__________________
These are not the droids you are looking for.....
drdfblackm is offline   Reply With Quote
Old 05-30-2013, 03:48 PM   #539
atravlr
Gnarly Adventurer
 
atravlr's Avatar
 
Joined: Sep 2010
Location: Arizona Desert
Oddometer: 195
I always ask how often the gear oil, and motor oil has been changed. Look for hesitation or a stammer on the answer. If there is, time to move on. Ask about the rear spring or fork springs, if they are stock and your above 200 lbs. tell him to knock off some dollars because you are going to have to upgrade.
atravlr is offline   Reply With Quote
Old 05-30-2013, 03:50 PM   #540
drdfblackm
VeeFeer
 
drdfblackm's Avatar
 
Joined: Sep 2006
Location: Safe haven from Zombies aka Flagstaff AZ
Oddometer: 805
I don't know if you looked...its the one listed in the Phx CL. Any chance you know the bike? I mean there are only so many Betas in AZ anyway.

And yes I am 6'4" at 225.
__________________
These are not the droids you are looking for.....
drdfblackm is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:54 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014