ADVrider

Go Back   ADVrider > Riding > Regional forums > Australia
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-01-2013, 02:17 AM   #4141
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
Also try the 15 min reset procedure, there is mixed feeling whether this does anything but who cares its worth a go, its meant to recalibrate the fuel injection. Remember to google as it searches adv better than adv searches itself.
Andy
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-01-2013, 02:31 AM   #4142
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
Also with 15000km on the bike it depends on cleanliness of the fuel put in it and whether it has a billet type raised filler to stop the dirt getting in the tank, what this could add up to is a dirty filter in the tank or even a dirty inlet gauze on the pump. These tanks generate a grey resin type residue which can clog the inlet gauze or the main fuel filter. I run a Profilter sock instead of the mesh on my pump inlet and have removed the internal filter to an external position. I change the external one every 7500km service and the Profilter at each 15000km. Obviously if you run with partially clogged filters your pump has a tough time and won't last as long.
Andy
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-01-2013, 02:32 AM   #4143
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
Fuck it just by a Triumph
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-01-2013, 03:13 AM   #4144
fatbloke49
Adventurer
 
fatbloke49's Avatar
 
Joined: Apr 2011
Location: Noosa QLD
Oddometer: 77
Quote:
Originally Posted by El Ponkin View Post
Fuck it just by a Triumph
Thanks



This will be the final time I pull the bike down before the APC, so might throw in a new fuel filter (withing the fuel tank), check on the Clutch switch, install the stand eliminator switch, clean the injector then take it to the shop to get it plugged in to the diagnostic machine to check mapping , air/fuel mixes etc...
fatbloke49 is offline   Reply With Quote
Old 05-01-2013, 03:45 AM   #4145
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
Be careful changing the filter as the plastic pipes are moulded on and very difficult to remove as well as being secured by special KTM clips which need special pliers to remove/install. You can refit with EFI hose clamps if you can find some to go that small, but it isn't a job for the faint hearted and be ultra careful not to kink the hoses when pushing the 200metres of umbilical chord back into the tank.

Plan B Fuck it just buy a Triumph
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-01-2013, 03:57 AM   #4146
MymoJoe
Ride Ride Ride
 
MymoJoe's Avatar
 
Joined: Sep 2005
Location: Fernvale QLD not close enough to the desert
Oddometer: 2,863
Come on..

Fair suck of the KTM690 fuel pump mate... I don't know old mate, so I was being nice....but you ya cheeky Git!!!

All good points raised Andy, sounds too much like the issues I had before I went to the Simpson..

02 sensor
Tps
Fuel pump and filter mods
And check- fix side stand switch.
Battery terminals (mine vibrated and had a crack in it)

Or

Buy a ktm625sxc ;)
Fuck the pommy heaps of shit!!!



I am too nervous to answer as I know Joe and Podge will be waiting to jump down my throat and say "its a 690 you should expect that shit or sell it" anyway with 20000kms under my belt I'll risk it.
__________________
Simpson Trip 2008

http://www.advrider.com/forums/showt...33#post7397233




Life should NOT be a journey to the grave with the intention of arriving safely in a well-preserved body, but rather to skid in sideways, body thoroughly used up, totally worn out and screaming "WOO HOO - what a ride!"
MymoJoe is offline   Reply With Quote
Old 05-01-2013, 04:09 AM   #4147
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-01-2013, 05:48 AM   #4148
chrisamberely
USMC. (retired).
 
chrisamberely's Avatar
 
Joined: Oct 2008
Location: West Aus/Texas
Oddometer: 137
Quote:
Originally Posted by fatbloke49 View Post
Went for a 800km ride on the week end from the Sunshine Soast to Childers and back via state forrest and had some issues that I hope can be sorted before I go on the APC in 16 days.
  1. The bike will only start when it's in neutral even if the clutch is pulled in. Is this a clutch switch issue or something to do with the side stand switch? If anyone knows how to fix this could you please upload a photo of the location of these switches?
  2. The bike has been doing it since I got it (15,000km on the clock). When the bike cranks over you have to give it a tiny bit of throttle to start it otherwise it just cranks over. When you give it a bit of throttle it coughs, farts and backfires into the air box. Could this be a mapping issue or something to do with a blocked fuel injector? I was looking at cleaning it like this video. http://youtu.be/1fbDUHlBQoU
  3. On the second day, when doing single track it would stall with low reves in corners but if you ride up to an intersection it will idle fine.
  4. One more from another ride, I pulled out of a service station and the bike just died like someone had turned the ignition switch off.
Any recommendations on any fixes for the above?

Only 16 days left to get it sorted......

Cheers,
Craig
AKA Fatbloke
Your 1st point, my bike is the same, I thought all 690's were like this.
2nd, could be the valves need an adjustment. Just a tweak.
3. Maybe just crap in the tank. Where did you get your gas? I just say that cause I gassed the truck at an el cheapo gas stop last weekend and she all but died on me later on. Turned out it was crap grade fuel. A friend gassed up at the same place and she got towed home. Her mech chained out her gas and she was good to go.
Maybe pull the tank and wash it out, I have no idea if injector cleaners work. Might be worth a try.
Do the throttle reset.
chrisamberely is offline   Reply With Quote
Old 05-01-2013, 06:12 AM   #4149
mrwocky117
Gnarly Adventurer
 
Joined: Mar 2009
Location: Brisvegas QLD Aus.
Oddometer: 158
Watts and watts of power !

What is the most people are running electrical wise, like, how much load combined are your lights, GPS, grip warmers radios, chargers, hair dryers, etc loading up the electrical system ? And has anybody had a stator failure or burn out, or drained battery due to excessive load ? Also any exact figures on how many Watts the FI system requires to operate correctly.
Reason been, I want to try and run 2 x 35 watt HID's and 2 x Ridgid Industries D2's ( 56 watts ).

Suggestions ?
mrwocky117 is offline   Reply With Quote
Old 05-01-2013, 03:04 PM   #4150
podge NT
Podge NT
 
podge NT's Avatar
 
Joined: Sep 2009
Location: Darwin NT
Oddometer: 2,246
Quote:
Originally Posted by El Ponkin View Post
I am too nervous to answer as I know Joe and Podge will be waiting to jump down my throat and say "its a 690 you should expect that shit or sell it" anyway with 20000kms under my belt I'll risk it.

1. Sounds like the sidestand switch you can buy the KTM sidestand switch eliminator which plugs in instead of the prox switch, you can make up your own resistor but its more trouble than its worth. The KTM bit is the same as the one for the 990, just google it and you will see lots of threads on it or I can fit for you.

2. This could be throttle rigging and the butterfly maybe closing off too much, if its under warrranty get the dealer to do it. There is a simple throttle electronic reset when you just open and close the throttle very slowly and evenly with ignition on and the electronics reset. Again google is your friend.

3 & 4. Could be loads of things, check your throttle body rubbers are seated correctly and not letting air in and clamps are not overtightened and rolling the rubber off the flanges. The injecfor can sometimes have a needle filter fitted and this can partially clog causing your symptoms, this can be removed and tossed or it could just be caused by throttle rigging as per above. As a big thumper they do occasionally have a cough stall at the most embarressing moment but just keeping it pinned stops that.

Righto now all you 690 dissenters tuck in and take your best shot.
Andy

Too busy to having fun on the Tiger at the moment to even think about 690 problems.
__________________
http://share.findmespot.com/shared/f...1IWs2Hg87TZcsW
Plan, what plan, there is no plan
podge NT is offline   Reply With Quote
Old 05-02-2013, 01:03 AM   #4151
El Ponkin
Bloodrunner
 
El Ponkin's Avatar
 
Joined: Oct 2006
Location: Brisbane
Oddometer: 2,013
Quote:
Originally Posted by chrisamberely View Post
Your 1st point, my bike is the same, I thought all 690's were like this.
2nd, could be the valves need an adjustment. Just a tweak.
3. Maybe just crap in the tank. Where did you get your gas? I just say that cause I gassed the truck at an el cheapo gas stop last weekend and she all but died on me later on. Turned out it was crap grade fuel. A friend gassed up at the same place and she got towed home. Her mech chained out her gas and she was good to go.
Maybe pull the tank and wash it out, I have no idea if injector cleaners work. Might be worth a try.
Do the throttle reset.

On the 1st point just checked 2011 and 2012 I have here and both will start in gear with the clutch in as long as the sidestand is up.
Andy
__________________
Don't Tempt Fate Taunt It, Right Here Right N0W
----------------------
KTM 690 EVO 1 Rally Raid Build Thread
KTM 690 EFI Idiots Guide
KTM 690 Troubleshooting Guide
El Ponkin is offline   Reply With Quote
Old 05-02-2013, 03:43 AM   #4152
fatbloke49
Adventurer
 
fatbloke49's Avatar
 
Joined: Apr 2011
Location: Noosa QLD
Oddometer: 77
Fixes

Cleaned the Injector and the bike starts up straight away now, man what a difference!
Did it the same as this video, http://youtu.be/1fbDUHlBQoU

Note: the 690 injector is under the air box and on top of the throttle body assembly. Also there was no inline filter after you undo the quick connect.

Took the clutch lever off and found that the clutch switch is working but the lever doesn't push the switch in far enough for it to work. So I,m getting a mate to put a bit of alumimium weld on the clutch lever so it pushes it in better. I will let you know how it goes when I get it back.
fatbloke49 is offline   Reply With Quote
Old 05-02-2013, 09:09 AM   #4153
001andrew
Just Add Sand
 
001andrew's Avatar
 
Joined: Aug 2008
Location: Sunshine Coast, Australia
Oddometer: 74
Throttle Calibration

Just got my spanking new 690 delivered and now I am up till all hours going through forums.............First fuel injected bike and there is a tip I had not heard of before? Throttle calibration?
Came across this just now,

http://www.monomaniacs.nl/tnt/KTM-69...hrottle-issues

Fat bloke, you ready to ride? I have had my bike for a week and only sat on it twice!!!!!!!!!! Arrrrrrrr
__________________
2013 690 with a few mods
001andrew is offline   Reply With Quote
Old 05-02-2013, 04:01 PM   #4154
fatbloke49
Adventurer
 
fatbloke49's Avatar
 
Joined: Apr 2011
Location: Noosa QLD
Oddometer: 77
Quote:
Originally Posted by 001andrew View Post
Just got my spanking new 690 delivered and now I am up till all hours going through forums.............First fuel injected bike and there is a tip I had not heard of before? Throttle calibration?
Came across this just now,

http://www.monomaniacs.nl/tnt/KTM-69...hrottle-issues

Fat bloke, you ready to ride? I have had my bike for a week and only sat on it twice!!!!!!!!!! Arrrrrrrr
I'm ready when you are......BUT I'm going on the APC rally in 15 days so it will have to be after that.

More than welcome to come over to Tewantin for a ride and go through the common issues..

I'm pulling my bike down to double check everthing.
fatbloke49 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:54 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014