ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (950/990cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-08-2008, 08:15 AM   #46
frog
Beastly Adventurer
 
frog's Avatar
 
Joined: May 2004
Location: Heber City, UT
Oddometer: 2,766
Quote:
Originally Posted by GaelicDog
If I try to crank it right after it dies it will not crank unless I crank the throttle and then it's like I am forcing it to run. If I hit the kill switch or the ignition and let the computer reboot it fires right up.
Same thing. If it dies and I try to fire it up without turning it off it spits and sputters unless I hold it wide open.
frog is online now   Reply With Quote
Old 09-15-2008, 05:25 PM   #47
Venteuri
I don't give a shit
 
Venteuri's Avatar
 
Joined: Sep 2007
Location: Queretaro , Mexico
Oddometer: 15,120
hey GD... read this thread: http://www.advrider.com/forums/showt...=369482&page=3


if it solves it... Its HOW material.
__________________
BMW R1200GSA 2014
Member #68,893
Above all stop pandering to posts from morons like Venteuri who can't even spell Venturi properly.
Venteuri is offline   Reply With Quote
Old 09-15-2008, 05:40 PM   #48
frog
Beastly Adventurer
 
frog's Avatar
 
Joined: May 2004
Location: Heber City, UT
Oddometer: 2,766
My 990 is headed into the shop tomorrow. Has anyone had any progress or a fix for this?
frog is online now   Reply With Quote
Old 09-18-2008, 10:22 AM   #49
bushnbikes
Adventurer
 
bushnbikes's Avatar
 
Joined: Nov 2006
Location: New Zealand
Oddometer: 49
Hi

Sorry, no answers in this one, only another bike to add to the list of those with problems. I haven't been on-line for about 18 months. I didn't really see much about these fueling/ ECU ellusive problems last time but it's certainly been interesting reading this time around. I'm going to at least change my fuel filter when I get home.

I've been lucky enough to only experience a few dying motor episodes (mostly in the centre of a 4 lane roads in heavy 60mph traffic!) My dead engine events don't seem to have been linked to the use of clutch and they were on fully warm engines. I've also had other issues with my standard 2006 990: Water pump seal & clutch slave cylinder replaced under warranty. Heavier spring placed behind valve in hydraulic cam chain tensioner plumbing. Original rear brake lines replaced with re-routed ones. Problem with rear brake caliper not releasing fully (wearing pads & rotor much to fast). Irratic throttle response, sometimes 5000rpm startups, get variation of up to 1000rpm with constant throttle (in neutral) and the motor is inconsistently noisey. I've generally been frustrated by the response from the local dealer workshops. Once the warranty is finished I'll be stripping the bike down myself and I hope to sort everything properly! It's not quite the "ideal on paper" bike I thought I was buying.

I sometime ride rocky slow tracks. Nearly every time, I have been annoyed by the off / on switch effect in the bike. I sometimes wonder if the "fallover cutout switch" plays a roll in that problem. It may be something else to look at for your bikes' problem to??

It may be a while before I am able to get back to this site but I eagerly await seeing some updates on how everyone is getting on with solving these issues.

Even with these various problems it's still possible to get out and feel the freedom of a bike and have a bit of fun sometimes (even though it seems I'm riding 500cc!).

Cheers
bushnbikes is offline   Reply With Quote
Old 09-26-2008, 01:52 PM   #50
roaddog7
n00b
 
Joined: Apr 2008
Location: Northeast
Oddometer: 4
I have a 2007 KTM 990 Adventure "HELP"

I just bought a left over 07 990. I have Akra's on my bike. I have 1500 miles on her. I'm finding when your on the throttle the bike is beautiful and sounds great. When you get into the city and trying to cruise at +3000- rpm it starts to dance and becomes skiddish, up and down, WHY??? I've tried 89oct, 91oct, wait for two and four bar warm ups and it still does it. I talked to someone today and he asked if the throttle bodies were synchronized at idle and at 3000rpm!!!! Do you all find that the accelerator grip is to sensitive? Is it the nature of the beast? I've had a Husqvarna, Ducati and BMW not an issue. What's up with KTM????

roaddog7 screwed with this post 09-29-2008 at 10:49 AM
roaddog7 is offline   Reply With Quote
Old 09-27-2008, 10:39 AM   #51
frog
Beastly Adventurer
 
frog's Avatar
 
Joined: May 2004
Location: Heber City, UT
Oddometer: 2,766
Try a g2 throttle cam. It wil help with the snatchy throttle. My throttle is fine it just stalls and is back in the shop for the fourth time to try a few other fixes.
frog is online now   Reply With Quote
Old 09-28-2008, 01:55 PM   #52
spsduc
spsduc
 
spsduc's Avatar
 
Joined: Apr 2005
Location: Dunedin, New Zealand
Oddometer: 99
Quote:
Originally Posted by GaelicDog
Basics: 2007 KTM 990 Adventure EFI, 10,000 miles, Akro's, pre-filter.

Bike has run flawless until last week, and the issues are sparatic:

Crank bike, 2500 RPM's, after a minute or 2 it'll drop back to 1250 and idle perfect. Or crank it and get a perfect idle.

Riding down the road and pull the clutch in, bike will idle around 3000, may settle down to 2000 or so, may not.

Stop at traffic light, bike has a really fast idle 2000 to 3000. Hit kill switch, recrank bike and it's a perfect 1250 again.

????????????????


I have a 990s which does the high reving idle thing. It did it with the std map and Akrapovic map.

The answer I believe is making sure you don't push the starter button until the bike has done it's full sweep of the rev counter and whatever else after you turn the key on.
If I am impatient and turn the key and push the button without waiting then I have the high idle problems.

If I have the problem I turn it off. Turn the key on let it do it's thing then start and let idle for a minute or two and it seems to solve it.

Sorry but have never had stalling issues.

Hope this helps.

Good luck.
spsduc is offline   Reply With Quote
Old 09-30-2008, 11:40 AM   #53
GaelicDog OP
Lesser of Two Weasels
 
GaelicDog's Avatar
 
Joined: Jun 2004
Location: Atlanta, GA
Oddometer: 7,322
Couple of weeks ago I take the bike to the shop again. Hook it to the diagnostic program and she's fine! Baffles everyone. Then I hear the fuel pump making a distinct Whrrrrrrrrrrrrrrrrrrr noise. The mechanic says he is running a program which makes the pump run and self check itself.

After this the bike runs DAMNED PERFECT!!!!!!! For about 2 weeks. I did the 2Day Breast Cancer Walk using this bike, perfect. Ridden 3 or 4 hundred perfect miles.

I am thinking the fuel pump during the self check may have cleared some lind of blockage.

I figure what the hell? I pull the tank off and go ahead and replace the fuel filters. Get her back together and she is still perfect, actually I feel she is better than the day I bought her.

About a week more of perfect riding then yesterday after filling up (and it's not topped off) and now I am getting the fast idle again. Pull in the clutch and it will be anywhere between 2000 and 3200 RPM's. Turn it off and on, crank it and she's back to 1400 RPMS.




__________________
Political Correctness is a doctrine fostered by a delusional, illogical, liberal minority, and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end.
GaelicDog is offline   Reply With Quote
Old 09-30-2008, 12:14 PM   #54
Venteuri
I don't give a shit
 
Venteuri's Avatar
 
Joined: Sep 2007
Location: Queretaro , Mexico
Oddometer: 15,120
Have ou tried holly water?
__________________
BMW R1200GSA 2014
Member #68,893
Above all stop pandering to posts from morons like Venteuri who can't even spell Venturi properly.
Venteuri is offline   Reply With Quote
Old 09-30-2008, 01:09 PM   #55
alphajory
Studly Adventurer
 
alphajory's Avatar
 
Joined: Mar 2008
Location: canada
Oddometer: 589
are all of the vents clear? does the erratic idle happen shortly after a you fill up?
alphajory is offline   Reply With Quote
Old 09-30-2008, 02:50 PM   #56
GaelicDog OP
Lesser of Two Weasels
 
GaelicDog's Avatar
 
Joined: Jun 2004
Location: Atlanta, GA
Oddometer: 7,322
Quote:
Originally Posted by alphajory
are all of the vents clear? does the erratic idle happen shortly after a you fill up?

The stalling episodes used to happen a little more often right after fill up or at almost empty. This fast idle bullshit, at least this time started after a fill up but has continued for 90 miles.


Jerry
__________________
Political Correctness is a doctrine fostered by a delusional, illogical, liberal minority, and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end.
GaelicDog is offline   Reply With Quote
Old 10-03-2008, 08:12 PM   #57
dagwood
Banned
 
dagwood's Avatar
 
Joined: Aug 2003
Location: Vancouver, Not! BC...
Oddometer: 35,427
Quote:
Originally Posted by frog
My 990 is headed into the shop tomorrow. Has anyone had any progress or a fix for this?



not yet. mine is erratic. some days it's ok then others.


not Even going well today. ran great for three days after the Dealer remapped with the Acro map then same old shit again Wednesday. idles at barely 1k then sometimes it's 2,2k. then the dropping cylinder issue is back at 4500-5500-. four tanks a gas thrue it in a week and it just keeps getting worse.

fuck it I'm putting the 640 back together and selling the 990. today really sucked.
dagwood is offline   Reply With Quote
Old 10-03-2008, 10:14 PM   #58
Lobby
Viel Spass, Vato!
 
Lobby's Avatar
 
Joined: Nov 2003
Location: San Antonio, Tx
Oddometer: 27,890


So GaelicDog and Dagwood are both having the exact same problem?



Have you considered making the dealer take them back? Lemon Law? Perhaps this would get KTM's attention and they'd address the problem.
__________________
Gracie's Gold
Lobby is offline   Reply With Quote
Old 10-03-2008, 10:35 PM   #59
marin ktm
Gnarly Adventurer
 
Joined: Feb 2008
Location: Marin County, CA
Oddometer: 322
mine still does the low idle, on the verge of stalling thing about 20% percent of the time. It has never had a fast idle problem.
marin ktm is offline   Reply With Quote
Old 10-04-2008, 08:22 AM   #60
frog
Beastly Adventurer
 
frog's Avatar
 
Joined: May 2004
Location: Heber City, UT
Oddometer: 2,766
Mine is in the shop for the forth time. Every state is different but to lemon law a vehicle in Utah you need 5 repair orders and attempted fixes with no fix. The you must yell and scream loud enough that they would rather trade you out of your bike. We'll see if they fix it this time and if they do I'll post the fix.
frog is online now   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:32 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014