ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-15-2013, 08:03 PM   #121
AJ990R
motorcycle guy
 
AJ990R's Avatar
 
Joined: Dec 2011
Location: MKE,WI
Oddometer: 191
Quote:
Originally Posted by Pistolero View Post


also look at this post from a SMT forum by kevxtx http://www.ktmsmt.com/viewtopic.php?f=3&t=3394#p11478
Thanks Pistolero! I will do as you say need some time before I can verify & report the results...
__________________
"saddle up or shut up"
KaTooM North
AJ990R is offline   Reply With Quote
Old 12-15-2013, 08:34 PM   #122
Pistolero
W. F. O.
 
Pistolero's Avatar
 
Joined: Mar 2011
Location: TN
Oddometer: 708
Quote:
Originally Posted by AJ990R View Post
Thanks Pistolero! I will do as you say need some time before I can verify & report the results...

Please PM me your results in detail. I'm trying to get to the bottom of this crap. Good luck!
Pistolero is offline   Reply With Quote
Old 12-16-2013, 02:58 AM   #123
rider911
Gnarly Adventurer
 
rider911's Avatar
 
Joined: Sep 2009
Location: Australia
Oddometer: 407
Quote:
Originally Posted by Gustavo.Ramos View Post
Not trying to be a smartass, but can't you just buy your friend's 2011 TB's? He obviously does not ride as they're more time apart than on his bike!
Yeah I know, lucky he works away. Got to get this sorted as he'll be home for Xmas.
I'd buy his bike but the fuel injection is worn out.

This is getting very difficult to diagnose as the severity of the problem keeps changing when using my original parts.
I believe the problem is in the throttle body wiring harness, there is a common wire shared by both injectors which means there is obviously a join inside the harness. I can register a slight resistance abnormality when testing it with a multimeter but its small enough to still keep some doubt in my mind. I hope to cut it open this week.

At the moment I cant get it to play up with the 2011 harness but who knows what happens tomorrow Ive got to put the new bike back together by the end of the week.



.
__________________
New RR ~ Across OZ... Corner by Corner

08 KTM 300 exce (small)
12 KTM 500 exc (medium)
07 KTM 990 Adv (large)
rider911 is offline   Reply With Quote
Old 12-16-2013, 03:55 PM   #124
Gustavo.Ramos
Studly Adventurer
 
Gustavo.Ramos's Avatar
 
Joined: May 2008
Location: Accross the pond
Oddometer: 738
Ain't the best solution, but i'd be sourcing an alternative set of TB's. random electrical issues are a PITA to diagnose and often you spend more hours than its worth a good used replacement unit.

Yet i fully understand your persistance to get it done and find the root cause of it.
__________________
Growing old is mandatory... growing up is optional!

Raid de L'Amitié 2011 RR (link)
690R
Gustavo.Ramos is offline   Reply With Quote
Old 12-17-2013, 05:21 AM   #125
rider911
Gnarly Adventurer
 
rider911's Avatar
 
Joined: Sep 2009
Location: Australia
Oddometer: 407
yes I know you are right but Id hate to think this thing is going to beat me.

Ive already spent too much time on this, so now its just a challenge

If I find the harness is definately the problem then maybe its the root cause of lots of peoples problems.


.
__________________
New RR ~ Across OZ... Corner by Corner

08 KTM 300 exce (small)
12 KTM 500 exc (medium)
07 KTM 990 Adv (large)
rider911 is offline   Reply With Quote
Old 03-07-2014, 02:56 PM   #126
dgjackson40
Gnarly Adventurer
 
Joined: Mar 2010
Location: Central Missouri USA
Oddometer: 239
Any Progress

I wonder how all this turned out??
__________________
The trail is the thing, not the end of the trail. Travel too fast and you miss all you are traveling for. Louis l'Amour
2007 KTM 990 Adv; 2005 VStar 1100 Sold!; 2002 GL1800
dgjackson40 is offline   Reply With Quote
Old 03-08-2014, 02:25 AM   #127
gefr
Life is a trip
 
gefr's Avatar
 
Joined: Nov 2005
Location: East Med, Greece
Oddometer: 3,756
I would suggest replacing only the front TPS and adjusting it.

And take it from there.
Cheers.
gefr is offline   Reply With Quote
Old 03-24-2014, 10:22 AM   #128
Pistolero
W. F. O.
 
Pistolero's Avatar
 
Joined: Mar 2011
Location: TN
Oddometer: 708
Quote:
Originally Posted by dgjackson40 View Post
i wonder how all this turned out??

+1
Pistolero is offline   Reply With Quote
Old 03-26-2014, 07:46 PM   #129
Bighat
Adventurer
 
Joined: Nov 2013
Oddometer: 35
TPS or fuel injection harness....or battery voltage ?
Bighat is online now   Reply With Quote
Old 03-27-2014, 08:58 AM   #130
Gustavo.Ramos
Studly Adventurer
 
Gustavo.Ramos's Avatar
 
Joined: May 2008
Location: Accross the pond
Oddometer: 738
Quote:
Originally Posted by Bighat View Post
TPS or fuel injection harness....or battery voltage ?
The usual suspects...
__________________
Growing old is mandatory... growing up is optional!

Raid de L'Amitié 2011 RR (link)
690R
Gustavo.Ramos is offline   Reply With Quote
Old 03-27-2014, 02:49 PM   #131
Pistolero
W. F. O.
 
Pistolero's Avatar
 
Joined: Mar 2011
Location: TN
Oddometer: 708
Pistolero is offline   Reply With Quote
Old 03-28-2014, 01:44 AM   #132
rider911
Gnarly Adventurer
 
rider911's Avatar
 
Joined: Sep 2009
Location: Australia
Oddometer: 407
I ended up replacing the complete throttle body harness. So FI, stepper motor and TPS.
Its working perfectly BUT I couldnt identify exactly where the problem in the harness is. Maybe its in the big grey plug but it looks fine.
I swapped harnesses back and forth several times to be sure the harness was the problem. Each time the bad harness was fitted it didn't always rev high BUT it always ran slightly erratic, the new harness was always perfect.

I would like to understand how the stepper motor is meant to be adjusted but as yet I have not read anything that has any credibility. I believe that some peoples problems lie in that adjustment.
__________________
New RR ~ Across OZ... Corner by Corner

08 KTM 300 exce (small)
12 KTM 500 exc (medium)
07 KTM 990 Adv (large)
rider911 is offline   Reply With Quote
Old 03-28-2014, 02:01 AM   #133
rider911
Gnarly Adventurer
 
rider911's Avatar
 
Joined: Sep 2009
Location: Australia
Oddometer: 407
I know Gefr is convinced that TPS's are the root cause of these weird idle events but I dont think so. It would be interesting to unscrew the TPS or plug in another TPS whilst the bike is idling and manually move the TPS thru its entire range without touching the throttle. I wonder what the motor would do?
__________________
New RR ~ Across OZ... Corner by Corner

08 KTM 300 exce (small)
12 KTM 500 exc (medium)
07 KTM 990 Adv (large)
rider911 is offline   Reply With Quote
Old 03-28-2014, 03:18 PM   #134
gefr
Life is a trip
 
gefr's Avatar
 
Joined: Nov 2005
Location: East Med, Greece
Oddometer: 3,756
I am sure TPS is one of the factors.

When TPS voltage is out of range, idle hangs at 4000rpm and when the throttle is closed, it sometimes dies abruptly. Idle sometimes hangs at 1000rpm.
I also believe EPS has a negative effect in the motor's smoothness.
Cheers.
gefr is offline   Reply With Quote
Old 03-30-2014, 12:21 AM   #135
ManuC
950 SM
 
Joined: Dec 2013
Location: Ardennes Belgium
Oddometer: 34
http://ktmadventure.asiafreeforum.co...leme%20ralenti

It's in french but may help
ManuC is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:35 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014