ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-18-2013, 03:33 AM   #46
coconuttele
Adventurer
 
Joined: Nov 2011
Location: New Haven Ct
Oddometer: 61
Had the same problem on my 07, went months chasing and testing wires. Ended up being the ABS switch on the dash was broke. Another inmate pointed it out. $35 dollars later, it was fixed. Of you have tried everything else, switch it out and see where it takes you.
coconuttele is offline   Reply With Quote
Old 03-18-2013, 06:22 PM   #47
DARKRYDER
NoNoob
 
DARKRYDER's Avatar
 
Joined: Jun 2010
Location: Santa Clara
Oddometer: 316
Quote:
Originally Posted by coconuttele View Post
Had the same problem on my 07, went months chasing and testing wires. Ended up being the ABS switch on the dash was broke. Another inmate pointed it out. $35 dollars later, it was fixed. Of you have tried everything else, switch it out and see where it takes you.
My bike doesn't have ABS, it's a 990 R. I thinking it's the cable assembly itself. Does any know the exact part number I need to order? The issue started after I wired in Rigid LED fog lights and installed a Scotts triple clamp and damper. I was careful not to pinch or kink any wires so I don't know if it's just coincidence or what.
__________________
10 KTM 990 Adventure R
10 KTM 530 EXC-R Champions Edition
05 Merc E55 AMG
3 Kaboom's, 3 Dudes, and a Chick ride Nevada, Utah, Wyoming, Colorado, Idaho, Montana
Passed Out In CO & Washed Up In UT (UTBDR & COBDR)
DARKRYDER is offline   Reply With Quote
Old 03-23-2013, 10:44 AM   #48
DARKRYDER
NoNoob
 
DARKRYDER's Avatar
 
Joined: Jun 2010
Location: Santa Clara
Oddometer: 316
Searched the KTM parts diagrams and found the part number for the sensor/cable assembly for anyone else that cares:

Speedometer Sensor 10 - 62514068200

I'm going to try replacing this part first and hopefully that solves the issue.
__________________
10 KTM 990 Adventure R
10 KTM 530 EXC-R Champions Edition
05 Merc E55 AMG
3 Kaboom's, 3 Dudes, and a Chick ride Nevada, Utah, Wyoming, Colorado, Idaho, Montana
Passed Out In CO & Washed Up In UT (UTBDR & COBDR)
DARKRYDER is offline   Reply With Quote
Old 03-23-2013, 10:37 PM   #49
DARKRYDER
NoNoob
 
DARKRYDER's Avatar
 
Joined: Jun 2010
Location: Santa Clara
Oddometer: 316
Tore the bike back apart today and found the problem. The thin red wire in the speedometer cable had cracked/severed near the lower triple clamp where the cable flexes a lot with the factory routing. I resoldered the wire, wrapped and rerouted the cable. Now my speedo and odo work perfectly again. Total cost to fix - $0
__________________
10 KTM 990 Adventure R
10 KTM 530 EXC-R Champions Edition
05 Merc E55 AMG
3 Kaboom's, 3 Dudes, and a Chick ride Nevada, Utah, Wyoming, Colorado, Idaho, Montana
Passed Out In CO & Washed Up In UT (UTBDR & COBDR)
DARKRYDER is offline   Reply With Quote
Old 07-11-2013, 04:44 AM   #50
Skinner
Mr.KTM
 
Skinner's Avatar
 
Joined: Oct 2004
Location: Lake county Il
Oddometer: 5,588
Hey all, I just bought a spare set of wheels with tires etc, They came a bike with ABS, my 2013 Baja has no ABS. Well I put the wheels on did not pay attention to the ABS plate, I damaged the speed sensor on my non abs bike, I replaced it and removed the abs plate. Still speedometer reads zero! Is there something different on one than the other? Is there different bolts or something that the other wheel has that the original has different? They look the same to me.
__________________
You might be an ADVRider if:

You recognize your friends by the sound of their mufflers.
http://www.meetup.com/Chicagoland-Du...torcycle-Club/
www.jimstarwaltteam.com
Skinner is offline   Reply With Quote
Old 07-11-2013, 05:51 PM   #51
Skinner
Mr.KTM
 
Skinner's Avatar
 
Joined: Oct 2004
Location: Lake county Il
Oddometer: 5,588
Up date!!! I had the speed sensor on 180 degrees wrong! The cable faces down and towards the back!
All is good now
__________________
You might be an ADVRider if:

You recognize your friends by the sound of their mufflers.
http://www.meetup.com/Chicagoland-Du...torcycle-Club/
www.jimstarwaltteam.com
Skinner is offline   Reply With Quote
Old 09-29-2013, 11:18 AM   #52
Lennys
Gnarly Adventurer
 
Joined: Jul 2013
Location: Crackiforia/Baja
Oddometer: 151
First real ride yesterday and my speedometer went on the blink, 2013 990 Baja and it jumps all over the place, where do I start
__________________
2013 990 adventure Baja
2010 xcw 530
Lennys is offline   Reply With Quote
Old 09-30-2013, 05:34 AM   #53
mathews42
Gnarly Adventurer
 
mathews42's Avatar
 
Joined: Jun 2012
Location: Colorado Springs
Oddometer: 336
Start at the dealer if its a 2013 it should be under warranty.

I had the same issue on my 07 and it was the speedo sensor.
__________________
Beads in the headlight a Flying Aga Tale by Isabel Dyson I met these two travelers on their Journey from the UK to Alaska and through South America on a 1979 BMW R100RS. Their book is now on Amazon for Kindle.
mathews42 is online now   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:49 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014