ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-13-2010, 06:35 PM   #1
Trike Flyer OP
Adventurer
 
Joined: Feb 2010
Location: Northern Indiana
Oddometer: 25
F650GS Speedo not working

I'm looking at a 03 f650gs that has a speedo that is not working. Any thoughts on what may be the issue?

Thx
Jeff
Trike Flyer is offline   Reply With Quote
Old 03-14-2010, 04:12 AM   #2
Zoef zoef
Gnarly Adventurer
 
Joined: Apr 2009
Location: Finnøy Island, near Stavanger, Norway
Oddometer: 396
If I'm not mistaken, the F650GS uses a sensor on the back wheel to determine the speed. First check if the distance is working or not.
If distance is working:
  • Speedo is probably defective
If distance is also not working:
  • Distance between sensor and ring could be faulty
  • Sensor could be broken
  • Wiring between sensor and speedo broken somewhere
Zoef zoef is offline   Reply With Quote
Old 03-14-2010, 04:51 AM   #3
veesquared
Gnarly Adventurer
 
Joined: Feb 2004
Location: Center of the Smokies
Oddometer: 126
speedo

have a look at the wire itself from the rear sensor. I have seen the tire rub through the wire. Also up under the speedo itself is a connector . There is a bail that holds it in position cheap piece of black plastic Make sure the plug is setting on the pickup pins . I have had problems with moisture as well making the speedo quit until it dried out.
__________________
KTM 1190 KTM 690 E KTM 200 Exc
veesquared is offline   Reply With Quote
Old 03-14-2010, 06:17 AM   #4
Capt. REDBEARD
TWECO
 
Capt. REDBEARD's Avatar
 
Joined: Oct 2008
Location: buzzards bay
Oddometer: 1,131
ditch it!

if you continue to have problems you might want to consider replacing it with a vapor or another aftermarket equivalent - a few folks around here have been doing that lately. Also if you are interested in keeping the OEM set-up I have a used speedo off of a 2003 w/14000k miles that I would be willing to part with..............


sorry I can't be more help - but it is a matter of back tracking wires from the unit out to make sure they are not compromised - and then checking with a volt meter at the speedo to make sure everything is providing the right juice.
__________________
1976 R60/6, 2009 530 EXC, 2008 250 XC, 2004 950 ADV

if the ocean were whiskey and I were a duck - I'd swim to the bottom and never come up
Capt. REDBEARD is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:12 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2015