ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-23-2009, 02:05 PM   #1
the venturer OP
Beastly Adventurer
 
the venturer's Avatar
 
Joined: Mar 2007
Location: Thrace and Istanbul
Oddometer: 1,409
F650 GS 15000 km maintenance

Hi there everybody. I am tired but glad that I have changed the oil and filters as well as battery check up. All by myself.
I want to share the pics with you.
I removed the side panels first. Don't be afraid and unscrew everything on the side panels. Panels are flexible enough. There are some screws holding them together.

Removing the oil tank.

This is the tap. Empty the oil from here.



Terrible oil.

Then I dismounted the crankcase protectors.


Removing the oil filter



And finally that sump plug. This is aluminium and very prone to deteriorate. Be very careful when you unscrew it; counter clockwise.
''Filtro Magnetico'' does the job. There were some metal scraps around it.


Front sprockets seem like new though 15.000 km on them. I cleaned both front and rear sprockets as well.

There was some oil seeping just under the engine block. Why? What do you think? Is this normal?

Then I came to one of the typical problems of F series. Sidestand connector and switch. Somewhere here I started a thread on how to remove sidestand switch and here I have some pics showing the connector this time. This is a complicated one. I ll try to explain how it works. Three tiny needles in it. Number 2 in the middle and the other two on sides. There is a mini piston in it. I think this piston moves that needle in the middle to the sides. There is an electrical connection between them each time the sidestand on the bike moves up and down and this movement completes the electrical circuit.
It doesn't seem to me that someone can fix it. So, I cleaned and sprayed it. The next time it causes me a problem, I am gonna cut the wires and solder them directly, eliminating the connector and the switch.



Next is air filter. A perplexing situation there. Just behind the air filter, there was some oil.

I dried it with a cloth.

15.000 km oily air filter

And the oil. Black is the old one and the light one is 10-40 semi synthetic oil.

On the way to the air filter, there is an air snorkel and it is not steady in its place. Is this normal? Do you think I should fix it there?

Another question is the coolant reservoir. It was almost empty. And it is still. Which antifreeze I should buy and what is the changing procedure? Can anybody here guide me through?

And finally there was no water in the battery. I refilled it and charged for two hours. Seems better though it never caused me a problem.
I hope this thread will help someone who needs it.
Ride safely you all.
the venturer
the venturer is offline   Reply With Quote
Old 05-23-2009, 05:34 PM   #2
tmotten
Lefthand ride Dutchy
 
tmotten's Avatar
 
Joined: Jun 2006
Location: Calgary
Oddometer: 2,449
The oil thing is difficult to explain with that picture. But oil has a habbit to cling to the motor untill the absoluty lowest point untill it drips. So keep an eye on it, but I'd guess it could be spilled oil from the oil filter cavity.

The oil in the air box is normal. It's a storage reservoir and should be emptied through the drain hose at a regular interval. Good reason to get a foam air filter though. http://www.uniflow.com.au/

Snorkel on the airbox should be tight, but if you get a uniflow it will be very tight.

The coolant burp tank should have fluid in it. Check your manual.

I'd ditch the wet cell battery for a maintenance free one.
tmotten is offline   Reply With Quote
Old 05-24-2009, 12:03 AM   #3
the venturer OP
Beastly Adventurer
 
the venturer's Avatar
 
Joined: Mar 2007
Location: Thrace and Istanbul
Oddometer: 1,409
Thank you tmotten. I believe that visual information comes first rather than words only. I emptied the oil out of three places. Oil tank, then comes the oil filter out, and finally sump plug removal. I waited about half an hour to let the whole oil flow out. I asked for the mixture of antifreeze and water? And the name of antifreeze? I know very well that a different one might harm the hoses of the radiator. I had once experienced this with my car. Then, I should tighten the air snorkel on the air box. Thank you for your comments.
the venturer is offline   Reply With Quote
Old 05-24-2009, 04:43 AM   #4
JDLuke
Ravening for delight
 
JDLuke's Avatar
 
Joined: May 2007
Location: New Jersey
Oddometer: 8,644
On the oil: I had a similar drip, more noticeable on the left side than the right. It turned out that most of the bolts holding my engine together had worked loose. Scary, but easily fixable. Go over all your fasteners, you might be surprised at how loose some of them are. The oil in your airbox, though, indicates that your bike has been over-filled with oil at least once. There is certainly a possibility that this is the source of the oil at the bottom of your engine, too.

Anti-freeze: I'm not going to recommend a brand. I believe (without referring to my manual) that BMW simly calls for a silicate-free coolant, there are plenty of them out there. Some come pre-mixed, most call for 50:50 dilution with water.

I agree with the call to replace the battery (which sits immediately above the engine and literally cooks itself to death) with a sealed one when you next find yourself having to buy a battery. I got a 'Scorpion' branded one from batterystuff.com that dropped in perfectly and works a treat.
__________________
Why did I drink all of the ingredients for vomit?
"Used to be Man vs. Nature.. then Man vs. Space.. then Man vs. the Moon. Now it's Man vs. Food" - Dalar
"you cannot reason a person out of something they were not reasoned into." - Jonathan Swift
JDLuke is offline   Reply With Quote
Old 05-24-2009, 09:50 AM   #5
the venturer OP
Beastly Adventurer
 
the venturer's Avatar
 
Joined: Mar 2007
Location: Thrace and Istanbul
Oddometer: 1,409
Quote:
Originally Posted by JDLuke
On the oil: I had a similar drip, more noticeable on the left side than the right. It turned out that most of the bolts holding my engine together had worked loose. Scary, but easily fixable. Go over all your fasteners, you might be surprised at how loose some of them are. The oil in your airbox, though, indicates that your bike has been over-filled with oil at least once. There is certainly a possibility that this is the source of the oil at the bottom of your engine, too.

Anti-freeze: I'm not going to recommend a brand. I believe (without referring to my manual) that BMW simly calls for a silicate-free coolant, there are plenty of them out there. Some come pre-mixed, most call for 50:50 dilution with water.

I agree with the call to replace the battery (which sits immediately above the engine and literally cooks itself to death) with a sealed one when you next find yourself having to buy a battery. I got a 'Scorpion' branded one from batterystuff.com that dropped in perfectly and works a treat.
Changing the coolant, flushing it out or refilling causes many problems. A good brand one, finely diluted, would suit the bike's need I think.
As regards to the oil, I am gonna check those bolts down the engine. This is the first time that I myself have changed the oil. It might have been an overfill. Thank you JDLuke.
the venturer is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:30 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014