ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-10-2013, 12:06 AM   #3616
WILL_S
OUTLAW POSTIE 001
 
WILL_S's Avatar
 
Joined: Feb 2009
Location: goodly satisfactory place, qld
Oddometer: 2,075
After fitting the safari tank i've noticed my fan coming on more often.The weather is cooler but the fan seems to be running more.Anyone else noticed this after fitting the safari tank?
__________________
out riding bored and stroked posties....braaaaaaaaaap
WILL_S is offline   Reply With Quote
Old 04-11-2013, 09:57 AM   #3617
SilverBullet
Gnarly Adventurer
 
Joined: Oct 2009
Location: Harmaston, TX
Oddometer: 391
TE610 thread

Anybody know what happened to the TE610 thread? My subscribed link is no longer showing up and I searched and can't find it. Did they merge it into this thread? Many things in common with our TE630's so I always liked to keep current there also.

_
__________________
2011 Husqvarna TE630
2004 Suzuki VStrom 650
2002 KTM 300EXC
1974 Suzuki TM400
SilverBullet is online now   Reply With Quote
Old 04-11-2013, 10:05 AM   #3618
rickcj7
Gnarly Adventurer
 
rickcj7's Avatar
 
Joined: Jun 2010
Location: Hollidaysburg PA
Oddometer: 446
Quote:
Originally Posted by SilverBullet View Post
Anybody know what happened to the TE610 thread? My subscribed link is no longer showing up and I searched and can't find it. Did they merge it into this thread? Many things in common with our TE630's so I always liked to keep current there also.

_

http://www.advrider.com/forums/showthread.php?t=156429
__________________
Husqvarna TE630

WR250R sold
FE450E sold
XT, NX, KLX, KLR, DR all long gone.
rickcj7 is online now   Reply With Quote
Old 04-12-2013, 05:52 AM   #3619
SilverBullet
Gnarly Adventurer
 
Joined: Oct 2009
Location: Harmaston, TX
Oddometer: 391
Quote:
Originally Posted by rickcj7 View Post
Thanks. My search didn't find it because I wasn't putting in the dash. Still don't know why I got unsubscribed though.

_
__________________
2011 Husqvarna TE630
2004 Suzuki VStrom 650
2002 KTM 300EXC
1974 Suzuki TM400
SilverBullet is online now   Reply With Quote
Old 04-20-2013, 06:26 PM   #3620
asi00007
Adventurer
 
Joined: Apr 2010
Location: Melbourne
Oddometer: 62
Fuel pump issue

Hi guys..

I put it on CH as well..



I got my 630 two month ago and I did 800 KM on it.. I just love that bike.. amazing what I can do with it.. well.. its me how try to keep up with the bike
But I have a problem .. Yesterday i took a ride to the bush and everything go well until we decided to head home , so I'm trying to start up the bike and nothing happend .. the fuel pump doesn't make any noise .. everything else is working fine .. after a few phone calls I tried again and suddenly it making the regular BZZZ and she fire up in a second and the N flash once , I'm going tomorrow to the dealer to sort that out but I wonder if anyone else here had the same problem .. I didn't find any information on CH but I'll be happy if someone have information about this issue

Asi

asi00007 screwed with this post 04-20-2013 at 10:29 PM
asi00007 is offline   Reply With Quote
Old 04-20-2013, 11:16 PM   #3621
WILL_S
OUTLAW POSTIE 001
 
WILL_S's Avatar
 
Joined: Feb 2009
Location: goodly satisfactory place, qld
Oddometer: 2,075
Hi have a look here

http://www.cafehusky.com/threads/doc...k-areas.30149/

Welcome to the weird electrical faults some 630's suffer.
__________________
out riding bored and stroked posties....braaaaaaaaaap
WILL_S is offline   Reply With Quote
Old 04-20-2013, 11:27 PM   #3622
asi00007
Adventurer
 
Joined: Apr 2010
Location: Melbourne
Oddometer: 62
Hi

I already looked there.... didn't find anything about the pump problem
there is the Fuel tank leaks and the temp sensor problem that i'm aware of

Ill keep you posted when i find somthing

asi00007 screwed with this post 04-20-2013 at 11:34 PM
asi00007 is offline   Reply With Quote
Old 04-21-2013, 07:36 AM   #3623
browneye
PIN IT & BANG GEARS
 
browneye's Avatar
 
Joined: Dec 2009
Location: Orange County, CA
Oddometer: 4,287
Quote:
Originally Posted by asi00007 View Post
Hi guys..

I put it on CH as well..



I got my 630 two month ago and I did 800 KM on it.. I just love that bike.. amazing what I can do with it.. well.. its me how try to keep up with the bike
But I have a problem .. Yesterday i took a ride to the bush and everything go well until we decided to head home , so I'm trying to start up the bike and nothing happend .. the fuel pump doesn't make any noise .. everything else is working fine .. after a few phone calls I tried again and suddenly it making the regular BZZZ and she fire up in a second and the N flash once , I'm going tomorrow to the dealer to sort that out but I wonder if anyone else here had the same problem .. I didn't find any information on CH but I'll be happy if someone have information about this issue

Asi

Sometimes I have to jiggle the ignition switch or re-click it. Like a sticky contact or something.
I suppose one day I'll be forced to hot-wire it in the field.
__________________
Chris Brown - "The Browneye"
"Without Motorcycles, People Live Very Boring Lives." - Malcolm Smith
browneye is online now   Reply With Quote
Old 04-21-2013, 07:44 AM   #3624
asi00007
Adventurer
 
Joined: Apr 2010
Location: Melbourne
Oddometer: 62
I have that feeling its coming from the kill switch on the handle bar
asi00007 is offline   Reply With Quote
Old 04-24-2013, 11:07 PM   #3625
Maxyb
Falling over slowly
 
Maxyb's Avatar
 
Joined: Dec 2011
Location: Radelaide
Oddometer: 104
I decided to weigh my 630 to work out what specs are actually correct as I've seen so many numbers been thrown around.
To make sure the weight was correct i weighed it twice on two different scales - calibrated digital refrigeration scales and some analogue oldies that are accurate as all buggery.

With everything stock plus
oil
water
2L of petrol
husky rear rack
ktm 690 windscreen
radiator braces
skidplate
beefed up subframe
and barkbusters

my 630 weighed in at 155kg! or about 340lb

It's not a heavyweight afterall.

A side note, i'm loving my 630 more and more everyday, and I'm sure many of you guys are too
Maxyb is offline   Reply With Quote
Old 04-25-2013, 04:12 AM   #3626
WILL_S
OUTLAW POSTIE 001
 
WILL_S's Avatar
 
Joined: Feb 2009
Location: goodly satisfactory place, qld
Oddometer: 2,075
Quote:
Originally Posted by Maxyb View Post
I decided to weigh my 630 to work out what specs are actually correct as I've seen so many numbers been thrown around.
To make sure the weight was correct i weighed it twice on two different scales - calibrated digital refrigeration scales and some analogue oldies that are accurate as all buggery.

With everything stock plus
oil
water
2L of petrol
husky rear rack
ktm 690 windscreen
radiator braces
skidplate
beefed up subframe
and barkbusters

my 630 weighed in at 155kg! or about 340lb

It's not a heavyweight afterall.

A side note, i'm loving my 630 more and more everyday, and I'm sure many of you guys are too
Good to hear mate
mine is a pos atm
blown map sensor number 3
wiring is corroded in the loom
i love how the thing goes when it is going
but it is becoming unreliable often
looks like i am gunna ride a ttr across the desert next week
__________________
out riding bored and stroked posties....braaaaaaaaaap
WILL_S is offline   Reply With Quote
Old 04-25-2013, 07:22 AM   #3627
SilverBullet
Gnarly Adventurer
 
Joined: Oct 2009
Location: Harmaston, TX
Oddometer: 391
Quote:
Originally Posted by Maxyb View Post
I decided to weigh my 630 to work out what specs are actually correct as I've seen so many numbers been thrown around.
To make sure the weight was correct i weighed it twice on two different scales - calibrated digital refrigeration scales and some analogue oldies that are accurate as all buggery.

With everything stock plus
oil
water
2L of petrol
husky rear rack
ktm 690 windscreen
radiator braces
skidplate
beefed up subframe
and barkbusters

my 630 weighed in at 155kg! or about 340lb

It's not a heavyweight afterall.

A side note, i'm loving my 630 more and more everyday, and I'm sure many of you guys are too
You could drop an easy 20+ lbs by going to a single FMF exhaust and a Li-Ion battery.

_
__________________
2011 Husqvarna TE630
2004 Suzuki VStrom 650
2002 KTM 300EXC
1974 Suzuki TM400
SilverBullet is online now   Reply With Quote
Old 04-25-2013, 10:43 AM   #3628
Fast1
Twisted Throttle
 
Fast1's Avatar
 
Joined: Aug 2007
Location: Bridge over Troubled Water
Oddometer: 1,807
Quote:
Originally Posted by WILL_S View Post
Good to hear mate
mine is a pos atm
blown map sensor number 3
wiring is corroded in the loom
i love how the thing goes when it is going
but it is becoming unreliable often
looks like i am gunna ride a ttr across the desert next week
Seems like some of this story is missing since you are one, if not the only, that has this problem and feels this way.
__________________
14 Husqvarna FE 501
10 Yamaha FJR 1300
11 Husqvarna SM630
11 Husqvarna TE630- sold
08 Husqvarna TE510- sold
Fast1 is offline   Reply With Quote
Old 04-25-2013, 10:55 AM   #3629
DYNOBOB
lucky dog
 
DYNOBOB's Avatar
 
Joined: Dec 2008
Location: Cincinnati, OH
Oddometer: 828
He's detailed his problems on CafeHusky. I think it's a case of dealer incompetence/run around. Sucks in any event, I'm sure he'd like to be riding his bike.



.
__________________
TE630.KLX250S.GL1800.CBR900RRturbo.919
CO/UT 2013
Northern Rockies 2013 IBA Key West 2014 Tentspace
DYNOBOB is online now   Reply With Quote
Old 04-25-2013, 11:59 AM   #3630
Maxyb
Falling over slowly
 
Maxyb's Avatar
 
Joined: Dec 2011
Location: Radelaide
Oddometer: 104
Quote:
Originally Posted by SilverBullet View Post
You could drop an easy 20+ lbs by going to a single FMF exhaust and a Li-Ion battery.

_
Or about 30lb with the Leovince ti system and a Li-Ion battery

would bring it down to stock ktm 690 weight
Maxyb is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:02 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014