ADVrider

Go Back   ADVrider > Bikes > Old's Cool > Airheads
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-23-2009, 06:35 PM   #1
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Installing an Acewell speedo/computer on an airhead --

I have now had the pleasure of "doing" two airheads, one a 1976 non-running R60/6 that became my little cafe; and the other a franken-beemer that had been sitting unused, but "was running when parked". Fun projects, both.

I guess that in the natural "evolution" of these bikes, and our tastes, and our desires of what we want (or think we want!) we all play with different combinations of this, that and the other thing.

So, it ends up that I put an Acewell electronic speedo/tach computer (sorta..) on Frank N. Beemer.



Yes, I am liking the result. A lot!

For those looking around for an alternative to the BMW instruments, for whatever reason, this is an excellent alternative. For those who don't know an Acewell from a hole in the ground (groan....), this is the Acewell unit:



Nice looking, in a modern but sorta-retro way.

Also under consideration had been several other possibilities. The Vapor has been widely used by the GS and offroad crowd. It does some similar functions, but definitely has a more contemporary look:

The Vapor has a few more "computer" functions meant for rally riding, etc, but pretty much works on the same principle: a little magnet and sensor on the front wheel and forks count how many times the wheel goes around, and computes the speed of the bike, based on rolling circumference and time. Simple concept, simple execution that works. Precisely.

And, there are other very nice, very retro-looking electronic speedos that could be mounted in much the same way. The only difference being that they are speedos, period. So, if you want a tach, and the usual cycle idiot lights, you have to add them.

One speedo that got serious consideration is from VDO, available in either black or white, and several other styles, but I liked these:

Nice looking units, each of them, but about 3" in size, and there is a matching tachometer as well.




Cost? The Acewell, all up, is about $130, maybe $150 for the Vapor once you add in the surround with the idiot lights:


The VDO's were not horribly expensive at about $120 plus the sensor, but then you have to add the tach, and the lights, and.... In the end, you are back to a pod of some sort. Nice, very nice, but not really what I was after.

And then there is the always-classic solution that was specific to the /5, and truly elegant:



So, those were some of the things that had come up while looking around and seeing what works. I found some truly gorgeous $800 speedos, but.... that ain't gonna happen, not in this lifetime.....




But then, if money were no object, maybe the beauty of perfection would shine through:



Sigh.
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________

bpeckm screwed with this post 11-23-2009 at 07:24 PM
bpeckm is offline   Reply With Quote
Old 11-23-2009, 06:45 PM   #2
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
I really do like the /5 solution, in spite of its shortcomings (the usual BMW speedo issues, and the broken needles, and the squirrely-acting cable),



(looks r e a l l y nice in white....)





but the clincher was....

the headlight.





I happen to like a nice, big headlight. I love these 8" headlights, clean up the lens and put in a new H4 bulbs, and they work! Now, I am not an 80mph-at-night rider. No, my night rides are simply because, here in Florida, in the summer, it is absolutely delightful to feel the balmy breeze of the night air. Daytime: hot hot hot. Night time: perfect! Plus, the bluehairs have already gone to bed, or are downing their cocktails, so the roads have only the young, the rowdy and the drunk.... and I will take my chances with them ANY DAY rather than the bluehair set. Plus, the 8" headlight has good presence during the daytime, when the blue-set is out and holding back traffic......

So this is what I ended up with:


It looks good, works great, and took some work.... hence the thread to get some of you'se guys on the right track.....
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-23-2009, 07:03 PM   #3
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
We (Frank N. has been sold, and the new owner wanted me to install the Acewell for him (!)) ordered the unit. There are a couple of places that handle the Acewell, it seems, but Electrosport seems to have the full selection, a nice website, and an efficient way of getting the product out. Good things to say about them!

There are several choices of models, we chose the Ace 2803, as it seemed to have the look, the lights and the options that we wanted. The various models give you combinations of idiot lights including turn signals, oil pressure, genlight, high beams, and fuel level. The 2803 has all of them except the fuel level (we airheads are resourceful... we open the filler cap and look in!).

Frankly, if it did it again, I might just order the 2802 since it does away with the genlight... more on why, later.

You must select a speedo adapter at the same time, so we ordered the "S" model: the universal front wheel magnet. They also make specific speedo-cable adapters which, I hear, can be easily modified to use the BMW speedo cable output. The whole package came to something like $130 iirc.

This is what showed up:







As you can see, the unit is quite small. It has a nice heft, though, the casing feels very solid, and it has a small bracket attached to the bottom, with a wire/harness hanging out. My first impression was of a good, solid unit. Their promo stuff states that it is 100% waterproof, vibration-tested to 8g's, and impact-tested to 100g's....!! Time will tell, but it is designed for this application, it is not a light-duty bicycle unit.
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-23-2009, 07:21 PM   #4
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Before I go too much further into the nitty gritty, I have to acknowledge that I have been a fan of what fellow-ADV'r MIOB has been doing over in Holland, and he was quite insistent that the Acewell was the unit to use.....

This bike is THE essence of cafe, to me:





Clean, one of a kind, and reflecting MIOB's vision and taste of what a bike really IS ...
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-24-2009, 03:48 AM   #5
Beemerboff
Beastly Adventurer
 
Joined: May 2005
Oddometer: 2,210
Good site and good prices - some sellers are adding EU35-for the cable adapter , on top of prices a good bit higher.

The little 50mm tacho on my G/S has flickered its last -anyone know of a 50 mm unit that will work on a Beemer , at a sensible price.
__________________
Adelaide Hills, Australia. 93 R100 GS, 77 R75/7 ,70 BSA B44VS, , 86 R80 G/S PD, 95 BMW Funduro F650 ST
Beemerboff is offline   Reply With Quote
Old 11-24-2009, 06:17 PM   #6
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
After admiring the new unit, the first step was to test the wires on the bike and figure out what would go to what....

So I clipped together the "harness" that is supplied with the Acewell, and used their wiring diagram to help diagnose....



Yes, those lovely plastic plugs come with the unit... I cannot imagine how or why anyone would use them, but for me they were handy so that I could simply strip the ends and stick them into the pod harness: the square rubber jobby that plugs into the back of the BMW /6 and /7 pod. Yes, each of those little holes are for a specific wire, and knowing which is what, is key to the whole shebang....

We are, in a nutshell, trying to get the wires on the left to hook up to the wires within the plug on the right... something like breeding a cat and a dog, methinks....


I was fortunate enough to have a couple of extra square plugs, so I simply used an ohm-meter to test which color wire goes to which # plug.

__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-24-2009, 06:29 PM   #7
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652




Above are the table of how to match the color wires plus the "pin" number to be able to test whether this will work with your harness. Note that the pins seem to be common to both my /6 and 1981-vintage wiring harnesses. BMW has used a common color/wiring system (which actually is a common Euro-designated color scheme) which you should be able to transpose as necessary to the different airhead wiring harnesses (harnii? ...)

I guess one cannot cut and paste a Word document, so I scanned and saved as a .jpg. Hopefully you will be able to "steal" the photo in a large enough format to be able to save it and read it.

Feel free to PM me with your email address and I will gladly email you the Wrod document in ".doc" format.



NOTE: As noted in the scanned document, the little triangle (gen warning light) does not work, due to the different way that BMW uses the gen-light as part of the alternator-excitation circuit.

It is hard to explain unless you have been into the wiring and understand the BMW system, but essentially, the gen-light is "on" when the green/black wire has +12vDC (ignition "on", but bike not running) and the blue wire has no power yet. This provides a small current THROUGH the filament that excites the alternator field, and once the engine is running with an excited alternator, the blue wire has "it's own" 12vDC, cancelling out the green/black 12vDC, and the light goes out.... Simple and effective, but there is no way to wire this function into the Acewell since there is no way to get the blue wire to the negative side of the indicator: Acewell uses battery ground as the negative side.

I bypassed this problem, as noted above, by picking up the blue and the black/green from the harness and running the two of them to a separate indicator. That is the red light underneath the Acewell.....below:


It functions as it does on the BMW pod: inition "on" and light comes on, start and blip the engine, and the light goes out. Simple, effective.

I think that, unless someone clever comes up with a way to use the internal gen-light function, I would order the unit without the gen-light, and use the separate indicator, again.

Still, could not be more satisfied with the unit, the way it is built, and the way that it is working.

__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________

bpeckm screwed with this post 11-25-2009 at 09:11 AM
bpeckm is offline   Reply With Quote
Old 11-24-2009, 06:42 PM   #8
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Once I had identified each wire, at both ends, I simply stuck them together temporarily to "test" my system prior to making them up together, permanently.




Success!

That was the first power-up, note the 0.0 miles... but the real deal was just seeing the various lights do their thang......




Once I had confirmed the wiring, the "real" wiring took place. I left the nice and neat harness from the Acewell intact, with the ends stripped. Then, I had to steele myself to cut off that lovely square nub, strip back the cover and bare the individual wires so they could be stripped on the end...


I dissected the head, and was impressed with how well and securely the wires were attached/embedded into the rubber. Felt a little like CSI-BMW

I did not want to simply crimp the wires, so I soldered them. It was in an awkward spot, just below the neck of the bike, so I first slid a piece of heat-shrink up the wire, then twisted the two wires together, and soldered them together. Then bent the soldered joint back parallel to the wire, slid the heat-shrink over it, and heat-zapped it.


Pic shows a joint that has been soldered, but prior to bending it back and parallel to the wires (note the heat-shrink slid above the joint), and some "done" joints in the back ground. There are actually twelve wires, so you want to make them as small and as consistent as possible so that they will look at least sorta right when it is all said and done
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-24-2009, 06:51 PM   #9
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Pic of the joint, done:


After all the joints were soldered, it was test-it-again time, and all was well, so I gathered all the wires and wrapped them with what we used to call "friction tape", a sticky, thick wire wrap.


Not 'xactly lovely, but functional. I ordered some Tommy Tape, which I will use for the final waterproof wrap. btw, that stuff is amazing, I had never used it before, but just did up a couple of other harness-splits: it comes with cellophane on one side, and sticks to itself almost like it is welded together, so if you stretch as you go, it will wind on itself, and stick together... good stuff!

__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-24-2009, 07:47 PM   #10
sparkymoto
learning a lot here
 
sparkymoto's Avatar
 
Joined: Aug 2009
Location: Indy
Oddometer: 202
this is great. very much appreciate the effort to post this up!
__________________
.
'76 BMW R75/6 Cafe Racer < build thread
'87 KLR 650, '70 Suzuki Titan, '10 Ural Red October, '00 Ural Patrol
Good Spark Garage < Rummaging Through Moto-culture - Stories, Pics, Bikes, Vids
sparkymoto is offline   Reply With Quote
Old 11-25-2009, 08:45 AM   #11
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Next I installed the sensor. I chose to use the universal-fit (Type S), as I had heard that it was pretty idiot proof.

The conundrum was to figure out how to mount the magnet on the wheel, and the sensor in a place that would be "disturbed" by the magnetic field of the magnet-on-the-wheel. This took a little bit of fussing, but in the end was pretty easy, and succesful.

This is the way that I first installed the parts:



You will have to look carefully, but the sensor is nice and neatly installed in what turned out to be the WRONG way. The sensor, with the wire coming out of it, actually has 2 sensors in it, one at each end of the cylinder. With this arrangement, the magnet was tripping both sensors. I was very astute in noticing that the speedo said I was doing 120mph going up A1A when I reckoned I was doing, maybe, 50....

I resolved this in two ways: first, I figured I could get away with more distance from the magnet, so I remove the "spacer" under the sensor (actually a nut) and went back to mounting it flat against the fork tab. And secondly, I rotate the sensor so that only one end would be close to the magnet. The combination worked great, and I got relatively-reasonable readings, though they were still not at all accurate.

This next photo shows how I mounted the magnet. The kit comes with two magnets, of different magnetic ooomph. I chose the larger magnet, not knowing how much "field" I would need to trip the sensor.
Note that the magnet is at the end of a lovely little curved tab, which is firmly bolted to the wheel hub with one of the four disc bolts. I simply took a little piece of flat aluminum from the scrap bin, drilled the appropriate size holes at either end, and shaped the piece to get the magnet somehwere near the sensor as it rotated, AND provided some "nut room" behind the magnet for the nut that secures it. Clever, eh? Rattle-can black and it disappeared nicely!



Next step was to calibrate. The instructions are ambiguous at best regarding the wheel diameter. I am still not sure whether they mean wheel, or tire, diameter with the guidlelines that they give you. They give you a number to plug in, which is quite easy to do when you get into the menu. So, I went to Anton's site to research the actual-and-correct RPM vs. speed: I have a 33/11 rear end, which says that I should be doing 70mph at 4005 rpm. Since the local constabulary frowns on doing 70mph up and down A1A, especially since it is bluehair season, I did some mental calculations to see what speed I should be doing at 3000 rpm in 5th gear, and came up with.... 3/4 of 4000 = 3000 rpm, so 3/4 of 70 = 52.5 mph. Cool!

And since there is a digital readout function for the tach, I simple scrolled through 'til I could get a tach reading (accurate to 100 rpm), of 3000 while I noted my indicated speed. Pulled over to the side, scrolled into the menu and adjusted that "magic number" by trial and error, until I got it just right. It took me four or five "stop and scroll"s at the side of the road, and by the time I got back home, it was spot-on. Perfect!
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________

bpeckm screwed with this post 11-25-2009 at 09:21 AM
bpeckm is offline   Reply With Quote
Old 11-25-2009, 08:59 AM   #12
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
So, at this point the unit is temporarily installed, simply by zip-tying it neatly to the clutch and throttle cables. Tested out, works great!

__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 11-25-2009, 09:01 AM   #13
Throbbing Missile
Stuck in a rut
 
Joined: Nov 2009
Location: Old Hampshire, UK
Oddometer: 30
I like Acewells, I have one on my Armstrong and one on my Guzzi.

The number you put in is the circumference of the tyre in mm. On my Guzzi I just balanced the bike upright, measured from the floor to the centre of the wheel spindle, multiplied by 2 then by 3.142 and stuck the number in. GPS said 106mph, Acewell said 107 - good enough for me.

*edit* Lovely looking bike btw
Throbbing Missile is offline   Reply With Quote
Old 11-25-2009, 09:02 AM   #14
datchew
Don't buy from Brad
 
datchew's Avatar
 
Joined: Aug 2005
Location: Savannah - the dirty south
Oddometer: 7,408


I'm seriously interested. Mebbe this would be good in a /2.
datchew is offline   Reply With Quote
Old 11-25-2009, 09:24 AM   #15
bpeckm OP
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,652
Sparkymoto: thanks, a pleasure. And WELCOME to the LoonBin, and btw, cool avatar!

Datch: keep in mind the lack of oil pressure sender, though you could get some functions if you convert to 12v. Cetainly the speedo part would work great! Still, the /2 needs a /2 speedo... mine was actually very accurate, and ya gotta love the way they wind "backwards"....



Throbbing Missile: 106! Yowza! Got any pics of your installs that you might post up, here....??
__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:45 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014