ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (950/990cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-15-2014, 02:22 PM   #1
Tatanka OP
Adventurer
 
Joined: Jun 2011
Location: NC
Oddometer: 57
Strange Brake Light Issue, Need Some Help

My front brake lever doesn't activate the brake light, but the rear brake lever does. The micro switch and wiring check out fine. There are three wires going into the rear light. I verified the rear running light is getting 12 volts between the brown (negative) and yellow wires. As expected, I get 0 volts between the brown and white wires when neither brake levers are used. However, and this is the weird part, I get 12 volts between the brown and white wires when either brake lever are used.

In other words, whenever I'm using the front or rear brake levers, I'm reading 12 volts as expected, but only the rear brake lever turns on the brake light.

Can anyone tell tell me how this can be and how to fix it? It's a 2010 690 Duke.
__________________
'10 Duke - It's a mountain bike with a motor!
'02 R1100S - My Audi looks at her with distain.
'01 SV650S - The first is never forgotten.
Tatanka is offline   Reply With Quote
Old 03-21-2014, 11:04 PM   #2
Tatanka OP
Adventurer
 
Joined: Jun 2011
Location: NC
Oddometer: 57
I fixed the issue. I shorted the prongs of the connector at the wiring harness, and the brake lights worked as they should. It turned out to be a bad micro switch. Lessons learned:

1) Even though a micro switch might pass a continuity test, there might be an issue preventing it from working when you supply voltage.

2) My Duke (perhaps other KTM models as well) uses Brembo brakes and levers. They're mostly compatible with Ducati, so I was able to find another micro switch rather easily from eBay.
__________________
'10 Duke - It's a mountain bike with a motor!
'02 R1100S - My Audi looks at her with distain.
'01 SV650S - The first is never forgotten.
Tatanka is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:35 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014