ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-18-2010, 02:03 PM   #1
Rayzor61 OP
Gnarly Adventurer
 
Rayzor61's Avatar
 
Joined: Mar 2008
Location: Yardley, PA
Oddometer: 226
HELP! Pinging sound on new 990, worried!

I'm about 700 miles into the new 990 ADV and I'm getting a pinging sound from the engine. Sounds like a low octane ping on a car! I use only Shell 93 octane.

The sound is more promanent from the left side of the engine area between the fan and the left case cover. That would make it near the oil resivoir or the foward (front) cylinder. It mostly appears to do it when I'm accelerating (in motion). I've reved the motor in netrual and dont hear it which makes me think it is firing correctly.

If it were a rattle sound I would be less worried and look for the loose fitting. Because it sounds like the motor pinging, I'm worried that I could be damaging it.

I don't know how long its been doing it but recently I started using a 3/4 helmet which allows me to hear everything more. I just changed the oil and added Hot Grips. Everything is secure as far as that goes.

Any ideas? Does anyone else hear this on their bike?

Conserned
Rayzor61 is offline   Reply With Quote
Old 09-19-2010, 11:50 AM   #2
MrSandman818
INaVANdownBYtheRIVER
 
MrSandman818's Avatar
 
Joined: Dec 2009
Location: El Paso, Republic of Texas
Oddometer: 810
Quote:
Originally Posted by Rayzor61
I'm about 700 miles into the new 990 ADV and I'm getting a pinging sound from the engine. Sounds like a low octane ping on a car! I use only Shell 93 octane.

The sound is more promanent from the left side of the engine area between the fan and the left case cover. That would make it near the oil resivoir or the foward (front) cylinder. It mostly appears to do it when I'm accelerating (in motion). I've reved the motor in netrual and dont hear it which makes me think it is firing correctly.

If it were a rattle sound I would be less worried and look for the loose fitting. Because it sounds like the motor pinging, I'm worried that I could be damaging it.

I don't know how long its been doing it but recently I started using a 3/4 helmet which allows me to hear everything more. I just changed the oil and added Hot Grips. Everything is secure as far as that goes.

Any ideas? Does anyone else hear this on their bike?

Conserned
Try running 110 or VP U4.4. That'll get rid of any ping. haha.

(Im jk dont actually do that)
__________________
-Chrome don't getcha home, but carbon fiber sure is fancy
2005 KTM 950 Adventure
2005 Yamaha YZ250F
1978 Batavus 48
MrSandman818 is offline   Reply With Quote
Old 09-19-2010, 04:10 PM   #3
mickd
crash test dummie
 
mickd's Avatar
 
Joined: Apr 2007
Location: brisbane,australia
Oddometer: 1,848
put ya old helmet back on ,ive get the same sound when ive got a moto-x helmet on but when ive got the road helmet on its gone,she will be right mate
__________________
You suck. And your mother dresses you funny.

I've just been to my first muslim birthday party. Musical chairs was a bit slow but F**k me, pass the parcel was bloody quick.
mickd is offline   Reply With Quote
Old 09-19-2010, 04:19 PM   #4
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,677
What plug are you using? Try going to one heat range colder plug.
__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.

AustinJake screwed with this post 09-19-2010 at 05:52 PM
AustinJake is offline   Reply With Quote
Old 09-19-2010, 05:24 PM   #5
Rayzor61 OP
Gnarly Adventurer
 
Rayzor61's Avatar
 
Joined: Mar 2008
Location: Yardley, PA
Oddometer: 226
I have the stock plugs, what ever they are. Maybe I can try an octane booster from Pep Boys. Or, perhaps I can start trying other fuel brands until I find one that fits.

I know it sounds like I'm being too particular but I've had a ton of bikes and never heard this sound on any other bikes (even on my other 5 previous KTM's). My 2 buddies that also have 990's say "stop listening"...lol.
Rayzor61 is offline   Reply With Quote
Old 09-19-2010, 05:37 PM   #6
AdvGa
Beastly Adventurer
 
AdvGa's Avatar
 
Joined: Nov 2009
Location: Atlanta Metro
Oddometer: 1,320
Rayzor,

Is your bike still under Warranty?

It may be your FI map needs reflashed causing improper detonation.

Or perhaps a timing chain jumped a tooth...

I hope your bike is under warranty and wish you a speedy fix.
AdvGa is offline   Reply With Quote
Old 09-19-2010, 05:53 PM   #7
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,677
Quote:
Originally Posted by Rayzor61
I have the stock plugs,
Pull the plugs, if they are white (instead of tan) try a colder plug.
__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.
AustinJake is offline   Reply With Quote
Old 09-19-2010, 06:37 PM   #8
Rayzor61 OP
Gnarly Adventurer
 
Rayzor61's Avatar
 
Joined: Mar 2008
Location: Yardley, PA
Oddometer: 226
The bike is brand new!!!!! I'll look at the plugs first. If all is well there, I'll start asking the dealer for warrenty service (re-map). I hate to cry wolf to the dealer. Their service department always makes me feel like I'm imposeing. I'm good for another 23 months of coverage though...

I was also wondering if perhaps it is related to the lean mapping for emmisions requirements. Maybe I should ask for the Ackro map. She really is a hot running bike. But if that were the case, a lot of others would be relating to my complaint/problem. I know its common knowledge that shes a hottie but don't see any other pinging noise threads.

Thanks guys!
Rayzor61 is offline   Reply With Quote
Old 09-19-2010, 07:36 PM   #9
AdvGa
Beastly Adventurer
 
AdvGa's Avatar
 
Joined: Nov 2009
Location: Atlanta Metro
Oddometer: 1,320
Rayzor,

I would take this to the Dealer First... don't touch it. This way you can document this Issue during your Warranty Period.

The more you monkey with something, the more there is a reason to deny a Claim or Responsibility.... I know 'cause I went through this with another brand of motorcycle and was Successful..


Good Luck.
AdvGa is offline   Reply With Quote
Old 09-20-2010, 02:08 AM   #10
men8ifr
Gnarly Adventurer
 
Joined: Jan 2008
Location: Midlands UK
Oddometer: 383
Add a load of octane booster to one tank will tell you if you are hearing detonation/knock or another mechanical noise.

I wouldn't change plugs, if they are getting so hot to cause pre-ignition (don't confuse this with knock (which would likely destroy your engine very fast) then there would be something seriously wrong with your engine that the dealer/ktm should fix.
men8ifr is offline   Reply With Quote
Old 09-20-2010, 10:44 AM   #11
jackr
2008 KTM 950 SE
 
Joined: Aug 2006
Location: Kamloops BC
Oddometer: 226
I have the same sound on my SE. I changed gas to a higher octane and its still there. I don't think its pinging but I don't know what it could be. I've had this sound ever since I can remember and I'm not worried about it.
jackr is offline   Reply With Quote
Old 09-20-2010, 11:03 AM   #12
Rayzor61 OP
Gnarly Adventurer
 
Rayzor61's Avatar
 
Joined: Mar 2008
Location: Yardley, PA
Oddometer: 226
Quote:
Originally Posted by jackr
I have the same sound on my SE. I changed gas to a higher octane and its still there. I don't think its pinging but I don't know what it could be. I've had this sound ever since I can remember and I'm not worried about it.
How many miles do you have on it now?
Rayzor61 is offline   Reply With Quote
Old 09-20-2010, 11:08 AM   #13
dezracer
Studly Adventurer
 
dezracer's Avatar
 
Joined: Jan 2003
Location: Las Vegas,NV.
Oddometer: 640
Do you have the high octane plug under the seat in correct configueration? Check your ownwres manual.
__________________
2007 990 Adventure

Suspension by Super Plush
Rekluse Pro Auto Clutch
WINGS N.O.S Exhaust
Euro Headlight with PIAA bulbs
KTM Hard Parts Radiator Cover
CJ Racer Clear Spoke Clutch Cover
Hilslamer Long Pegs
GPR Stabilizer
DH Racing tripleclamps
'300' Throttle Cam
16t CS Sprocket
Mefo "Super Explorers"
Ram Mount Garmin 76c
PABIKER sidestand relocaton kit.
2007 KTM 300XC (long live lightweight 2-strokes)

Las Vegas, NV and the Great Mojave Desert
dezracer is offline   Reply With Quote
Old 09-20-2010, 01:56 PM   #14
Rayzor61 OP
Gnarly Adventurer
 
Rayzor61's Avatar
 
Joined: Mar 2008
Location: Yardley, PA
Oddometer: 226
Quote:
Originally Posted by dezracer
Do you have the high octane plug under the seat in correct configueration? Check your ownwres manual.
Yes, it is connected as it should be.
Rayzor61 is offline   Reply With Quote
Old 09-20-2010, 05:14 PM   #15
gettr
Team Turtle
 
gettr's Avatar
 
Joined: Oct 2007
Location: LaSalle Co.
Oddometer: 686
Sometimes I get a light pinging noise on mine (10 990R.. it sounds more like an exhaust higher pitched ping/rattle), but after my GS... I know that detonation sound... marbles rolling around in a paint can. Either way, if it's a concern to you... take it back to the dealer, screw them and their feelings of inconvenience. You paid for the warranty and the bike... not them.
gettr is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:14 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014