ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-24-2015, 05:46 PM   #1
610ripper OP
n00b
 
Joined: Feb 2015
Location: longisland
Oddometer: 2
Cool2 Need help with husky 610 sm please!!!

Hey everyone first post long time reader i need some help.. so i brought a 2008 efi husky 610sm last summer and it always ran perfect and then i was riding it one day it kept bogging down and stalled out and wouldnt start for about 20 mins till engine was cool then did same thing again. Now it starts up perfectly and idles but like 10-15 minutes into riding it stalls again and just turns over no start, wait 20-30 mins for it to cool down starts right back up and then stalls again after riding. Any help would be great i need to fix and get back on my husky!

Also what are the two fuel petcock valves on each side of the gastank i was messing with them when it stalled the first time now i dont remember if they should be screw out or in.
Thanks!!!
610ripper is offline   Reply With Quote
Old 02-24-2015, 05:49 PM   #2
Navin
Beastly Adventurer
 
Navin's Avatar
 
Joined: Sep 2009
Oddometer: 8,000
Screw them out to open and I'd guess you need a fuel pump.
Navin is offline   Reply With Quote
Old 02-25-2015, 05:43 AM   #3
610ripper OP
n00b
 
Joined: Feb 2015
Location: longisland
Oddometer: 2
Thank you any other ideas i was thinking about changing the water temp sensor? I can also hear the fuel pump turn on
610ripper is offline   Reply With Quote
Old 02-25-2015, 05:54 AM   #4
bobnoxious67
Baby steps...
 
Joined: Jun 2008
Location: Marion, MA
Oddometer: 2,686
Sounds like the fuel pump dying
bobnoxious67 is online now   Reply With Quote
Old 02-25-2015, 06:33 AM   #5
SRG
SRG
 
SRG's Avatar
 
Joined: Nov 2004
Location: Charlottesville, Virginia USA
Oddometer: 1,284
^^yep^^ When it's cold it works. As it gets hotter, it begins to seize and eventually stops. If you listen for the pump right after it cuts out (hot), can you hear it? If you can, does it sound like it's running slowly or at full (normal) speed? Check/clean/replace any fuel filters too and maybe test/clean the injector.
__________________
Lazy Traveler
SRG is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 02:24 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2015