ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-14-2011, 10:18 AM   #1
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
How to check a coil, Polaris help needed

Got a 2004 Polaris Sportsman 500 HO, think I have a bad coil and I'm not sure how to check it.
Can anyone tell me how?
__________________
2006 Tiger
2008 KLR (hers)

Fe Man screwed with this post 02-14-2011 at 02:07 PM
Fe Man is offline   Reply With Quote
Old 02-14-2011, 04:00 PM   #2
gvthnks
Studly Adventurer
 
gvthnks's Avatar
 
Joined: Nov 2008
Location: Actionville NC
Oddometer: 528
Specs from my FSM are as follows.

primary resistance: .3 ohms

secondary resistance: 6.3K

Primary is the resistance between the electrical connector to ground (which is a mounting tab on the coil)
secondary is between the electrical connector and spark plug cap.

If you get no reading on the secondary side, unscrew the spark plug cap and read it again. Then check to make sure the plug cap is OK by reading through it too. Some plug caps have resistors in them and they can go bad too.

hope this helps
__________________
09 Kawi KLR 650
05 Road Kind Custom
01 Suzuki DRZ-250
96 Honda Shadow
93 Honda XR 80
87 Honda XR250r
83 Honda XR350r
73 Honda XL350
73 CB750
73 Yamaha DT-1

wife calls it a sickness. I'm running a M/C rescue
gvthnks is online now   Reply With Quote
Old 02-14-2011, 04:06 PM   #3
Range Motorsport
Junk collector
 
Range Motorsport's Avatar
 
Joined: Nov 2007
Location: Da UP Eh!
Oddometer: 1,647
what are your symptoms? I have never seen a bad coil on a 500 Sportsman but the ignition box was known to cause some issues on certain years but I believe that was 2005 models. The wire tends to get disconnected from the cap often as well.

I have fixed many no spark issues by simply moving the kill switch to the run position.
__________________
2007 KTM Superduke
SNL Will Ferrell Yoga, google it.
www.adventuremine.com
www.upoverland.org
Range Motorsport is offline   Reply With Quote
Old 02-14-2011, 05:35 PM   #4
concours
WFO for 41 years
 
concours's Avatar
 
Joined: Dec 2008
Location: Kensington, NH USA
Oddometer: 5,073
I've got a service manual out in the garage, I'll go look in a minute. The speed limiter in reverse works by interupting the spark. I bought the very first year Sporty 500 (1996) and still have it. The engine always has sounded like a coffee can full of bolts, but still runs well.
__________________
Too much is just barely enough.....
concours is offline   Reply With Quote
Old 02-14-2011, 06:29 PM   #5
concours
WFO for 41 years
 
concours's Avatar
 
Joined: Dec 2008
Location: Kensington, NH USA
Oddometer: 5,073
From the Poolaris FACTORY service manual: Primary winding resistance should be .3 to .5 ohm, the secondary should be 6300 ohm (+/- 10%) WITHOUT the resistor cap. The resistor plug cap should be 5000 ohms. Good luck!
__________________
Too much is just barely enough.....
concours is offline   Reply With Quote
Old 02-15-2011, 06:49 AM   #6
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
Thanks all!

The coil measurements are "within" spec; the measurements to the cap are within spec but I get no reading through the cap...

The symptom was cutting out Horribly under load. Sitting it would rev normally, put it in gear and it wouldn't move out of it's own tracks.

At first I thought was fuel delivery, contamination or carb issues. I took the carb apart, cleaned, replaced fuel filter, still a problem.
__________________
2006 Tiger
2008 KLR (hers)
Fe Man is offline   Reply With Quote
Old 02-15-2011, 06:53 AM   #7
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
Quote:
Originally Posted by Range Motorsport View Post
what are your symptoms?

I have fixed many no spark issues by simply moving the kill switch to the run position.

I figured that one out years ago!
__________________
2006 Tiger
2008 KLR (hers)
Fe Man is offline   Reply With Quote
Old 02-15-2011, 09:17 AM   #8
SilkMoneyLove
Beastly Adventurer
 
SilkMoneyLove's Avatar
 
Joined: Nov 2007
Location: Minneapolis
Oddometer: 1,744
ha ha

Sidestand switch?

(I had to)
SilkMoneyLove is offline   Reply With Quote
Old 02-15-2011, 09:45 AM   #9
concours
WFO for 41 years
 
concours's Avatar
 
Joined: Dec 2008
Location: Kensington, NH USA
Oddometer: 5,073
so try rolling it over without the cap on the wire. You should get a good spark jump off the end of the plug wire
__________________
Too much is just barely enough.....
concours is offline   Reply With Quote
Old 02-15-2011, 09:48 AM   #10
concours
WFO for 41 years
 
concours's Avatar
 
Joined: Dec 2008
Location: Kensington, NH USA
Oddometer: 5,073
troubleshooting flow chart says: disconnect the black wire at the CDI module to isolate the ignition system from the kill system.

Spark? Yes? Test the ignition switch, kill switch and speed limiter for shorts to ground. Also check terminal board for moisture or corrosion.
__________________
Too much is just barely enough.....
concours is offline   Reply With Quote
Old 02-15-2011, 10:22 AM   #11
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
I would like to buy a service manual, preferably the factory service manual but upon searching the web, you see all of these "download" houses that offer but seem to not actually have the books.

Where can I buy a copy online?
__________________
2006 Tiger
2008 KLR (hers)
Fe Man is offline   Reply With Quote
Old 02-15-2011, 11:23 AM   #12
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
So as I am broke I'm trying to get my shit to run by working on it myself.
Now my fucking battery appears to be dead and need replacing!
__________________
2006 Tiger
2008 KLR (hers)
Fe Man is offline   Reply With Quote
Old 02-15-2011, 12:58 PM   #13
Range Motorsport
Junk collector
 
Range Motorsport's Avatar
 
Joined: Nov 2007
Location: Da UP Eh!
Oddometer: 1,647
http://www.ohiolemonlaw.com/mll-site...is-recalls.htm

Dead battery is a sign of the ECM shorting out and draining it. Those things were scary when they went bad.
__________________
2007 KTM Superduke
SNL Will Ferrell Yoga, google it.
www.adventuremine.com
www.upoverland.org
Range Motorsport is offline   Reply With Quote
Old 02-15-2011, 01:25 PM   #14
Fe Man OP
I am Iron Moran!
 
Fe Man's Avatar
 
Joined: May 2008
Location: Moran Nation, N. Atlanta Outpost
Oddometer: 7,477
No, just a dead battery...

I got it started; runs like shit and the exhaust pipe is smoking with the distinct smell of burning oil but nothing has been spilled on it!
__________________
2006 Tiger
2008 KLR (hers)

Fe Man screwed with this post 02-16-2011 at 06:24 AM
Fe Man is offline   Reply With Quote
Old 02-15-2011, 02:02 PM   #15
gvthnks
Studly Adventurer
 
gvthnks's Avatar
 
Joined: Nov 2008
Location: Actionville NC
Oddometer: 528
Quote:
Originally Posted by concours View Post
The engine always has sounded like a coffee can full of bolts, but still runs well.
thought I was the only one.....
__________________
09 Kawi KLR 650
05 Road Kind Custom
01 Suzuki DRZ-250
96 Honda Shadow
93 Honda XR 80
87 Honda XR250r
83 Honda XR350r
73 Honda XL350
73 CB750
73 Yamaha DT-1

wife calls it a sickness. I'm running a M/C rescue
gvthnks is online now   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:43 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014