ADVrider

Go Back   ADVrider > Bikes > Old's Cool
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-18-2011, 07:01 PM   #1
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
New project GR650

Okay...been ten years without a bike. Made my wife nervous when I arrived at my destination about a second and a half ahead of my bike. (Whoops.) Sold the bike while the kids were little and amused myself with an old Miata.


A friend I hadn't seen for awhile mentioned that he had what he thought was a DR650 in his barn that I could have. Sounded great to me. Turned out to be somewhat different.

The Suzuki GR 650 was only offered for sale in the U.S for two years. Has some interesting features, but it never caught on. Cycle World named it the "best buy of 1983" but that didn't save it. Was sold until '89 in Canada and Europe.

After a series of delays, I went today to get it. Four hours away in north central Ohio. Not a great start to the day.


Saw a few guys on I-70 getting a bit more adventure than seemed fun.



But I persevered and snapped a few shots while gassing up to head for home.



radianrider is offline   Reply With Quote
Old 06-18-2011, 07:08 PM   #2
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Sorry about the blue pictures. It was pretty overcast all day (when it wasn't actively raining) and I was using a new camera. Didn't get the white balance right.

PO told me that his BIL bought the bike new in '83 and had been hit by a car at some point. The brake pedal is bent in toward the engine case and the front fender has a bend it it.

After my friend got it his son dropped it. Broke the turn signals on the left side and bent the headlight bracket.

Had the carbs cleaned last fall and it ran great until dropped. It was pushed into the barn and left there in September and hasn't been started since. Likely I need to do the carbs again.

Lots more pictures to follow tomorrow. Too late to dig in tonight.

Oh yeah, look closely at the back rest. That is not stock and it ain't coming off easily. PPO welded it onto the grab bar. It may give some HD fans heartburn to see it on this old child of the Orient. Proudly labeled as a gen-u-wine HD backrest.

More to follow as I work to get this '83 largely forgotten Suzuki back on the road. I will add that whoever designed the handlebars on this bike should be banned from designing anything. Ever.
radianrider is offline   Reply With Quote
Old 06-18-2011, 07:25 PM   #3
vtwin
Air cooled runnin' mon
 
vtwin's Avatar
 
Joined: Jan 2005
Location: NorCal
Oddometer: 7,259
Looks like a real throwback with the backrest. It seems in pretty good shape though and the price is right. Keep us posted.
__________________
"Alles hat ein Ende--nur die Wurst, sie hat zwei"
Monroe.

"You only have too much fuel if you're on fire"
unknown
vtwin is offline   Reply With Quote
Old 06-18-2011, 09:04 PM   #4
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Quote:
Originally Posted by vtwin View Post
Looks like a real throwback with the backrest. It seems in pretty good shape though and the price is right. Keep us posted.
Will do. I think the chrome is in generally decent shape. Paint is really faded and I'll likely have to repaint it at some point.

First comes the getting it running part.
radianrider is offline   Reply With Quote
Old 06-19-2011, 11:31 AM   #5
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
She runs! But mostly at idle only. Try to rev it much and it wants to die pretty quickly.

But, oh does it sound sweet at idle. Has a deep rich throb. Have heard many on Youtube videos, but they must be a testament to cheap camera mics. Sounds much deeper and more throaty than anything I've heard online.

I did get it to rev up for a little bit and it sounded very healthy before it choked out again.

Pics to follow.
radianrider is offline   Reply With Quote
Old 06-19-2011, 12:14 PM   #6
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
He's 15. Wants to know when he can get his license. His Mom says "30."


She's 18. Guessing the age 30 rule will apply here as well.


On to the bike.

I'm guessing this is part of the battery issue. (Note the black wire running from the negative to the rectifier.)



Engine is generally tight with only a few leaks in evidence.


Nice size dent in the front fender that I'll have to straighten out.


Brake pedal is bent out of shape as well. I think the footpegs are slightly out of position as well.


Headlight bracket and front turn signal on the left are pretty well bent and/or broken. Have replacement turn signal for the front, but will need to straighten the brackets. Haven't sourced a rear turn signal yet.

Most of the chrome is going to need some serious elbow grease,


Will also need an oil cap.

radianrider screwed with this post 06-19-2011 at 12:23 PM
radianrider is offline   Reply With Quote
Old 06-19-2011, 03:01 PM   #7
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Got it running enough to ride it around the cul de sac, but it's running pretty rough. Pops and backfires a bit, but it is going to be fun.
radianrider is offline   Reply With Quote
Old 06-19-2011, 04:41 PM   #8
vtwin
Air cooled runnin' mon
 
vtwin's Avatar
 
Joined: Jan 2005
Location: NorCal
Oddometer: 7,259
The wire I had going from the battery (-) to the rectifier looked just like that. Found out one of the starter solenoid studs touched the aftermarket rectifier fins from time to time.

They are cold-blooded and run poorly until about 5 miles into it. I know mine is. Check the air filter foam, they go bad fast, about a $65 item.
__________________
"Alles hat ein Ende--nur die Wurst, sie hat zwei"
Monroe.

"You only have too much fuel if you're on fire"
unknown
vtwin is offline   Reply With Quote
Old 06-19-2011, 05:55 PM   #9
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Quote:
Originally Posted by vtwin View Post
The wire I had going from the battery (-) to the rectifier looked just like that. Found out one of the starter solenoid studs touched the aftermarket rectifier fins from time to time.

They are cold-blooded and run poorly until about 5 miles into it. I know mine is. Check the air filter foam, they go bad fast, about a $65 item.
Yikes! That's a bit steep for a filter.

Slowly getting some things done. Have bent the headlight brackets back closer to where they are supposed to be. Installed the front turn signal and got them working.

Charging the battery. Seems to be running a bit better. Put some Seafoam in the tank and am slowly running that through the system.

It just feels good to have a bike again.
radianrider is offline   Reply With Quote
Old 06-19-2011, 09:14 PM   #10
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
I checked the filter. Nearly perfect and well oiled, so on to other items.

Seafoam seems to have really helped the beast. It sounds good and revs up nicely. Just needed to run for awhile I guess. Can't wait to get it titled and plated.
radianrider is offline   Reply With Quote
Old 06-24-2011, 04:08 PM   #11
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Changed out the beat up bars for wider, more forward, bars. Like the feel immensely, but now it won't start.

Actually dirt bike bars, but the brace is removable for more street bike look and feel.

Starting issue is purely electrical, pretty sure. I stink at tracking down electrical issues. Great.
radianrider is offline   Reply With Quote
Old 06-24-2011, 06:42 PM   #12
vtwin
Air cooled runnin' mon
 
vtwin's Avatar
 
Joined: Jan 2005
Location: NorCal
Oddometer: 7,259
Quote:
Originally Posted by radianrider View Post
Changed out the beat up bars for wider, more forward, bars. Like the feel immensely, but now it won't start.

Actually dirt bike bars, but the brace is removable for more street bike look and feel.

Starting issue is purely electrical, pretty sure. I stink at tracking down electrical issues. Great.

Perhaps you damaged something during the swap like the clutch switch?
__________________
"Alles hat ein Ende--nur die Wurst, sie hat zwei"
Monroe.

"You only have too much fuel if you're on fire"
unknown
vtwin is offline   Reply With Quote
Old 06-25-2011, 09:14 PM   #13
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Definitely a possibility. Have jumped across the starter relay and the starter spun up, so now certain it is one of the switches.

I think it might be the kickstand switch. The light was staying on when I first got it and the bike started anyway. Got it to go out and the bike ran. It is back on and the bike won't start.

Plan to figure out how to test it next.
radianrider is offline   Reply With Quote
Old 06-29-2011, 05:48 AM   #14
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Went to Cycle-Recycle in Indy yesterday and bought a rear turn signal shell. That should be the last part I need to get functional lights although the headlight brackets are still bent. Functional is the goal for now, pretty comes later.

Struggling to figure out why the starter is not being engaged. Pushing the starter button has no effect. Checked the starter switch and the clutch safety for continuity and they appear to be working.

Starter does engage if I jump across the ignition relay. Have a new relay on the way and I am hoping that does the trick.

Got all the title issues worked out, so now I can call the police for the VIN check (required for a vehicle purchased out of state) and apply for a title. Should be on the road in a few days once I get the starter figured out.
radianrider is offline   Reply With Quote
Old 06-29-2011, 04:24 PM   #15
radianrider OP
Adventurer wanna'be
 
radianrider's Avatar
 
Joined: Aug 2006
Location: Avon, IN Not so much Motorcycle Heaven
Oddometer: 455
Certainly enjoy this conversation with myself. Finally, somebody understands me.

Been tracking down an electrical issue which is preventing the bike from starting. Thought is was the ignition relay and bought a replacement. Made no difference, so I started back through the switches.

Found a weird problem. If the clutch lever bracket is twisted so the lever is coming down to the bar the bike will start (or at least try...battery is weak.)

If I immediately move the lever back to the normal position...all dead.

Clearly related to the clutch safety switch in some fashion, but I'll be hanged if I can figure it out.
radianrider is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:52 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014