ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-27-2011, 02:18 PM   #1
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
Bad TPS sensor 2007 990ADV?

My bike has developed a real bad fueling issue just off idle. and it is not your normal snatchy throttle that we we are talking about. At just off idle 2-4% throttle the bike acts like it shuts off! and some time it does I thought i had some bad gas so i drained the tank and replace the fuel filters. No better. 15 min idle, no change. if your running hard it seems okay but if your in town in 4th or 5th gear the bike is unrideable This felt like a TPS sensor so i opened up the air box and pulled the connector for the TPS. hooked up my Fluke 78. I am getting about 3.95K ohms at idle and 1.5K at WFO but at that 2-4% throttle it spikes to about 4.3K ohms. I have been on the H.O.W. and searching around here looking at TPS issues and only have found topics related to 950 carbs not 990 EFI??? any one else have some help???? OH yea the best part KTM does not list the TPS sensor as a separate piece you have to buy the complete throttle body for a $GRAND$

HELP! any one have a used one? or an idea WTF is wrong with my bike??
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 06-27-2011, 07:10 PM   #2
grinns
Semper Fi
 
grinns's Avatar
 
Joined: May 2010
Location: Rainy, Wa
Oddometer: 1,306
Quote:
Originally Posted by boat.man View Post
My bike has developed a real bad fueling issue just off idle. and it is not your normal snatchy throttle that we we are talking about. At just off idle 2-4% throttle the bike acts like it shuts off! and some time it does I thought i had some bad gas so i drained the tank and replace the fuel filters. No better. 15 min idle, no change. if your running hard it seems okay but if your in town in 4th or 5th gear the bike is unrideable This felt like a TPS sensor so i opened up the air box and pulled the connector for the TPS. hooked up my Fluke 78. I am getting about 3.95K ohms at idle and 1.5K at WFO but at that 2-4% throttle it spikes to about 4.3K ohms. I have been on the H.O.W. and searching around here looking at TPS issues and only have found topics related to 950 carbs not 990 EFI??? any one else have some help???? OH yea the best part KTM does not list the TPS sensor as a separate piece you have to buy the complete throttle body for a $GRAND$

HELP! any one have a used one? or an idea WTF is wrong with my bike??

Yep complete throttle body... (rediculious) I don't know if anyone has sourced an alternative.

This suggestion is more of a hack. Connect tune ecu and see what it does for TPS (if its really screwed it may peak at a high throttle at that position). Next I would see if you can adjust that part of the potentiometer out and still be in the voltage tolerance for the idle position. Then do a reset and 15 minute idle.

All that information is in the Tune ecu thread and on there website.

Here is a comment, not trying to confuse you but just some knowledge. At that low of a throttle position and below about 5k it should be calculating off the map sensors. I don't know what the TPS would be inputing but it could be causing the FL settings to switch to the bad TPS value.

Message me if you need help, I had a wierd issue with my bike and had to figure all this stuff out.
__________________
2012 300 EC Race
2010 690 R
2007 990 S

grinns is offline   Reply With Quote
Old 06-28-2011, 08:22 AM   #3
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
Well i just got off the phone with my local KTM dealer. He called the tech guy and they claim to "never have problems with the TPS" and will not sell the part separate. so the only way to get the part new is to buy a throttle body for $1000.00 NOT!!! I am really considering a carb conversion, solves all my problems and i end up with a better bike at the end of the day!! Anyone parting out a 950 and want to sell me the carbs and components???
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 06-28-2011, 10:43 AM   #4
Zuber
Zoob
 
Zuber's Avatar
 
Joined: Sep 2004
Location: Main Street, Shedd, Oregon
Oddometer: 1,693
That dirty pot will cause your problems. You could try cleaning it with electrical contact cleaner. You'd need to drill a small hole in the right place, don't ask me where. This works on automotive TPS, for a while.

The 2011 model shows the separate part for $109 - 61041077000 Throttle position sensor. Good bet it would fit.
__________________
"Dad, can I get a motorcycle when I grow up?"
"Son, you can't do both"
Zuber is offline   Reply With Quote
Old 06-28-2011, 11:50 AM   #5
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
See! That's why this is the best forum on the planet! Options, work-arounds, help I am still thinking about the carb swap but at least i can get it on the road for one tenth the cost... i hope
Thanks guys for the replies will keep you posted.
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 07-01-2011, 10:11 AM   #6
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
Couple questions for some one with a shop manual for a 990 please???

1 Is the TPS sensor adjustable on it?
2 if so what is the procedure and value to set it?

Thanks!!
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 07-01-2011, 11:05 AM   #7
JTXT
Adventurer
 
Joined: Sep 2010
Location: Lake Stevens, WA
Oddometer: 78
Quote:
Originally Posted by boat.man View Post
Well i just got off the phone with my local KTM dealer. He called the tech guy and they claim to "never have problems with the TPS" and will not sell the part separate. so the only way to get the part new is to buy a throttle body for $1000.00 NOT!!! I am really considering a carb conversion, solves all my problems and i end up with a better bike at the end of the day!! Anyone parting out a 950 and want to sell me the carbs and components???
The carbs have throttle position sensors on them as well.
JTXT is offline   Reply With Quote
Old 07-01-2011, 11:19 PM   #8
grinns
Semper Fi
 
grinns's Avatar
 
Joined: May 2010
Location: Rainy, Wa
Oddometer: 1,306
Quote:
Originally Posted by boat.man View Post
Couple questions for some one with a shop manual for a 990 please???

1 Is the TPS sensor adjustable on it?
2 if so what is the procedure and value to set it?

Thanks!!
I'll try to find the info, It's doable and i've done it. I had to make a little custom tool.
__________________
2012 300 EC Race
2010 690 R
2007 990 S

grinns is offline   Reply With Quote
Old 07-02-2011, 06:50 AM   #9
JTXT
Adventurer
 
Joined: Sep 2010
Location: Lake Stevens, WA
Oddometer: 78
Here is good information on how to adjust your TPS from the "Wisdom of the Forum" - The procedure for adjusting the TPS on carbs and fuel injection is the same -

http://www.ktm950.info/how/wotf/wotf...PositionSensor

Here is a reply from Dusty that has a copy of the page from the KTMmanual showing how to adjust the TPS -

http://www.advrider.com/forums/showt...+sensor&page=2

This page has a photo from Dusty also that shows how he made an access hole and used a plug to access the TPS lockdown screw so you do not have to remove your throttle bodies to make the adjustment -

http://www.advrider.com/forums/showt...osition+sensor
JTXT is offline   Reply With Quote
Old 08-08-2011, 08:52 AM   #10
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
Update

Well i got the bike into the dealer last week to have them check it out for me.
There KTM mechanic called in sick that day I was able to get them to reload the map and re set everything. But no diagnostics or anything else. the bike stalled on the way out of the parking lot but by the time i got it home ( 1.5 hour ride) it seemed better!! to be sure i also replaced the battery the next day and did another 15 min idle reset. Off i go on a 1000 mile weekend trip, the bike was running pretty good for about a day... When we got to the middle of no were everything goes to hell. the bike would not stay running from idle to 4000 RPM
I thought the thing was going to leave me stranded for sure so i made a b- line for home! it would run pretty good at 85mph+ so i got back in a hurry! the good news is that the check engine light came on and set a code

6 blinks. code 6 bad TPS sensor what a surprise. I just ordered a TPS for a 2011 for $92.00 bucks, i sure hope it is a match otherwise the efi is coming off and i am putting carbs on this POS so i can get on with my life!
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 08-11-2011, 06:52 AM   #11
boat.man OP
Chief bottle washer
 
boat.man's Avatar
 
Joined: Jun 2006
Location: N.W. Wisconsin
Oddometer: 162
Progress!

The TPS sensor part# 6104107700 for a 2011 Adventure (thanks Zuber) is a match Remember to switch the O ring. I installed it last night and set it to .61V at idle and 3.71V WFO cold. Then i did a 15 min idle reset and checked it again and was at .57V- 3.68V hot- PERFECT!
Put it all back together and went for a 40 mile ride and everything is good Knock on wood. i wont be 100% sure for a few days or even a week but it is running better than it ever has!

Thanks everyone for the input!

There may be a lot of guys out there with severe throttle snatch that may benefit from this new sensor???
__________________
When I read about the evils of drinking, I gave up reading.
07 KTM 990 Adventure
06 TE610 Sold
2 sleds
lets go play!!
boat.man is offline   Reply With Quote
Old 08-13-2011, 04:18 AM   #12
Kenbike
Studly Adventurer
 
Joined: Jul 2009
Location: South of the big lake
Oddometer: 595
It is great you got the bike fixed with out KTM getting a $1000 out of you for a part they should sell every day. I am also the pissed owner of a 2007 990, should have spent the extra for a 2010 or 2011. I am having trouble with it running terrible over 4500 rpm's and think it my be a pump that I will drop $500 for a new one. I going to test today and if it is low pressure pull it and operate on the regulator.

I wonder if the 2007/2998 owners would be better installing a new ECU and map.
__________________
Current Bikes: 2012 Yamaha Tenere, 2010 Vespa 300 Super scooter ( hers), 2011 Blur 220i (his)
Kenbike is offline   Reply With Quote
Old 09-10-2012, 04:50 PM   #13
Gustavo.Ramos
Studly Adventurer
 
Gustavo.Ramos's Avatar
 
Joined: May 2008
Location: Accross the pond
Oddometer: 696
This thread is about a year old but it has an interesting bit of information: the 2011 TPS is sold as a unit and it seems to be fit for the early 990's.

My 2006/7 is acting weird and i'm leaning towards a bad TPS. Here's what happen:

1. key on
2. kill switch off/on, fuel pump works, secondary butterflies move, tach sweeps.
3. hit start
4. engine starts perfectly, but stays at 1400/1500 revs even when in cold start, i'd guess it should be at 1700revs
5. twist the throttle in neutral, all ok, revs go up nice and easy.
6. shift first, bike not moving, throttle acts normaly
7. start moving, ok
8. still moving, pull the clutch, revs drop to 1000/900, engine stalls
9. start button, engine turns, but does not start or only start if the throttle is a bit twisted, running roughly.
10. kill switch off, then switch on, fuel pump works, etc... same as step 2.
11. hit start
12. engine starts normally, stays again at 1400/1500 revs
13. repeat step 5., 6., 7. , etc...

To summarize, in neutral, she works ok, still does not speed up the idle for cold start (weather has been hot though..), when start moving if the clutch is pulled, the revs drop and engine stalls. Even when going through 3 or 4k, if closing the throttle i can clearly feel she's going to stall like if the kill switch was switched to off and the engine is turning due to rear wheel transmission, and if the clutch is pulled, she'll stall.

This means i don't have idle speed and in traffic i face a vtwin engine lock, which in low gears will mean a locked rear wheel until the clutch is puled. Not a good sight on a +200kg bike


I'm thinking about TPS totally wrong and not recognizing idle point, yet, it's strange that after reset with kill switch on/off, will start and idle at 1400/1500 almost normally, and when detectes phisical movement will go crazy and not idle.

what do you think?
__________________
Growing old is mandatory... growing up is optional!

Raid de L'Amitié 2011 RR (link)
690R
Gustavo.Ramos is offline   Reply With Quote
Old 09-11-2012, 03:05 AM   #14
Kenbike
Studly Adventurer
 
Joined: Jul 2009
Location: South of the big lake
Oddometer: 595
I not sure but recall the clutch has a switch and your issue may be related, try a search.
__________________
Current Bikes: 2012 Yamaha Tenere, 2010 Vespa 300 Super scooter ( hers), 2011 Blur 220i (his)
Kenbike is offline   Reply With Quote
Old 09-11-2012, 08:39 AM   #15
Gustavo.Ramos
Studly Adventurer
 
Gustavo.Ramos's Avatar
 
Joined: May 2008
Location: Accross the pond
Oddometer: 696
Quote:
Originally Posted by Kenbike View Post
I not sure but recall the clutch has a switch and your issue may be related, try a search.
After some reading defenitly calls for an inspection as it seems to be much the same as GaelicDog erratic idle mentioned here:

http://www.advrider.com/forums/showthread.php?t=378672

thanks, let's see what happens
__________________
Growing old is mandatory... growing up is optional!

Raid de L'Amitié 2011 RR (link)
690R
Gustavo.Ramos is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:41 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014