ADVrider

Go Back   ADVrider > Riding > Layin' down tracks
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-10-2011, 03:26 PM   #1
tedder OP
irregular
 
tedder's Avatar
 
Joined: Jun 2004
Location: Los Angeles (ktown)
Oddometer: 8,797
GPSMAP478, can't connect via USB

I have a borrowed 478. I've connected it via USB, but my Windows PC doesn't know it is there. It's as if the 478 isn't recognizing a USB cable is connected. In setup/interface it is set to "garmin data transfer" and "host", which I assume is correct. I've tried restarting the Garmin and the PC.

I've tried with two different mini-USB cables and two different PCs. Nothing happens. Should the icon on the 478 change to indicate a computer is connected? It doesn't indicate it is charging or anything else- just the normal boring battery icon.
tedder is offline   Reply With Quote
Old 07-10-2011, 05:31 PM   #2
Steve W
Old Grouch
 
Steve W's Avatar
 
Joined: Apr 2008
Location: Rocky Mountains of Alberta
Oddometer: 648
Quote:
Originally Posted by tedder View Post
I have a borrowed 478. I've connected it via USB, but my Windows PC doesn't know it is there. It's as if the 478 isn't recognizing a USB cable is connected. In setup/interface it is set to "garmin data transfer" and "host", which I assume is correct. I've tried restarting the Garmin and the PC.

I've tried with two different mini-USB cables and two different PCs. Nothing happens. Should the icon on the 478 change to indicate a computer is connected? It doesn't indicate it is charging or anything else- just the normal boring battery icon.
What are you expecting it to do? Unless you're running MapSource or BaseCamp the unit will remain invisible to the OS. One of these programs is necessary to do anything with the unit, download or upload. The 478 does not function as a mass storage device as many of the newer units do. The usb port does not power the 478, a separate wall charger exists to charge the battery.
__________________
SW

The Weather in my Backyard
Steve W is offline   Reply With Quote
Old 07-10-2011, 06:16 PM   #3
tedder OP
irregular
 
tedder's Avatar
 
Joined: Jun 2004
Location: Los Angeles (ktown)
Oddometer: 8,797
Quote:
Originally Posted by Steve W View Post
What are you expecting it to do? Unless you're running MapSource or BaseCamp the unit will remain invisible to the OS. One of these programs is necessary to do anything with the unit, download or upload. The 478 does not function as a mass storage device as many of the newer units do. The usb port does not power the 478, a separate wall charger exists to charge the battery.
I was expecting the USB to register. In any case, MapSource doesn't "find" the GPS, so there's a problem. I'm trying to determine where the problem is. Considering my 60series and Nuvi are "found" with no problem, I tend to think there's a problem with the 478 or the mini-usb connection.

Again, I'm assuming the 478 should say "PC connected" or something similar.
tedder is offline   Reply With Quote
Old 07-10-2011, 08:47 PM   #4
Steve W
Old Grouch
 
Steve W's Avatar
 
Joined: Apr 2008
Location: Rocky Mountains of Alberta
Oddometer: 648
Quote:
Originally Posted by tedder View Post
Again, I'm assuming the 478 should say "PC connected" or something similar.
It will flash "usb connected" briefly on the screen and it must be turned on. Sorry for the confusion, there was no mention of MapSource in your original post and most new Garmins can connect directly and show up as a mountable drive. Garmin has their own usb drivers. It might be a good idea to download the latest and install, if that still doesn't work it's probably the 478 port.
__________________
SW

The Weather in my Backyard
Steve W is offline   Reply With Quote
Old 07-10-2011, 10:26 PM   #5
tedder OP
irregular
 
tedder's Avatar
 
Joined: Jun 2004
Location: Los Angeles (ktown)
Oddometer: 8,797
Quote:
Originally Posted by Steve W View Post
It will flash "usb connected" briefly on the screen and it must be turned on.
Hmm. Not seeing that flashing.

Quote:
Sorry for the confusion, there was no mention of MapSource in your original post and most new Garmins can connect directly and show up as a mountable drive. Garmin has their own usb drivers. It might be a good idea to download the latest and install, if that still doesn't work it's probably the 478 port.
Thanks. I downloaded the most recent drivers, no dice. I'm suspecting something on the GPS side or the cable.
tedder is offline   Reply With Quote
Old 07-11-2011, 04:07 AM   #6
9Dave
Bazinga!
 
9Dave's Avatar
 
Joined: Aug 2005
Location: Central Ohio
Oddometer: 12,831
Does the 478 work with the owner's PC? If so, I'd suspect a driver issue.

If not - well, then you could have either a USB port problem on the 478, or a cable problem. The cable is just a standard mini USB.

There is a thread buried in here somewhere about how to uninstall/reinstall drivers, complete with how to remove the prior version from the registry. A google search might find it.

All of my GPS were "found" by Windows on connection.
__________________


dunno.....
9Dave is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:45 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014