ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-10-2013, 06:51 PM   #8191
Gros Buck
Beef = Packed Vegetables
 
Gros Buck's Avatar
 
Joined: Jun 2006
Location: Quebec City, Canada
Oddometer: 847
Quote:
Originally Posted by Seth S View Post
hmmmm...Its possible I am using the next size down on the 2.5" rim...I have not had any issues.

edit: right now I have no rim locks on the bike because I have Rally Mousse in the tires
Let's assume you installed that 2.15 and tighten the screw ... You have any clue they were doing their job properly ? I mean, they may have not lock the tire at all after all. I ride at 20 PSI and never felt the need to install rim lock ... It was a very different story on my previous Jap bike. I thought of installing two rim locks at one point ...


Paul Jr
__________________
KTM690r 2011

Gros Buck screwed with this post 04-10-2013 at 07:00 PM
Gros Buck is offline   Reply With Quote
Old 04-10-2013, 06:57 PM   #8192
Biped
NooB Again
 
Biped's Avatar
 
Joined: Jul 2008
Location: Oregon, Wet Side
Oddometer: 265
Quote:
Originally Posted by StepOnIt View Post
thanks for your lack of help...should have asked your better half . As long as you are telling me I am screwed vs trying to screw me all is good.
Maybe this will help you feel less screwed.

http://advrider.com/forums/showpost....54&postcount=1
__________________
If it moves and it should not, duct tape it, if it does not move and it should WD40 it!
Biped is offline   Reply With Quote
Old 04-10-2013, 07:12 PM   #8193
DrtSqtr
Gnarly Adventurer
 
DrtSqtr's Avatar
 
Joined: Apr 2008
Location: Ponchatoula,LA
Oddometer: 139
zip ty magnetic drain plug

Anyone have a problem installing a Zip Ty Racing magnetic drain plug? Mine seems to want to start but buy the 2nd thread it starts to bind and does not want to go in any further. I removed and installed the original one to make sure i didnt mess up the threads and it screws in just fine.Tried a few times with same result in 2 threads then binds. Any thoughts suggestions? Thanks
DrtSqtr is offline   Reply With Quote
Old 04-10-2013, 07:46 PM   #8194
StepOnIt
Assitoner
 
StepOnIt's Avatar
 
Joined: Jan 2010
Location: Huntsville ON.
Oddometer: 937
thanks

That was the thread I was looking for and couldn't find again.
thanks so much, makes life less screwed, for the bike that is..

Quote:
Originally Posted by Biped View Post
Maybe this will help you feel less screwed.

http://advrider.com/forums/showpost....54&postcount=1
__________________
The road less traveled is the road I travel more.

"I feel sorry for people who don't drink. When they wake up in the morning, that's as good as they're going to feel all day." Dean Martin
StepOnIt is offline   Reply With Quote
Old 04-11-2013, 06:01 AM   #8195
Seth S
Safari Scramble!!!!!
 
Seth S's Avatar
 
Joined: Jul 2004
Location: sanity?
Oddometer: 4,145
Quote:
Originally Posted by Gros Buck View Post
Let's assume you installed that 2.15 and tighten the screw ... You have any clue they were doing their job properly ? I mean, they may have not lock the tire at all after all. I ride at 20 PSI and never felt the need to install rim lock ... It was a very different story on my previous Jap bike. I thought of installing two rim locks at one point ...


Paul Jr
Well considering i had to mount the tire myself and I had to fight the bead under the rim lock and I had done it with a Mousse in the tire...I am pretty sure that the rim lock was working. I also had to take the thing apart to remove the rim locks after everyone said not to run them with the Mousse . But it has been a while and its quite possible I in fact have the larger black rim lock in there. I definitely have the blue one on the front.
__________________
Seth S

My intuition nearly makes up for my lack of good judgement. Just installed my new trolling motor
Seth S is offline   Reply With Quote
Old 04-11-2013, 06:03 AM   #8196
Seth S
Safari Scramble!!!!!
 
Seth S's Avatar
 
Joined: Jul 2004
Location: sanity?
Oddometer: 4,145
Quote:
Originally Posted by Gros Buck View Post
Let's assume you installed that 2.15 and tighten the screw ... You have any clue they were doing their job properly ? I mean, they may have not lock the tire at all after all. I ride at 20 PSI and never felt the need to install rim lock ... It was a very different story on my previous Jap bike. I thought of installing two rim locks at one point ...


Paul Jr
Note #2. At 20 psi you shouldn't have any need for a rim lock...the pressure in the tires puts enough force on the bead to secure it in place. I run the rim locks when I have tubes in the tires and am running around 10 to 13 psi front and rear.
__________________
Seth S

My intuition nearly makes up for my lack of good judgement. Just installed my new trolling motor
Seth S is offline   Reply With Quote
Old 04-11-2013, 11:36 AM   #8197
BK.RD.RNR
Torque Stick
 
BK.RD.RNR's Avatar
 
Joined: Dec 2008
Location: Livin' in the 90's
Oddometer: 5,391
Quote:
Originally Posted by snohobo View Post
When I originally got this code back in Colombia (10,000 miles ago) - I was running the stock filter. I brought it to the dealer - and they cleared the code and changed my spark plug. He also sold me a higher flow foam filter - which I didn't install until at least 2,000 miles later.

I'm still running the new foam filter - but at one point in my trip one of the inserts ripped out of the top of the airbox. i've been expoying it back on ever since. I suspect it's letting in a little bit more air into the box because the lid doesnt sit as flush as it used to - but it's been like that for thousands of miles.

Have you tried using a couple of zip ties to secure the lid/ snorkel? I did it that way on mine, and it is more confidence inspiring than wondering if the grommets will pull out again while on a ride. Also did it as a backup on my new 2012 so that I dont have to worry about the possibility of it coming undone.


I could try putting on my buddies airbox to see if it changes anything. Or go back to the paper filter.
If you want/ need a new airbox, I have one brand new in the bag that I would be willing to part with.. pm me if interested.
__________________

Quote:
Originally Posted by metaljockey View Post
None of us are exceptionally skilled riders (excepting when I'm drunk, then I'm fcking quick).
BK.RD.RNR is offline   Reply With Quote
Old 04-11-2013, 01:40 PM   #8198
Hoots
Beastly Adventurer
 
Hoots's Avatar
 
Joined: May 2011
Location: Gundaroo NSW OZ
Oddometer: 1,252
Quote:
Originally Posted by Seth S View Post
Note #2. At 20 psi you shouldn't have any need for a rim lock...the pressure in the tires puts enough force on the bead to secure it in place. I run the rim locks when I have tubes in the tires and am running around 10 to 13 psi front and rear.
This was my concern also ...

I'm intending to drop the rear to about 15, but leave the front reasonably high to protect the rim from rock jarring ...

I'm not going to fit one to the front at this stage ...

I found some 2.5" light-weight billet alloy rim locks, which should be OK ...

Just a short term adjustment - keen to retry the couple of hills that undid me a month or so ago - want to see how much difference lowered tyre pressures actually makes to traction on long steep stretches of loose rock ...
Hoots is offline   Reply With Quote
Old 04-11-2013, 03:46 PM   #8199
motoged
Studly Adventurer
 
motoged's Avatar
 
Joined: Feb 2006
Location: Kamloops, BC
Oddometer: 883
Quote:
Originally Posted by Hoots View Post
.....
I found some 2.5" light-weight billet alloy rim locks, which should be OK ...
J..
These?

http://www.rockymountainatvmc.com/p/...?term=rim+lock

__________________
Ged Schwartz
Kamloops , BC


Baja '05 , Baja 06/07 , Baja 08/09 , BC Alpine Single Track




motoged is offline   Reply With Quote
Old 04-11-2013, 04:47 PM   #8200
Hoots
Beastly Adventurer
 
Hoots's Avatar
 
Joined: May 2011
Location: Gundaroo NSW OZ
Oddometer: 1,252
Quote:
Originally Posted by motoged View Post
No

I've used those on a DR650, and didn't like them - too heavy and not well made.

I've ordered some from Torpedo 7:

http://www.torpedo7.com.au/products/...y-cnc-rim-lock
Hoots is offline   Reply With Quote
Old 04-11-2013, 05:03 PM   #8201
Baja Dad
Beastly Adventurer
 
Baja Dad's Avatar
 
Joined: Jan 2011
Location: Norco California
Oddometer: 1,856
I rum rim locks with bibs all the time allways have.
You need too or you will spin the tire.
Yes I know what I am talking about !
I worked for Michelin as a Tire rep at the SCORE races for 5 years.
I have mounted 1000' of Bibs!!!!
__________________
2014 support: GPR,IMS Aurora Rally Kriega, Raiden LS2,100Goggles,SIDI,Seat Concepts, Rally Raid Products UK,Precision Concepts, MX1West,Dunlop
Baja Dad is offline   Reply With Quote
Old 04-11-2013, 05:18 PM   #8202
MrHix
Gnarly Adventurer
 
MrHix's Avatar
 
Joined: Mar 2012
Location: MO
Oddometer: 388
Quote:
Originally Posted by Baja Dad View Post
I rum rim locks with bibs all the time allways have.
You need too or you will spin the tire.
Yes I know what I am talking about !
I worked for Michelin as a Tire rep at the SCORE races for 5 years.
I have mounted 1000' of Bibs!!!!
How about running pinned rims instead? Will the beads remain seated on them with the bibs?

Cheers,

MrHix
MrHix is offline   Reply With Quote
Old 04-11-2013, 06:48 PM   #8203
invisible monster
Gnarly Adventurer
 
invisible monster's Avatar
 
Joined: Sep 2007
Location: Perry County, OH
Oddometer: 483
Any of the US 690 owners on here have a stock taillight/turn signal assembly laying around they want to get rid of? My taillight/brakelight is getting wonky and I figured someone would have one based on how many posts I see about people replacing them with an LED unit. Shoot me a PM if you can help.

And just to keep in time with the recent posts about rim locks. I run one on the rear wheel of my 690. I don't run my tire pressures lower than maybe 18-20 lbs in the rear so I guess I probably don't really need one but I like the insurance against tearing a valve stem.
invisible monster is offline   Reply With Quote
Old 04-11-2013, 07:12 PM   #8204
modeselector
Common as muck
 
modeselector's Avatar
 
Joined: Jul 2009
Location: Washington USA
Oddometer: 621
Quote:
Originally Posted by invisible monster View Post
Any of the US 690 owners on here have a stock taillight/turn signal assembly laying around they want to get rid of? My taillight/brakelight is getting wonky and I figured someone would have one based on how many posts I see about people replacing them with an LED unit. Shoot me a PM if you can help.
I have an almost new brake light minus signals. Send PM with email and I can shoot you over a photo.
modeselector is offline   Reply With Quote
Old 04-11-2013, 08:32 PM   #8205
Seth S
Safari Scramble!!!!!
 
Seth S's Avatar
 
Joined: Jul 2004
Location: sanity?
Oddometer: 4,145
Quote:
Originally Posted by Baja Dad View Post
I rum rim locks with bibs all the time allways have.
You need too or you will spin the tire.
Yes I know what I am talking about !
I worked for Michelin as a Tire rep at the SCORE races for 5 years.
I have mounted 1000' of Bibs!!!!
Ran the rally bibs at the safari rally in 2011a and did not run rim locks. Never spun a tire or had any issues. None of my team mates ran rim locks either. We pulled and relubed them every day.


I do run rim locks with the enduro bibs though as they are much smaller
__________________
Seth S

My intuition nearly makes up for my lack of good judgement. Just installed my new trolling motor
Seth S is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:54 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014