ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-16-2013, 07:48 PM   #301
Kirkster
Parts Murderer
 
Joined: Dec 2011
Location: Peoples Republic of MD
Oddometer: 296
Anyone lost a fuel pump yet?

I am getting my spares ready for my TAT ride in June and am looking for spares.

a cycleworks fuel pump
a spare fuel injector
wire and crimpers and connectors...

Not sure what else as my 690 has been pretty bulletproof...
__________________
TAT 2013 the "I'm Just Sayin" tour
BMW 2007 R1200R
2012 KTM 690 R
07 WR 450F
Kirkster is offline   Reply With Quote
Old 05-16-2013, 07:56 PM   #302
Kirkster
Parts Murderer
 
Joined: Dec 2011
Location: Peoples Republic of MD
Oddometer: 296
nuked
__________________
TAT 2013 the "I'm Just Sayin" tour
BMW 2007 R1200R
2012 KTM 690 R
07 WR 450F
Kirkster is offline   Reply With Quote
Old 06-02-2013, 02:20 PM   #303
LordSteven
Adventurer
 
LordSteven's Avatar
 
Joined: Aug 2012
Location: Worthington, Ma
Oddometer: 42
2012 690 throttle body

I know this has been covered but I have not seen a solid answer yet. My throttle body blew off today, simple fix on the side of the trail but I need to make sure it does not happen again. I have read the clamp is not tight enough, the box needs to be moved forward. Neither of these makes a lot of sense when I look at the set up. I was hoping someone that owns a 2012 690 had this problem and fixed it for good. Any help is much appreciated. Thanks
LordSteven is offline   Reply With Quote
Old 06-02-2013, 05:40 PM   #304
palmstatecrawler
Gnarly Adventurer
 
palmstatecrawler's Avatar
 
Joined: Apr 2013
Location: Columbia, SC
Oddometer: 481
When I brought my 2013 home from the dealer I went around the bike with a bottle of blue loctite making sure I dont lose any bolts. Upon further inspection I found that the throttle body clamp was just dangling on the hose! Great QC ktm... I dont have many miles on mine yet but the only problem i've had is a coil wire coming loose and throwing an FI code. Easy fix. Fingers crossed everything continues this way.
__________________
'13 KTM 690 Enduro R w/ full akrapovic exhaust, Evo1 lid, uni filter, Renazco seat, hard parts windshield and footpad, scotts damper with BRP submount, hammerhead shifter, flatlands skidplate, lost dog centerstand, Touratech engine guards, r&g front and rear axle and exhaust sliders, piaa 1100's, Doubletake mirrors, G2cam system,
'07 Kawasaki KLX250, '86 Yamaha BW80
palmstatecrawler is offline   Reply With Quote
Old 06-03-2013, 03:20 AM   #305
creedyflyr
Gnarly Adventurer
 
creedyflyr's Avatar
 
Joined: Jan 2011
Location: Port Stephens NSW Australia
Oddometer: 225
Quote:
Originally Posted by LordSteven View Post
I know this has been covered but I have not seen a solid answer yet. My throttle body blew off today, simple fix on the side of the trail but I need to make sure it does not happen again. I have read the clamp is not tight enough, the box needs to be moved forward. Neither of these makes a lot of sense when I look at the set up. I was hoping someone that owns a 2012 690 had this problem and fixed it for good. Any help is much appreciated. Thanks
1) Undo Clamp
2) Take spacer out of clamp
3) reinstall clamp
problem solved
creedyflyr is offline   Reply With Quote
Old 06-03-2013, 05:44 PM   #306
LordSteven
Adventurer
 
LordSteven's Avatar
 
Joined: Aug 2012
Location: Worthington, Ma
Oddometer: 42
Thanks

OK, thanks for the reply. I'll do it tomorrow. This site is the best.
LordSteven is offline   Reply With Quote
Old 06-03-2013, 09:16 PM   #307
CanadianX
Oh!? That is deep.
 
CanadianX's Avatar
 
Joined: Dec 2010
Location: Ontario
Oddometer: 1,438
Quote:
Originally Posted by LordSteven View Post
I know this has been covered but I have not seen a solid answer yet. My throttle body blew off today, simple fix on the side of the trail but I need to make sure it does not happen again. I have read the clamp is not tight enough, the box needs to be moved forward. Neither of these makes a lot of sense when I look at the set up. I was hoping someone that owns a 2012 690 had this problem and fixed it for good. Any help is much appreciated. Thanks
Mine (2012) was backfiring back through the throttle body and blowing the air box coupler off and pushing the air box back in the process. Did it hard enough once to cause the air bot to hit the APS sensor and crack it. (Replaced under warranty).

I added a FMF pipe, unifiter and a tune for the 2012. No more stalling or backfiring issues, and no more furnace under my ass with the stock can gone.
CanadianX is offline   Reply With Quote
Old 06-07-2013, 08:34 AM   #308
LordSteven
Adventurer
 
LordSteven's Avatar
 
Joined: Aug 2012
Location: Worthington, Ma
Oddometer: 42
690 gas fill ups?

I bought mine used with 1900 miles and the air box mod and pipe were done. BUT, when I try to fill my tank it overflows alot of the time. What can I do to get the tank filled without overflowing? My light comes on after 100 - 115 miles depending on type of riding. There must still be a gallon in there because I added 2 gal. last time after light came on and it still spilled. Any help would be great. Thanks
LordSteven is offline   Reply With Quote
Old 06-07-2013, 09:12 AM   #309
TheMuffinMan
Forest Ranger Magnet
 
TheMuffinMan's Avatar
 
Joined: Mar 2010
Location: Denver, USA
Oddometer: 5,631
Quote:
Originally Posted by LordSteven View Post
I bought mine used with 1900 miles and the air box mod and pipe were done. BUT, when I try to fill my tank it overflows alot of the time. What can I do to get the tank filled without overflowing? My light comes on after 100 - 115 miles depending on type of riding. There must still be a gallon in there because I added 2 gal. last time after light came on and it still spilled. Any help would be great. Thanks

http://www.renazcoracing.com/index.c...&itemid=538852
__________________
"To strive, to seek, to find, and not to yield."
KTM 525 XC-W // KTM 950 Adventure
690 Wiki
TheMuffinMan is offline   Reply With Quote
Old 06-07-2013, 06:06 PM   #310
LordSteven
Adventurer
 
LordSteven's Avatar
 
Joined: Aug 2012
Location: Worthington, Ma
Oddometer: 42
YES, Thanks

That isn't helpful, thanks though. I need to carry at least 3/4 of the capacity to avoid getting stuck in woods with no "petro" gas. I think there is a bigger issue. Tank is over 3gal I should be able to carry 2.5 without an issue.
LordSteven is offline   Reply With Quote
Old 06-08-2013, 01:49 AM   #311
BygDaddee
Where do I get a pie
 
BygDaddee's Avatar
 
Joined: Oct 2012
Location: Brisbane Northside, OZ
Oddometer: 1,570
Are you saying its overflowing while your riding ?, if so it must be a cap problem, mine doesn't leak at all no matter how full.

Or are you saying it overflows as you are filling it, if so my first reply applies.

Quote:
Originally Posted by LordSteven View Post
That isn't helpful, thanks though. I need to carry at least 3/4 of the capacity to avoid getting stuck in woods with no "petro" gas. I think there is a bigger issue. Tank is over 3gal I should be able to carry 2.5 without an issue.
__________________
Relax and enjoy the journey, not just the destination.
2013 WR450F(The best bike KTM never built) and BMW G650GS Sertao (The refined mans DR)
Pauls Spot Tracker http://share.findmespot.com/shared/f...mgxmQRRUCqrKiY

BygDaddee screwed with this post 06-08-2013 at 03:08 PM
BygDaddee is online now   Reply With Quote
Old 06-08-2013, 05:44 AM   #312
sprouty115
Beastly Adventurer
 
sprouty115's Avatar
 
Joined: May 2012
Location: Providence, RI
Oddometer: 1,274
Quote:
Originally Posted by LordSteven View Post
That isn't helpful, thanks though. I need to carry at least 3/4 of the capacity to avoid getting stuck in woods with no "petro" gas. I think there is a bigger issue. Tank is over 3gal I should be able to carry 2.5 without an issue.
There is a gasket under the cap and an oring under the flange that attaches to the tank (held in by three screws). One of those is either missing or damaged. You should be able to fill the tank right up to the top and not have a leak.
sprouty115 is online now   Reply With Quote
Old 06-08-2013, 06:58 AM   #313
rdkyote
Adventurer
 
rdkyote's Avatar
 
Joined: May 2012
Location: Colorado
Oddometer: 67
Quote:
Originally Posted by LordSteven View Post
I know this has been covered but I have not seen a solid answer yet. My throttle body blew off today, simple fix on the side of the trail but I need to make sure it does not happen again. I have read the clamp is not tight enough, the box needs to be moved forward. Neither of these makes a lot of sense when I look at the set up. I was hoping someone that owns a 2012 690 had this problem and fixed it for good. Any help is much appreciated. Thanks
I'm sure there are a lot of different solutions to this problem. On mine, the coolant overflow tube was routed under the air box and, sort of like a bungee cord, was pushing the whole thing out of the TB on the trail. Now, I am sure if I had I figured out the clamp thing and got it cranked down that would have fixed the problem. As it was, I just rerouted the overflow and dumped the SAS and haven't had the problem since and I just have normal-light torque on the hose clamp.
__________________
2012 KTM 690 Enduro R
2007 KTM 250 XC
rdkyote is offline   Reply With Quote
Old 06-09-2013, 04:46 PM   #314
PatSmith
Gnarly Adventurer
 
Joined: Aug 2011
Location: Sacramento
Oddometer: 391
FREE to a good home- you pay shipping

I just changed the gearing on my 2012 690. The stock 15/45 are free to anyone that is willing to pay the shipping.
Pm me
PatSmith is offline   Reply With Quote
Old 06-09-2013, 04:49 PM   #315
PatSmith
Gnarly Adventurer
 
Joined: Aug 2011
Location: Sacramento
Oddometer: 391
17 tooth cs sprocket

I tried a 17 tooth cs sprocket today and found it had slight interference with the rubber swing arm protector. Went to a 16 instead. Is anyone using a 17 cs on a 12 enduro?
PatSmith is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:12 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014