ADVrider

Go Back   ADVrider > Bikes > GSpot > Parallel Universe
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-07-2013, 09:55 AM   #16
Mtl_Biker
Studly Adventurer
 
Mtl_Biker's Avatar
 
Joined: Jun 2011
Location: Montreal, Canada
Oddometer: 553
My dealer changed the brake lever to the adjustable one (which I thought was the one I ordered originally) and this one fits ABOVE the foot peg. Even if the other one does fit, I didn't like it because it would be the lowest point on that side of the bike and the first spot to scrape ground in tight leaned over corning.

Tried to install it last night and couldn't get the original bolt open. Ended up rounding the head of the bolt and now it's going to have to be drilled out. SIGH I don't know if it was over-torqued at the factory or if they used Red Loctite or what, but even with a properly fitting torx bit I just couldn't get it off.

Luckily I've got my first service on the bike in the morning and I'll get the dealer to fix it for me.

Quote:
Originally Posted by Angryrican View Post
It is the right brake lever, it threw me off when I got mine since it curves under the foot peg but it fits and works fine.
Mtl_Biker is offline   Reply With Quote
Old 04-07-2013, 05:47 PM   #17
murdock84 OP
Studly Adventurer
 
Joined: Apr 2012
Location: Elizabethtown, PA
Oddometer: 548
[QUOTE=Mtl_Biker;21129248
Tried to install it last night and couldn't get the original bolt open. Ended up rounding the head of the bolt and now it's going to have to be drilled out. SIGH I don't know if it was over-torqued at the factory or if they used Red Loctite or what, but even with a properly fitting torx bit I just couldn't get it off..[/QUOTE]

Had almost the same problem here as well. I think it had blue locktite on. My stupid torx head was also stripped out when it finally came out. I re-tapped the hole and put a bolt with a standard box end wrench head in there. I had trouble getting a few screws and bolts out and back in the bike during mods. I bought a tap and die kit and that has been the ticket.
murdock84 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:50 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014