ADVrider

Go Back   ADVrider > Gear > Equipment
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-29-2005, 02:50 PM   #1
GS Jonny OP
Killer Bee
 
GS Jonny's Avatar
 
Joined: Oct 2002
Location: NJ
Oddometer: 130
new odyssey battery

Hey Everyone,

I just ordered a new Odyssey pc680 for my GS from ebay. Will I need to charge it before I intall it? If so, what do I need for that?

Thanks!
John
__________________
And the trouble is, if you don't risk anything, you risk even more.
~Erica Jong
GS Jonny is offline   Reply With Quote
Old 05-29-2005, 04:12 PM   #2
Lone Rider
Registered User
 
Joined: Jan 2002
Location: out and about
Oddometer: 25,130
Dunno.....

But...you'll need to bend the connector(s) going to the battery and work-off a nut that's attached to one of them. No biggy...just get aggressive with some pliers.
Lone Rider is offline   Reply With Quote
Old 05-29-2005, 04:35 PM   #3
Frank Warner
Traveller
 
Frank Warner's Avatar
 
Joined: Mar 2002
Location: Sydney, Australia
Oddometer: 6,593
Quote:
Originally Posted by GS Jonny
I just ordered a new Odyssey pc680 for my GS from ebay. Will I need to charge it before I intall it?
No. At least mine have all gone straight on to th ebike.. and both are still going ..
Frank Warner is offline   Reply With Quote
Old 05-30-2005, 04:44 AM   #4
rayder
Adventurer
 
Joined: Jun 2004
Location: midwest michigan
Oddometer: 91
I just put my ebay odyessy in last week, already charged right out of the box. But I did have to stretch the cables a little and make an extension for the negative side.
It's nice to ride without the ABS lights flashing for the first three miles until I could stop and reset and start with a warm engine.
rayder is offline   Reply With Quote
Old 05-30-2005, 07:56 AM   #5
SFSlim
Dada Buddhist Biker Punk
 
SFSlim's Avatar
 
Joined: Jun 2004
Location: San Francisco, CA
Oddometer: 1,200
Quote:
Originally Posted by rayder
It's nice to ride without the ABS lights flashing for the first three miles until I could stop and reset and start with a warm engine.
Glad to hear I'm not the only one with that problem.

Also, just bought a new odyssey on Craigslist. Will pick it up sometime this week and install - Hope I get the same results as you!

- SFSlim
SFSlim is offline   Reply With Quote
Old 05-30-2005, 08:06 AM   #6
GS Jonny OP
Killer Bee
 
GS Jonny's Avatar
 
Joined: Oct 2002
Location: NJ
Oddometer: 130
thanks

Thanks for the info guys. I can't wait to install it and go for a ride!

Later,
John
__________________
And the trouble is, if you don't risk anything, you risk even more.
~Erica Jong
GS Jonny is offline   Reply With Quote
Old 05-30-2005, 08:15 AM   #7
Jhammer
Gnarly Adventurer
 
Jhammer's Avatar
 
Joined: Nov 2004
Location: Joplin Missouri
Oddometer: 277
Hi, I have been thinking of buying one of there battery's, on there website they have charging instructions and they sell a 90deg L for the top of the battery so you do not have to bend your clamps. : http://www.odysseybatteries.com/bmwposts.htm
Jhammer is offline   Reply With Quote
Old 05-30-2005, 11:04 AM   #8
Makalu
Beastly Adventurer
 
Makalu's Avatar
 
Joined: Oct 2003
Location: Event horizon
Oddometer: 2,826
Just another ditto to the above. My battery was fully charged and ready to go. I made a 90 adapter and a have had no problems. Some here just straighten out the stock cable connector. If you go that route, get it right the first time, because they have been known to break off. You'll love the battery.
Makalu is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:59 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014