ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-30-2012, 11:31 PM   #1
kawasakiklx OP
Adventurer
 
Joined: Jun 2012
Location: Chico, CA
Oddometer: 10
XR600r CDI vs XL600r CDI

I have done a lot of research about this and haven't found a definitive answer. My question is simple but rather specific.

Since I couldn't find a reasonable price for a CDI unit for my '85 XL600r I ordered a unit from a newer (88-00) XR600r.

The unit I ordered looks to have the two individual rectangular connection but my question is: Is this plug and play on my bike?

I know I can at least swap some wires on my harness around but I'm not sure yet. I was really hoping at least one person has done this before and could tell me for sure.

Here is a link to the unit I ordered, http://www.amazon.com/gp/product/B00...ls_o02_s00_i01

Any help is appreciated. I am a SOLID 1 for 1 on getting help here so far, scored a great deal on a nice OEM cam. Thanks again, Steve, I know you'll read this
kawasakiklx is offline   Reply With Quote
Old 07-31-2012, 04:44 AM   #2
mcma111
Beastly Adventurer
 
mcma111's Avatar
 
Joined: Jul 2007
Location: San Francisco,Ca.
Oddometer: 10,043
Yep, here I am
__________________
Steve in SF

BMW's
58 R26
79 R100s
91 R100gs

87 Harley FXRS-SP ~ 06 KTM 625 SMC ~ 72 Honda CB750/915cc ~ 92 XR600/654cc ~ 95 XR650l/675cc ~ 03 CRF450r ~ 05 CRF450x ~ 02 XR650l/675cc ~ 86 YZ490 ~ 93 YZ80 ~ 93 XR650l Project
mcma111 is offline   Reply With Quote
Old 07-31-2012, 08:27 AM   #3
uranys
Gnarly Adventurer
 
Joined: Oct 2007
Location: Steeler Nation
Oddometer: 188
Quote:
Originally Posted by kawasakiklx View Post
I have done a lot of research about this and haven't found a definitive answer. My question is simple but rather specific.

Since I couldn't find a reasonable price for a CDI unit for my '85 XL600r I ordered a unit from a newer (88-00) XR600r.

The unit I ordered looks to have the two individual rectangular connection but my question is: Is this plug and play on my bike?

I know I can at least swap some wires on my harness around but I'm not sure yet. I was really hoping at least one person has done this before and could tell me for sure.

Here is a link to the unit I ordered, http://www.amazon.com/gp/product/B00...ls_o02_s00_i01

Any help is appreciated. I am a SOLID 1 for 1 on getting help here so far, scored a great deal on a nice OEM cam. Thanks again, Steve, I know you'll read this
If the connectors are the same, probably but the only way to know for sure would be to compare the wiring diagrams. However neither of the diagrams have the connector pinouts. I was planning on putting a new battery in my bike tonight (96 xr600) I can snap a pick of the harness/connectors/cdi if it would help.
uranys is offline   Reply With Quote
Old 07-31-2012, 08:53 AM   #4
kawasakiklx OP
Adventurer
 
Joined: Jun 2012
Location: Chico, CA
Oddometer: 10
That would be a huge help, thanks!
kawasakiklx is offline   Reply With Quote
Old 08-01-2012, 01:47 PM   #5
uranys
Gnarly Adventurer
 
Joined: Oct 2007
Location: Steeler Nation
Oddometer: 188
Not the greatest pics but...





hth
uranys is offline   Reply With Quote
Old 08-01-2012, 05:17 PM   #6
kawasakiklx OP
Adventurer
 
Joined: Jun 2012
Location: Chico, CA
Oddometer: 10
Thanks SO MUCH for taking the time to do that. People like you are few and far between.

Update: The 88-00 XR600r CDI from Rick's works perfectly in my XL600r (so far) rides great. Plug and play, I verified the wiring with the above pics.
kawasakiklx is offline   Reply With Quote
Old 08-03-2012, 10:46 AM   #7
uranys
Gnarly Adventurer
 
Joined: Oct 2007
Location: Steeler Nation
Oddometer: 188
No problem, glad to hear you got your bike going again.
uranys is offline   Reply With Quote
Old 11-08-2012, 01:50 PM   #8
brokeagain
Gnarly Adventurer
 
Joined: Aug 2012
Oddometer: 142
Hi!

Just want to make sure that someone else doesn't make the same mistake I did upon stumbing on this thread.

The CDI box that is linked has a DIFFERENT CONNECTOR than the '83/84 XL600R.

After seeing this thread, I went ahead and ordered it without actually looking at the connection. I figured I would knock it all out when I was putting my Ricky Stator in today. Unfortunately, my ('84) connector is round with the 6 pins, vs what looks like the two-in-one 6 pin connector for the CDI box shown above in the photo.

I'm going to work on figuring out which wires connect to which pins on the new CDI by comparing it to the diagram in the manual for my bike and the 88-00 XR600R, and also a way to connect them up without the wires touching each other ... I'll post when I get it done.

Just wanted to get that information out there, is all.

EDIT:

I just came across this post, it seemed very helpful. If anyone has a link for an 88-00 XR600r Manual, or at least the CDI pinout/color parts just so I can be sure, let me know. I'm having trouble locating one. Thanks!

brokeagain screwed with this post 11-08-2012 at 02:45 PM Reason: Found some info.
brokeagain is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014