ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (950/990cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-20-2014, 11:22 PM   #1
yvautrin OP
Dive & Ride
 
Joined: Sep 2010
Location: Sharm El Sheikh, Egypt
Oddometer: 21
A few questions!

Good morning to everyone, I have a few questions for the KTM experts hanging around here!

Since a couple of weeks, there is a "click-click-click" kind of noise on the right side on the bike. I thought it was the waterpump, so I rebuilded it (it was necessary at the end, as one of the bearings was dead!), but I still have the same noise...any idea?

Changed the engine oil as well, and the oil light on the "dashboard" doesn't go off...

Now, I start as well to have a leak on the fuel tap of the right tank when it is on open position, i took it off, celaned it, disassemble it, nothing looks suspicious...Should I replace it? anyone knows of other tap I can put on my bike instead of the OEM KTM ones?

Bike : 990 Adv S EU 2008


Thanks for your help!

Cheers!
yvautrin is offline   Reply With Quote
Old 07-20-2014, 11:26 PM   #2
yvautrin OP
Dive & Ride
 
Joined: Sep 2010
Location: Sharm El Sheikh, Egypt
Oddometer: 21
one more....

oops! sorry, one more question!

I replaced the Light bulb (H7), as the low beam was not working anymore, and still the same....Hi Beam=ok, Low Beam=nothing...


Thanks
yvautrin is offline   Reply With Quote
Old 07-21-2014, 08:55 AM   #3
oldfuddy
Gnarly Adventurer
 
oldfuddy's Avatar
 
Joined: Aug 2013
Location: SouthWest
Oddometer: 403
Quote:
Originally Posted by yvautrin View Post

Since a couple of weeks, there is a "click-click-click" kind of noise on the right side on the bike.

Changed the engine oil as well, and the oil light on the "dashboard" doesn't go off...

Now, I start as well to have a leak on the fuel tap...!
You've got several issues, only two might be related.

Yes, buy a new OEM petcock and be done with it....

Oil light won't go out and a clicking in the motor with fresh oil sounds like a pump problem... I'd take the bike to someone with experience that can check oil pressure or narrow down what's clicking...

As for your light, try another bulb to be sure, if high beam won't work you'll need to trace the wire from the headlight to the switch. Could be cracked/broke or just rusted at a connector.
oldfuddy is online now   Reply With Quote
Old 07-21-2014, 02:36 PM   #4
Peanuts
Beastly Adventurer
 
Peanuts's Avatar
 
Joined: Sep 2009
Location: UK
Oddometer: 1,523
Dont ride it until the clicking has been cured.

Did you use a genuine KTM oil filter when you did the oil change? Non genuine ones have been known to cause problems.
Peanuts is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:04 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014