ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-20-2012, 02:32 PM   #1
Black Hills OP
Studly Adventurer
 
Joined: Apr 2011
Location: Western South Dakota
Oddometer: 896
advice for BRP users

installed a BRP triple clamp with a scott's damper a while ago, works great!! After a spirited ride (some air) I find one fork tube slid through the clamps? Retorque everything and repeat the ride with the same resutls? After a closer look it appears the bolts are bottoming in the holes before tightening on the tubes. I contact BRP and after a series of e-mails I discover some clamps were sold with intructions stating to use the stock bolts (30mm i think?). those are wrong according to BRP and thier clamps should only be used with 25mm bolts they supply. So, if you used stock bolts in a BRP clamp it would be in your best interest to replace them with the proper size. just an FYI.
Black Hills is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:26 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014