ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-07-2012, 04:38 PM   #1
The Savage Rabbit OP
Adventurer
 
The Savage Rabbit's Avatar
 
Joined: Mar 2009
Location: Agoura Hills, CA
Oddometer: 85
Finally joined the club

Just bought 2005 950 Adventure. 8,500 miles. Gel seat, engine guards, panniers, gps mount, and akropavic exhaust. The bike is everything I hoped it would be. It runs great. However, the coolant disappears from the reservoir. Taking it to my local deal tomorrow for a full inspection and to investigate the disappearing coolant. Despite that, the bike runs great.

Assuming the coolant thing is a relatively easy fix, I am very happy.
__________________
2012 KTM 990 Adventure
2014 Triumph Street Triple R
The Savage Rabbit is offline   Reply With Quote
Old 12-07-2012, 05:37 PM   #2
cjracer
AWD please!!
 
cjracer's Avatar
 
Joined: Sep 2005
Location: Mukwonago, WI
Oddometer: 3,951
Welcome!

Boy sure is a hot month for new LC8 ADV owners. Congrats.


My guess would be waterpump shaft and seal. Older bike sitting, about the right miles. Fix it and be done with it.

Great bike.

Safe travels,
Craig
__________________
My 2006 950S thread. 2006 950s update
New product updates here! Wordpress BLOG
click www.cjdesignsllc.com for the full line of products. FREE STUFF!!
cjracer is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:29 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014