ADVrider

Go Back   ADVrider > Bikes > GSpot > GS Boxers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-30-2012, 08:20 PM   #1
rocketman1 OP
rocketman1
 
Joined: Aug 2010
Location: NZ
Oddometer: 127
Help- R1150GS front brake- no brake light

Hi I have a 2003 R1150GS, first little problem in 3 years. The front brake will not not make the rear brake light operate.
The rear brake brightens the brake light no problem. All other electrics works fine and bike runs well.
I have traced the wiring back as far as I can from the front brake and cleaned up the first connection.
Has anybody else had this problem? I would like to know where to start .
rocketman1 is offline   Reply With Quote
Old 11-30-2012, 09:07 PM   #2
Mr. Canoehead
Taste Gunnels!
 
Mr. Canoehead's Avatar
 
Joined: Apr 2007
Location: Calgary, Too far to the mountains and too cold
Oddometer: 1,449
Do you have ABS? The brake lights work opposite for ABS/Non-ABS bikes.
__________________
___________________________________________
2006 FJR1300, 2005 GS1150 Adventure, 2002 DR650 SE, a fortune in Farkles.

"No matter how many [internet] opinions you line up, you can't vote nonsense into truth"- Kevin Cameron
Mr. Canoehead is online now   Reply With Quote
Old 12-01-2012, 01:40 AM   #3
Zoef zoef
Gnarly Adventurer
 
Joined: Apr 2009
Location: Finnøy Island, near Stavanger, Norway
Oddometer: 341
Sir,

There is a microswitch near the base of the brake handle. You should also hear that click when you move the handle. When you have the servo ABS, the switch is "normally closed" which is the opposite of normal brake light switches, which are "normally open". If I not mistaken the switch has its connector under the front of the fuel tank.
Zoef zoef is offline   Reply With Quote
Old 12-01-2012, 02:42 AM   #4
sw3dl1
DR Don
 
Joined: Feb 2008
Location: Scottsdale, AZ
Oddometer: 506
Ran into this problem with a 1999 R1100gs, it was the brake light switch. I'm not sure if the 1100 and the 1150 share the same front master cylinder or not, but the brake light switch on the 1100 sits just below and attached to the master cylinder. Over the years, brake fluil had leaked out of the master cylinder bowl and onto the switch. It ate away at the switch until one day, no brake light. Replaced the switch light worked again.
__________________
2007 BMW f650GS
1988 Honda NX650 - X2
1982 Honda GL1100 - X2
sw3dl1 is offline   Reply With Quote
Old 12-01-2012, 02:45 AM   #5
Twilight Error
Going nowhere slowly
 
Twilight Error's Avatar
 
Joined: May 2002
Location: The Submarine Mines
Oddometer: 22,503
Quote:
Originally Posted by Mr. Canoehead View Post
Do you have ABS? The brake lights work opposite for ABS/Non-ABS bikes.
Note: Most 1100 and 1150 models are equipped with ABS from the factory. Versions of ABS vary, but they all route the brake lamp switches through the ABS computer. If you remove the ABS unit, you've also got to rewire the brake switches to activate the lights. BMW uses NC switches.

EDIT: replaced ALL with Most. It took some digging, but I did find indications that I was wrong. The parts fiche shows two FD PNs, one for ABS and one without. Based on that, I've got to assume a non-ABS version was available at some point.
__________________
If you're all about the destination, take a fucking flight.

Twilight Error screwed with this post 12-01-2012 at 03:17 PM
Twilight Error is offline   Reply With Quote
Old 12-01-2012, 03:12 AM   #6
Steptoe
steptoe
 
Steptoe's Avatar
 
Joined: Feb 2004
Location: london, England
Oddometer: 2,477
Quote:
Originally Posted by Twilight Error View Post
Note: All 1100 and 1150 models are equipped with ABS from the factory. Versions of ABS vary, but they all route the brake lamp switches through the ABS computer. If you remove the ABS unit, you've also got to rewire the brake switches to activate the lights. BMW uses NC switches.
This information is completely and absolutely wrong.
The poster is assuming all abs equipped bikes from 1994 up until 2005 are the same. They aren't.
The posters example is relevent ONLY to 1150 bikes equipped with ABS AND SERVO brakes from 2003.
__________________
www.gsshop.co.uk
Steptoe is offline   Reply With Quote
Old 12-01-2012, 10:59 AM   #7
Gezerbike
Hey Rocky...........
 
Gezerbike's Avatar
 
Joined: Jul 2002
Location: Everybody knows this is nowhere......
Oddometer: 3,361
And there was a model called the " Sport " that only came in yellow and it did not haave ABS. And the 1150 used different switchgear than the 1100.
__________________
___________________________________________

Mike

2012 R 1200 GS RALLYE 1997 Suzuki DR 350 SE
Gezerbike is offline   Reply With Quote
Old 12-01-2012, 02:01 PM   #8
Mr. Canoehead
Taste Gunnels!
 
Mr. Canoehead's Avatar
 
Joined: Apr 2007
Location: Calgary, Too far to the mountains and too cold
Oddometer: 1,449
Quote:
Originally Posted by Steptoe View Post
This information is completely and absolutely wrong.
The poster is assuming all abs equipped bikes from 1994 up until 2005 are the same. They aren't.
The posters example is relevent ONLY to 1150 bikes equipped with ABS AND SERVO brakes from 2003.
Yes, I have a friend with a 2004 GSA and no ABS from the factory. I think that if you had a bad switch on a servo bike, you would also have no brakes since (I believe) that the switch is actually what activates the servo.

Since the OP has a 2003, he may or may not have servos but if he has ABS he will have servo brakes..
__________________
___________________________________________
2006 FJR1300, 2005 GS1150 Adventure, 2002 DR650 SE, a fortune in Farkles.

"No matter how many [internet] opinions you line up, you can't vote nonsense into truth"- Kevin Cameron
Mr. Canoehead is online now   Reply With Quote
Old 12-01-2012, 03:01 PM   #9
sidetrack one
Boss STAG
 
sidetrack one's Avatar
 
Joined: Jul 2006
Location: hole shaven area
Oddometer: 4,711
Quote:
Originally Posted by Twilight Error View Post
Note: All 1100 and 1150 models are equipped with ABS from the factory. Versions of ABS vary, but they all route the brake lamp switches through the ABS computer. If you remove the ABS unit, you've also got to rewire the brake switches to activate the lights. BMW uses NC switches.
What a crock of shit!!
The Battle Bike dont got no stinkin' ABS!! and I believe its an 1150!

__________________
I live more in 5 minutes on my motorcycle than some people live in a lifetime...............
I am serious.........and don't call me Shirley!
www.buyabale.com.au.. Our farmers thank you!
sidetrack one is offline   Reply With Quote
Old 12-01-2012, 07:43 PM   #10
dfwscotty
Beastly Adventurer
 
dfwscotty's Avatar
 
Joined: Apr 2006
Location: Denton, TX
Oddometer: 3,185
Stick your ear next to the front brake handle. Squeeze the handle and see if you hear it clicking. My '99 had issues like that. Maybe it would work, maybe it wouldn't. If you don't hear it click then the plunger switch is not fully activating the light.

I was preparing to replace the switch and started to tear into it to see if I could fix it or replace something. I found the microswitch. I sprayed some contact cleaner and soaked it real well. Exercised it well, stuck it back in the bike and haven't had an issue in over a year.
__________________
Traffick911

1999 BMW 1100GS
2012 Kawasaki Concours
dfwscotty is offline   Reply With Quote
Old 12-01-2012, 07:51 PM   #11
rocketman1 OP
rocketman1
 
Joined: Aug 2010
Location: NZ
Oddometer: 127
Fixed it, R1150GS front brake switch

Thanks for your help guys.
I separated the wired connection juntion which is fixed to the frame just below the handle bars on the right hand side.
I checked the resistance to the circuit with my ohm multimeter, and the there was a high resistance ie. 0.50 / 0.60 ohms when operating the handbrake, .should be Zero
I removed the microswitch and wiring from below the front brake master cylinder, then checked the open circuit on the bike with a couple of wires and sure enough the brake light works.
Ichecked the internet and saw that this replacement part was about $60.00. I thought , thats 3 tanks of gas!!
I then decided to pull the wee microswitch apart and clean it up. So I put on my magnification glasses 4x, and if you look very closely you will see that this switch has a little stainless hinged lever, with a very small screw driver lever this clip off, then very carefully use the same jewellers screwdriver to separate the two parts of the switch.
Wow inside is a tiny little spring and a set of contacts. All i did was to get some fine emery paper and sand the contacts which are about half the size of a pinhead, I then squirted it all with CRC cleaner and carefully dried it all.
At this stage before I checked it with my multimeter, sure enough the resistance was Zero.
Fitted it back on the bike, cable tied it all back together and it works perfectly. Zero cost.
This took about two hours to complete, fiddley, but satisfying to fix.
Thanks for your help again.

Cheers
rocketman1 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:34 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014