ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-03-2012, 10:57 AM   #1
Phlox123 OP
n00b
 
Joined: Dec 2012
Oddometer: 1
83 xl250r electric problems

Hi all im new here, dont even know if this is the right place to post my question but here goes

I have recently aquired an old xl250r 1983 model in not a bad shape, i got the engine running again but now im tryin to sort out the electrics, lights and so on, now my questions is this, what should i be looking for when ghe bulbs keep blowing on the bike, cause the lights work when the bike idles but when i crack the throttle just a littel bit it blows the bulb, i only have the headlight bulb connected at the moment, i also dont have a battery connected, dont know if its needs the battery, maybe to act as abuffer or something to keep the voltages at 12v?

I suspect maybe the regulator/rectifier that maybe bad? Any easy way of checking?
Phlox123 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:30 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014