ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-26-2012, 01:43 PM   #1
Cycleman4 OP
Gnarly Adventurer
 
Joined: Jun 2009
Oddometer: 255
Clutch?

While riding this past weekend I thought i felt something strange under acceleration from a stop. felt like it took a second for the clutch to let go completely. Thought it might be wheel spin since I was riding in the dirt. Then on the way home on the tarmac i was in 3rd gear and punched it and again it felt like the RPM's ran up but the speed did not increase quickly like it should. I have never had clutch issues on any other bike so forgive my lack of knowledge. What am I headed for? thanks for your input.
Cycleman4 is offline   Reply With Quote
Old 11-26-2012, 01:50 PM   #2
High Country Herb
Adventure Connoiseur
 
High Country Herb's Avatar
 
Joined: Apr 2011
Location: Western Sierras
Oddometer: 6,617
It does sound like the clutch is slipping. If it is adjustable, losening the cable may fix the problem. I'm guessing yours has a hydraulic clutch, though, which I am not that familiar with. It could be that the plunger is sticking in the clutch master cyclinder or slave cyclinder, or it may need a new clutch.

If you've ever thought about adding a slipper clutch or Rekluse clutch, this could be a good time to do it.
High Country Herb is offline   Reply With Quote
Old 11-26-2012, 01:56 PM   #3
Geek
oot & aboot
 
Geek's Avatar
 
Joined: Jun 2003
Location: 8000ft, Twin Spruce Gap, Colorado
Oddometer: 29,805
The clutch plates/springs are pretty easy to do.. you can swap them in ~20 mins if you know what you are doing (check the HOW if you aren''t familiar - www.ktm950.info ). Mine had been fine for 25,000 miles .. and then one day I decided to ride the bike over Pearl Pass

I ordered my plate/spring kit from CJdesigns and it was at my door two days later



p.s. make sure you properly torque/spec the clutch plate spring bolts so you don't pull a "Qwik"
Geek is offline   Reply With Quote
Old 11-26-2012, 04:19 PM   #4
Cycleman4 OP
Gnarly Adventurer
 
Joined: Jun 2009
Oddometer: 255
Thanks for the info guys. Has anyone used the Barnett clutch rebuild kit?
Cycleman4 is offline   Reply With Quote
Old 11-28-2012, 06:31 AM   #5
Central Cali Rider
Gnarly Adventurer
 
Central Cali Rider's Avatar
 
Joined: Aug 2006
Oddometer: 330
Quote:
Originally Posted by Geek View Post
The clutch plates/springs are pretty easy to do.. you can swap them in ~20 mins if you know what you are doing (check the HOW if you aren''t familiar - www.ktm950.info ). Mine had been fine for 25,000 miles .. and then one day I decided to ride the bike over Pearl Pass

I ordered my plate/spring kit from CJdesigns and it was at my door two days later



p.s. make sure you properly torque/spec the clutch plate spring bolts so you don't pull a "Qwik"
Now that is a clean arse work bench... No beer caps , grease, dirt, extra bolts which weren't needed Bravo
__________________
Central Kali Coast
2005 KTM 950 Adventure
1965 Meyers Manx Dune Buggy
2006 Suzuki SV1000S for wifey Sold !
1997 KLR650 For sale SOLD !!
Central Cali Rider is offline   Reply With Quote
Old 11-28-2012, 07:48 AM   #6
geometrician
let's keep going...
 
geometrician's Avatar
 
Joined: May 2008
Location: West-By-God Virginia
Oddometer: 1,023
Quote:
Originally Posted by High Country Herb View Post
It does sound like the clutch is slipping. If it is adjustable, losening the cable may fix the problem. I'm guessing yours has a hydraulic clutch, though, which I am not that familiar with. It could be that the plunger is sticking in the clutch master cyclinder or slave cyclinder, or it may need a new clutch
another expert lurker working on increasing their post count
__________________
Britt
'06 KTM 950 Adv 'S'
'03 KTM 250 EXC
'87 KLR650 - <200K miles "Like the Energizer Bunny, just keeps going & going..."
geometrician is offline   Reply With Quote
Old 11-29-2012, 06:00 PM   #7
mikeegee
Gnarly Adventurer
 
Joined: Sep 2005
Location: Omaha, and I most definitely know why.
Oddometer: 295
Yeah, I used a Barnett, and all was fine until my oil jet decided to plug up.

All things considered, it couldn't have happened at a better time as I was in the woods behind CJ's house at his big bike weekend extravaganza.

The Barnett comes with a stringer spring, so be prepared for a bit of a stiffer clutch than the stock - which I run now.

It's a perfect time, however, to take a look at the Rekluse. If you've ever thought of it the money you'll spend on new clutch disks will go a long way in that direction. Given the chance, I'd redo my choice for the KTM clutch and get the Rekluse.

Of course, you can also get one of those from CJ.
__________________
meh
mikeegee is offline   Reply With Quote
Old 11-29-2012, 08:06 PM   #8
triplenickel
Beastly Adventurer
 
triplenickel's Avatar
 
Joined: Jul 2008
Location: Campbell River, BC. Fantasy Island
Oddometer: 2,419
Quote:
Originally Posted by geometrician View Post
another expert lurker working on increasing their post count
You don't think it could be the cable?
__________________
07 SE

PG007
"Up there where you eat moose-cock you must all be rockets scientists."
triplenickel is offline   Reply With Quote
Old 11-29-2012, 10:50 PM   #9
gefr
Life is a trip
 
gefr's Avatar
 
Joined: Nov 2005
Location: East Med, Greece
Oddometer: 3,720
I think the clutch booster sometimes plays up.

I believe I have experienced the same with the OP. The clutch kind of slips and then engages completely. Comes and goes I believe. Nothing to worry about. I don't remember being the sign of failed clutch.
Cheers.

gefr screwed with this post 11-30-2012 at 03:12 PM
gefr is offline   Reply With Quote
Old 11-30-2012, 03:15 AM   #10
walstibsf
ADVENTURE-HOLIC
 
walstibsf's Avatar
 
Joined: Jul 2008
Location: Prescott, Arizona
Oddometer: 212
Quote:
Originally Posted by Cycleman4 View Post
While riding this past weekend I thought i felt something strange under acceleration from a stop. felt like it took a second for the clutch to let go completely. Thought it might be wheel spin since I was riding in the dirt. Then on the way home on the tarmac i was in 3rd gear and punched it and again it felt like the RPM's ran up but the speed did not increase quickly like it should. I have never had clutch issues on any other bike so forgive my lack of knowledge. What am I headed for? thanks for your input.
Out of curiosity: How many miles on your bike now? And when was the last time service included cleaning the clutch oil jet?
__________________
W A L S T I B........ S F......................

what a long strange trip it's been......SO FAR......
walstibsf is offline   Reply With Quote
Old 11-30-2012, 03:33 AM   #11
walstibsf
ADVENTURE-HOLIC
 
walstibsf's Avatar
 
Joined: Jul 2008
Location: Prescott, Arizona
Oddometer: 212
Quote:
Originally Posted by Central Cali Rider View Post
Now that is a clean arse work bench... No beer caps , grease, dirt, extra bolts which weren't needed Bravo
Not only that, the granite portion is reserved for more important parts like triple clamps......etc.............
__________________
W A L S T I B........ S F......................

what a long strange trip it's been......SO FAR......
walstibsf is offline   Reply With Quote
Old 11-30-2012, 10:56 AM   #12
Cycleman4 OP
Gnarly Adventurer
 
Joined: Jun 2009
Oddometer: 255
I am going to get into the bike this weekend. I will check the cable and the oil jet. The bike has just under 12k on the clock. Thanks for the ideas.
Cycleman4 is offline   Reply With Quote
Old 11-30-2012, 03:17 PM   #13
gefr
Life is a trip
 
gefr's Avatar
 
Joined: Nov 2005
Location: East Med, Greece
Oddometer: 3,720
Quote:
Originally Posted by Cycleman4 View Post
I will check the cable
The only cables are the throttle cables. Your clutch is hydraulic. They are pulling your leg.
Cheers.
gefr is offline   Reply With Quote
Old 11-30-2012, 05:05 PM   #14
Qwik
Adrenaline Addict
 
Joined: Apr 2008
Location: Sunnyvale, California
Oddometer: 6,069
Quote:
Originally Posted by Geek View Post
p.s. make sure you properly torque/spec the clutch plate spring bolts so you don't pull a "Qwik"


__________________
Speed bumps never seem to make me go any faster
Qwik is offline   Reply With Quote
Old 12-01-2012, 07:46 AM   #15
dlrides
1:1.618
 
dlrides's Avatar
 
Joined: Jul 2005
Location: Newton NC
Oddometer: 5,189
Check clutch booster before replacing clutch.


__________________
"The BSC was to strong in that one, had to get out !"
dlrides is online now   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:34 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014