ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-07-2012, 09:38 AM   #1
disston OP
ShadeTreeExpert
 
disston's Avatar
 
Joined: Mar 2011
Location: Silver Spring, Md
Oddometer: 8,977
Good time to buy A/C tools

Any body know about A/C system leak detectors? I now have a working system on my Crown Victoria except the R134a leaks out. I'm willing to buy a leak detector but do not know which one will be right. Should I just get the stuff for injecting dye or a $250 leak detector? They throw around some terms I'm not familiar with. "Heated Probe", "Maintenance Kit", "Pump style probe".

I have most all the A/C tools needed but do not know which leak detector to get. I'd like to have one that works, professional quality preferred.
__________________
.
Never memorize something you can look up.
---Albert Einstein

Pay your debt, piratejohn.http://www.advrider.com/forums/showthread.php?t=949341
disston is offline   Reply With Quote
Old 12-07-2012, 10:08 AM   #2
OldPete
Be aware
 
OldPete's Avatar
 
Joined: Oct 2007
Location: Los Alamitos, CA
Oddometer: 4,698
I gotta halogen leak detector with pump tucked away that hasn't been used in 20 years.

Takes a 9v battery and the better ones come with a spare sensor for the probe as contamination will cause false reads.

Bought it from the MAC Tool man for cheap iirc.
OldPete is offline   Reply With Quote
Old 12-07-2012, 10:26 AM   #3
Benesesso
Beastly Adventurer
 
Benesesso's Avatar
 
Joined: Jul 2008
Location: West of Phoenix, Arizona
Oddometer: 9,898
Use fluorescent dye and a black UV light.
__________________
US out of the UN, UN out of the US.
Benesesso is offline   Reply With Quote
Old 12-07-2012, 10:38 AM   #4
disston OP
ShadeTreeExpert
 
disston's Avatar
 
Joined: Mar 2011
Location: Silver Spring, Md
Oddometer: 8,977
I still own a Halogen detector that I bought 30 years ago. It works with a propane bottle. I left it at the restaurant I used to work at and the guy owns the restaurant says he still uses it. I could never get the thing to work unless I held the flame in front of a full bottle of Freon and cracked the tap to open.

I think Benesesso you may be right.

But I still want a cute little electronics one.
__________________
.
Never memorize something you can look up.
---Albert Einstein

Pay your debt, piratejohn.http://www.advrider.com/forums/showthread.php?t=949341
disston is offline   Reply With Quote
Old 12-07-2012, 10:43 AM   #5
Benesesso
Beastly Adventurer
 
Benesesso's Avatar
 
Joined: Jul 2008
Location: West of Phoenix, Arizona
Oddometer: 9,898
Quote:
Originally Posted by disston View Post
I still own a Halogen detector that I bought 30 years ago. It works with a propane bottle. I left it at the restaurant I used to work at and the guy owns the restaurant says he still uses it. I could never get the thing to work unless I held the flame in front of a full bottle of Freon and cracked the tap to open.

I think Benesesso you may be right.

But I still want a cute little electronics one.
I have one of them too. It works, but it will detect the smallest amount of R12 (never used it for 134) and drive you nuts.
__________________
US out of the UN, UN out of the US.
Benesesso is offline   Reply With Quote
Old 12-07-2012, 10:43 AM   #6
D.T.
One wheel wonder...
 
D.T.'s Avatar
 
Joined: Aug 2004
Location: Moneyapolis, MN
Oddometer: 10,344
How about soap solution? Cheap.
__________________
Quote:
Originally posted by burgerking So?
Holland is about the most expensive country in Europe when it comes to bikes and fuel..Stop whining and go riding It's just money and you only live once...
D.T. is online now   Reply With Quote
Old 12-07-2012, 10:53 AM   #7
1greenmachine
Studly Adventurer
 
Joined: Aug 2010
Location: green bay, wi
Oddometer: 685
I've found the dye works the best, or pressurise the system and use soap because the ac sniffers are a joke.
1greenmachine is offline   Reply With Quote
Old 12-07-2012, 10:58 AM   #8
disston OP
ShadeTreeExpert
 
disston's Avatar
 
Joined: Mar 2011
Location: Silver Spring, Md
Oddometer: 8,977
I have used soap solutions many times at the restaurant I used to work at. Doesn't work as good in cars though because so much is not so easy to reach. I even have a bottle of special A/C Guy soap called "Big Blue". I was in an A/C club a couple years ago but because I don't do this stuff with any regularity I'm just not in it any more. Those guys really don't like talking to ametuers.

They also insist that you put r134a or any gas in in liquid form instead of right side up gaseous form.

I'll think on it a couple days. I think the dye system and maybe a cheapo modern leak detector. There are some around $50 and better ones are only $120.
__________________
.
Never memorize something you can look up.
---Albert Einstein

Pay your debt, piratejohn.http://www.advrider.com/forums/showthread.php?t=949341
disston is offline   Reply With Quote
Old 12-07-2012, 11:40 AM   #9
Motomantra
Registered Lurker
 
Motomantra's Avatar
 
Joined: Mar 2008
Location: Beaverton, OR
Oddometer: 1,235
Before you do anything

Do as complete of a visual as you can. Look for a dirty, oily spot somewhere. You may get lucky with just a flash light.
I've used several types of sniffers & found them to be hit & miss. That was ten years ago. Maybe they're better, now?
__________________
For those that fight for it, freedom has a flavor the protected will never know.
Motomantra is offline   Reply With Quote
Old 12-07-2012, 11:54 AM   #10
ttpete
Rectum Non Bustibus
 
Joined: May 2009
Location: Dearborn, MI
Oddometer: 5,679
You want to be careful with the halide leak detector torches. Freon + flame = phosgene. Use them in a well ventilated area. And never smoke around refrigerant for the same reason.
__________________
15 BMW RnineT
10 Ducati 1098 Streetfighter S - "Sleipnir"
09 Kaw Versys
67 Triumph Bonneville TT Special
ttpete is offline   Reply With Quote
Old 12-07-2012, 12:49 PM   #11
Stan_R80/7
Beastly Gnarly
 
Stan_R80/7's Avatar
 
Joined: May 2012
Location: VA
Oddometer: 1,277
If you can't see the oil from the leak spot - that means it is leaking where you cannot see. A leak detector will have a hard time locating a leak you cannot access. This becomes a circular argument with time.

Virtually all refrigerant leaks are in the evaporator. Why? Because that is the wet area prone to corrosion. The evaporator is under the dash in a spot that takes ~ 10 hours to disassemble. Then a new evaporator can be purchased from the dealer.

Other leaks (not in the evaporator) can be spotted by looking for oil. They also make an oil that fluoresces under black (UV) light that is added into the system. But, if the leak is where you can see, the oil from the leak is obvious.

But, I never want to be accused of stopping someone from buying a new toy. If you want a freon leak detector, expect to pay ~150.00 (new) for one that is a decent instrument. If you insist on paying less, make sure you can return the instrument that does not work as intended in a reasonable amount of time.

My (free) advise: buy some R134a with leak stop and add a couple of cans. If that works, buy a case of R134a at a discount price and add some when needed. Good luck!
Stan_R80/7 is offline   Reply With Quote
Old 12-07-2012, 02:32 PM   #12
urbanXJ
Beastly Adventurer
 
urbanXJ's Avatar
 
Joined: Aug 2008
Location: Houston, TX
Oddometer: 3,031
Here is what happened to me.

Mine was leaking, couldn't find the leak.

I tried the dye, no luck except I kept noticing a bunch of the dye in the cap on the low pressure service port.

I changed the schrader valve in the port (just like what is in a tire stem) and it fixed the leak.

Dealer had previously quoted me over 1k to replace the whole assembly.

So consider that it could be leaking out of where you add the freon...

just my .02

PS a new valve was $8 and the tool to chage it was 5 or 10. The pressure blew the first valve off the tool and I lost it, so I had to buy a second.
__________________
...SPEEDING PAST THE LINE OF GOOD TASTE...
urbanXJ is offline   Reply With Quote
Old 12-07-2012, 03:35 PM   #13
disston OP
ShadeTreeExpert
 
disston's Avatar
 
Joined: Mar 2011
Location: Silver Spring, Md
Oddometer: 8,977
To get the evaporator out of a '90's Crown Vic is probably more than ten hours by the book.

Yeah, I changed one of the Schrader valves back when the accumulator was new.

I have looked for oil leaks. I have found bad hoses this way. I did change all seals when I rebuilt the system 2 years ago. It was a new compressor, new condenser, new dryer/accumulator, newer used hoses (washed) So I don't see any oil leaks and I also suspect the evaporator.

I have a Robinair Vacuum Pump. A MasterCool Scale. Good Gauges, never used on anything but R134a.

Last year it needed charging at the beginning of Summer. Now the leak is so bad that ALL the gas is gone this year.

I'll put some gas in it from the 30 lb can I have and see if I can find the leak.

Quit Smoking.
__________________
.
Never memorize something you can look up.
---Albert Einstein

Pay your debt, piratejohn.http://www.advrider.com/forums/showthread.php?t=949341
disston is offline   Reply With Quote
Old 12-07-2012, 04:47 PM   #14
Wasser
Spilt my beer
 
Wasser's Avatar
 
Joined: Oct 2009
Location: Colorado
Oddometer: 4,781
As was suggested elsewhere, look for dirt/oil accumulations around connections.

Seeing as this is an older Ford, I'd almost be willing to bet just about every spring lock- hose coupling is leaking (o-rings) I used to make a fortune re-sealing Ford AC couplings. Econoline vans where the best, got about 5-6 hrs+ for leak test, reclaim, reseal every fitting & re-charge. It was always the o-rings on the spring lock connections. Almost never saw a compressor or evaporator on a Ford.

If it was a GM, it was almost always the front compressor shaft seal.

If it was a Chrysler, it was an evaporator. Chrysler couldn't source a good evaporator manufacturer to save their ars. Even the new replacement evaporators from the parts dept leaked.

You can usually get a complete seal kit from Ford that has every O-ring for every coupler. You just need the spring lock disconnect tools. LINKY You can probably get them from Harbor Freight as well.

You might try the local auto parts store and see if they rent an electronic leak detector. Save your coin for the repair parts & re-charge.

Clean the fittings first with some brake clean & compressed air before you use the spring release tool. Makes life easier. Pick up a small bottle of PAG oil to lube the new O-rings and hose couplings on install.
Wasser is offline   Reply With Quote
Old 12-07-2012, 04:58 PM   #15
Stan_R80/7
Beastly Gnarly
 
Stan_R80/7's Avatar
 
Joined: May 2012
Location: VA
Oddometer: 1,277
Just to point out the obvious (or maybe not so obvious), they did not start putting R134a into US cars until 1996. If the evaporator is for R12, it may leak at the higher pressures for R134a. Reducing the system charge (by ~ 80%) is the number used in conversion kits. I know this from converting my 92 GMC truck this summer.

Back in the late 90's - and even today - there was much confusion on oils, freons, mineral oil, PAG oils, Ester oils, and how (if at all) they would work together. The kit I used this summer cost $50.00 and had oil and R134a. I pulled a vacuum on the system (using a RobinAir vacuum pump with a R12 gauge set), added the kit to 80% R12 charge, and ta-da. Cold AC. I expect there is a small leak in the truck evaporator - but can live with that.

Thinking about this, the difference in pressure between R12 and R134a in the evaporator should not be that much. But, once fluid has leaked out the evaporator pressure will rise. So a small leak starts small and appears to get bigger. Then again, maybe none of this applies to your Crown Vic.
Stan_R80/7 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:05 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014